+ Responder ao Tópico



  1. #1
    tux-lol
    Visitante

    Padrão Problema com LVM, PV e VG, alguem me ajuda?

    Olá galera do underlinux, estou com um pequeno problema, e queria que me tirassem algumas duvidas.
    A situação é a seguinte: eu tenho um servidor linux com 2 hds, anteriormente eles estavam usando o raid de espelhamento pela propria placa-mãe, mas eu tirei ( ou pelo menos tentei ) essa funcionalidade, pra poder ficar com mais espaço no hd.
    agora o meu servidor red hat é startado ele dá um erro de " Found duplicate PV 7NTXTV7a6zVh4AJ0L8BQBur3vPFrVox5: using /dev/cciss/c1d1p2 not /dev/cciss/c1d0p2 ". Ou seja, pelo que eu entendi, só estou conseguindo usar um hd,pois o boot tá fazendo a chamada de um volume logico, e como os 2 hds estão com o mesmo nome e as mesmas informações, o boot chama por um nome e os dois respondem, sendo que é utilizado somente um dos 2.
    minhas duvidas:
    alguem sabe o q eu posso fazer pra criar uma chamada para utilizar o outro hd?
    O que eu faço pra poder utilizar os 2 hds? só formatando ou tem alguma configuração que eu possa fazer??
    Se eu apagar o volume logico eu perco todos os dados :? :?

    Agradeço desde já.

  2. #2

    Padrão Re: Problema com LVM, PV e VG, alguem me ajuda?

    Bem pelo que entendi você estava com 2 hds espelhados, só que deseja usar o disco em que fazia de espelho e usa-lo normalmente!

    Se foi isso que entendi você está dando boot em um dos discos! se sim formate o outro criando novas PV's e processando e organizando da forma que desejar.



  3. #3
    tux-lol
    Visitante

    Padrão Re: Problema com LVM, PV e VG, alguem me ajuda?

    hmm... vlws pela ajuda, mas será que n tem outro jeito de fazer sem formatar não!?!?
    []'s

  4. #4

    Padrão Re: Problema com LVM, PV e VG, alguem me ajuda?

    Porque não quer formatar o outro disco? ele não será o disco de expansão para o seus VG's?
    Você tem um disco redundante ai com você. o que quer com com esses dados redundantes?
    :?



  5. #5
    tux-lol
    Visitante

    Padrão Re: Problema com LVM, PV e VG, alguem me ajuda?

    eh... acho que o jeito eh formatar, mais soh mais uma duvida, no erro tah dando "Found duplicate PV 7NTXTV7a6zVh4AJ0L8BQBur3vPFrVox5: using /dev/cciss/c1d1p2 not /dev/cciss/c1d0p2", eu pensei que ele estava yusando o c1d1p2 e n o c1d0p2, mas qdo eu dou comandos pra ver o pv ou vg, ele mostra informações do c1d0p2, resumindo, o qe eu tenh q formatar eh o c1d1p2 certo??

    vlws pela ajuda chacara :wink:

  6. #6

    Padrão Re: Problema com LVM, PV e VG, alguem me ajuda?

    Se ele mostra as informações do "c1d0p2" ele está usando o mesmo! mas para que não haja nenhum tipo de problema seria no seu caso extremamente aconcelhavel desligar a unidade em que se encontra o "c1d1p2" e dar um re-boot no sistema.
    E ter a certeza de que o seu sistema vá funcionar corretamente observando se todos os dados estão presentes e todos os serviços estão funcionando. Feito isso re-ligue a unidade e a formate.

    Para que não ocorra nenhuma surpresa desagradavel você poderia postar o seu fstab. Para se ter certeza que se usava somente "raid-1" no disco "c1d1p2".

    É um prazer lhe ser util.



  7. #7
    tux-lol
    Visitante

    Padrão Re: Problema com LVM, PV e VG, alguem me ajuda?

    opa,
    vlw mesmo pela ajuda que vcs estão me dando, o fstab está assim:
    eu tou axando que ele tah xamando o logvol00 e como as partições dos 2 h.ds estão com os mesmos nms, ele chama os 2 por isso que tá dando erro.
    o que vcs acham?!?

    # This file is edited by fstab-sync - see 'man fstab-sync' for details
    /dev/VolGroup00/LogVol00 / ext3 defaults 1 1
    LABEL=/boot /boot ext3 defaults 1 2
    none /dev/pts devpts gid=5,mode=620 0 0
    none /dev/shm tmpfs defaults 0 0
    none /proc proc defaults 0 0
    none /sys sysfs defaults 0 0
    /dev/VolGroup00/LogVol01 swap swap defaults 0 0
    /dev/hda /media/cdrecorder auto pamconsole,fscontext=system_ubject_r:removable_t,exec,noauto,managed 0 0

  8. #8

    Padrão Re: Problema com LVM, PV e VG, alguem me ajuda?

    Você pode fazer o seguinte também, de um pvscan e veja a device que o seu pv usa e em que vg ele esta.
    Observe o espaço livre do pv e anote, depois copie um arquivo grande ex: 1G e veja em qual pv o espaço foi subtraido, assim você vai saber a device o pv e o vg que você esta trabalhando realmente :-D



  9. #9
    tux-lol
    Visitante

    Padrão Re: Problema com LVM, PV e VG, alguem me ajuda?

    ehehhehe
    tá usando o c1d0p2 mesmo, eu dei um pvscan, transferi os dados, e conferi de novo, eh nele que estão sendo guardados os meus dados.
    =D
    vou formatar o servidor hj de noite
    o segundo h.d ^^

  10. #10

    Padrão Re: Problema com LVM, PV e VG, alguem me ajuda?

    OK! Simples né!
    Qualquer dúvida é só mandar mensagem ou poste novamente.
    Abraço.



  11. #11
    tux-lol
    Visitante

    Padrão Re: Problema com LVM, PV e VG, alguem me ajuda?

    vlws pela ajuda charadaa!!!
    tah funcionando td aki :-D

  12. #12
    tux-lol
    Visitante

    Padrão Re: Problema com LVM, PV e VG, alguem me ajuda?

    ops
    desculpa a gafe!!
    Eu tenho agradecer imensamente eh ao CHACARAAA!! :wink:
    Vlews msm cara!! :-D



  13. #13

    Padrão Re: Problema com LVM, PV e VG, alguem me ajuda?

    Charada foi muito legal! (risos) :-D :-D :-D
    Disponha amigo quando precisar é só chamar!