+ Responder ao Tópico



  1. Ele faz o compartilhamento normal, apenas quando peço pra fazer o proxy transparente que nao navega. Mesmo quando nao é transparente e aponto po proxy nao navega.

  2. alguém ?



  3. Confirmando:

    01)No firewall:
    iptables -A INPUT -i $if_lan -s 192.168.10.0/24 -p tcp --dport 3128 -j ACCEPT
    iptables -t nat -A PREROUTING -i $if_lan -d 0/0 -p tcp --dport 80 -j REDIRECT --to-port 3128
    iptables -t nat -A POSTROUTING -s 192.168.10.0/24 -j MASQUERADE
    Onde: $if_lan é declarado com a interface conectada na rede local. Ex: eth0

    02) No squid.conf a porta setada é 3128?
    03) Configurando o proxy manualmente nos clientes ele navega?
    04) Se tentar navegar diretamente com o ip do site ao inves do nome vai? Ex: http://200.221.2.45/
    05) Configurou o redirecionamento de pacotes?

  4. #LIBERA A ACESSO A PORTA 3128

    $IPTABLES -A INPUT -d 192.168.10.254 -p tcp --dport 3128 -j ACCEPT
    $IPTABLES -A INPUT -d 192.168.12.30 -p tcp --dport 3128 -j ACCEPT


    ##############################
    ## NAT E TRANSPARENT PROXY ##
    ##############################
    # TRANSPARENT PROXY
    $IPTABLES -t nat -A PREROUTING -i eth1 -d ! 200.189.214.0/24 -p tcp --dport 80 -j REDIRECT --to-port 3128
    $IPTABLES -t nat -A PREROUTING -i eth2 -d ! 200.189.214.0/24 -p tcp --dport 80 -j REDIRECT --to-port 3128


    ###
    ### NAT GERAL
    ###

    $IPTABLES -t nat -A POSTROUTING -o eth2 -s 192.168.10.0/24 -j SNAT --to 192.168.10.254
    $IPTABLES -t nat -A POSTROUTING -o eth1 -s 192.168.12./27 -j SNAT --to 192.168.12.30
    ###
    ### NAT SO PARA HOSTS LIBERADOS
    ###
    if [ -f $HOSTS_LIBERADOS ] ; then
    for i in `cat $HOSTS_LIBERADOS` ; do
    $IPTABLES -t nat -A POSTROUTING -s $i -j SNAT --to $IP_IF_EXT
    $IPTABLES -t nat -A POSTROUTING -o $IF_EXT -s $i -j SNAT --to 192.168.10.254
    $IPTABLES -t nat -A POSTROUTING -o $IF_EXT -s $i -j SNAT --to 192.168.11.254
    $IPTABLES -t nat -A POSTROUTING -o $IF_EXT -s $i -j SNAT --to 192.168.12.30


    done;
    else
    echo "ARQUIVO $CAMINHO_BASE hosts_liberados NAO ENCONTRADO"
    fi;

    A NAT FUNCIONA SEM PROBLEMA ... NAVEGA BLZ , MENOS QUANDO INICIO O SQUID.



  5. Alguém ... ?






Tópicos Similares

  1. Problemas no Squid, 'Memory pools are 'off'; limit: 2.00 MB'
    Por H_Franzin no fórum Servidores de Rede
    Respostas: 3
    Último Post: 31-03-2005, 15:07
  2. Amigos estou com sérios problemas no squid(RunCache)
    Por bandlinux no fórum Servidores de Rede
    Respostas: 1
    Último Post: 04-03-2005, 06:07
  3. Problemas no Squid com firewall
    Por Dick_Vigarista no fórum Servidores de Rede
    Respostas: 4
    Último Post: 03-11-2003, 15:09
  4. Problemas no squid com a porta 8088
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 17-02-2003, 08:42
  5. problemas no squid
    Por roggy no fórum Servidores de Rede
    Respostas: 2
    Último Post: 25-09-2002, 15:12

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L