+ Responder ao Tópico



  1. #1

    Padrão Compartilhar internet

    Bem é muito ´facil mas ta dando uma dor de cabeça enorme; Aqui tenho um provedor funcionando blz o problema começou com o seguinte e gostaria de mostrar o que ta estranho. Em uma empresa implementei o Red Hat 9 recebendo o meu sinal via wireless e coloquei as outras máquinas para acessarem ele. O red hat na eth0 tem ip válido e eth1 invalido. Coloquei primeiramente os ips
    eth0 = 200.222.6.XXX gw 201.59.X.XXX
    eth1 = 192.168.0.254

    coloquei no script inicialmente o seguinte
    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -o eth0 -j MASQUERADE

    Depois iria colocar o restante do firewall, mas primeiramente queria fazer os testes
    nos clientes coloco
    ip 192.168.0.X
    Masc 255.255.255.0
    GW 192.168.0.1
    DNS 201.59.X.XXX

    Mas eles não navegam por nada o engraçado é que se eu pingar por ip valido vai, mas por nome não, estranho uma vez que não vejo nada de errado, o restante do firewall seriam regras de segurança ..... mas fiz o teste como está aqui e nada, o que pode ser? Iria tambem implementar o squid mas isso ainda nem tentei.

  2. #2

    Padrão Re: Compartilhar internet

    Opa,
    se o ip do RH é 192.168.0.254, por que o GW dos clientes é 192.168.0.1 ?? dessa forma eles não vão navegar mesmo, altere a rota (GW) dos clientes para 192.168.0.254, o IP do RH.
    Agora pelo fato de não resolver nomes, certifique-se que seu servidores DNS estão corretos.



  3. #3

    Padrão Re: Compartilhar internet

    Citação Postado originalmente por hrober
    Opa,
    se o ip do RH é 192.168.0.254, por que o GW dos clientes é 192.168.0.1 ?? dessa forma eles não vão navegar mesmo, altere a rota (GW) dos clientes para 192.168.0.254, o IP do RH.
    Agora pelo fato de não resolver nomes, certifique-se que seu servidores DNS estão corretos.
    Desculpe, escrevi errado o gw é 192.168.0.254 e no caso de resolver nomes, no RH navego normalmente, o que acho estranho e nos terminais pingo por ip e se eu colocar o ip no campo url não abre nada, estranho demais e quanto ao DNS tá tudo certo o que me deixa mais cabreiro, tenho de utilizar o route add eth0 default gw?

  4. #4

    Padrão Re: Compartilhar internet

    Ops e ai amigo, muito estranho isso heim mais aki consegui fazer essa conf. sem problema so uma dica toda a conf. da sua rede tem que ser configurada na eth0 os clientes vão usar o gw da placa eth0 e o DNS do seu provedor... qualquer coisa da uma olhada nesse artigo achu que explicar melhor:

    http://www.vivaolinux.com.br/artigos....php?codigo=57

    Espero ter ajudado!!!

    .:: bA



  5. #5
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão Re: Compartilhar internet

    De fato, creio que seu problema seja o DNS, como esta seu resolv.conf?

  6. #6

    Padrão Re: Compartilhar internet

    Código :
    eth0 = 200.222.6.XXX gw 201.59.X.XXX

    IP e gateway precisam estar na mesma subrede...




  7. #7
    Fernando Henrique
    Visitante

    Padrão Re: Compartilhar internet

    aqui nao deu certo