Página 4 de 4 PrimeiroPrimeiro 1234
+ Responder ao Tópico



  1. #16
    fagundao
    Voltando ao meu problema inicial...

    Bom eu tive uma ideia mas não sei ainda como executa-la! rsrsr

    Pensei o seguinte:
    Existe alguma maneira de encaminhar todos os pacotes destinados a porta 80 para uma determinada conexão?
    Pensei que se conseguir identificar tudo que é para porta 80 e puder direciona-lo para minha conexão VPN faria com que todo o trafego da Internet fosse pela minha VPN e assim resolveria meu problema.

    Ate agora so consigo direcionar todos os pacotes para uma determinada rede.
    Gostaria de direcionar um determinado pacote para qualquer rede - no Linux usando o iptables acredito que tem como fazer essa diferenciação mas no windows q e fogo!!!

    abraços


  2. Galera, estou de volta. Testei hoje o OpenVPN, com a solução que adotei. Ou seja, instalei o OpenVPN e funcionou perfeitinho. Instalei NFS e Samba, na filial e tudo ok. Vi do outro lado no ambiente de rede o que era esperado. Abri arquivo do outro lado usando utilitário da M$. Mas agora estou me debatendo com um probleminha do qual eu já instalei várias vezes e nunca aconteceu isso. Eu carrego o Squid para compartilhar a internet com os pc´s na rede da filial, e vendo o log do Squid está tudo perfeito. Todas as mensagens de boot do Squid aparecem normais. Não dá o menor erro. Mas não pingo para fora. Pingo até o modem. Um Dlink 500G em router. Já entrei no modem e está tudo normal. Aliásmente fiz testes várias vezes no ambiente windows (e lá vem comparação novamente com a M$) e está normal. Só não consegui entender porque o Squid não libera o acesso a internet para os usuários da rede da filial. No resto o OpenVPN está funcionando normal. Estou usando um K6-II 500 e confesso que a maquininha quando liguei na filial está dando uma série de problemas. Desliga sózinha sem mais e sem menos. O teclado para de funcionar sem nenhum motivo aparente. Eu creio que o problema está na máquina. Peguei alguns tutoriais hoje, do Underlinux, do Vivaolinux para conferir se tinha alguma configuração errada no Squid. Não tinha. Olhei o firewall e também nada. Aliásmente, gostaria até de perguntar ao pessoal aqui. No arquivo /etc/rc.d/rc.local eu carrego o Squid primeiro e depois o OpenVPN. Essa ordem tem alguma coisa a ver ? Mas alguma coisa me diz que o problema está mais no pc que é muito antigo. Mas de qualquer forma eu tive progressos. Estou usando o OpenVPN 1.6 e ele está funcionando legal. Mas o compartilhamento da internet via Squid não vai mesmo. Vou trocar amanhã placa de rede, aumentar memória e ver no que dá. Mas não entendi o porque do Squid não compartilhar a internet e vendo no log do Squid carregando tudo normal. Uma placa de rede é uma 3Com e está abrindo o túnel normal do OpenVPN. E a outra uma Realtek 8139c que pinga nas estações.
    Mas, volto aqui para falar sobre essa nova experiência na instalação da VPN.
    Um grande abraço a todos aqui nesse tópico. Bom é que esse tema está se desenvolvendo de uma forma bem madura por todos que estão participando.
    Qualquer novidade posto aqui. E se alguém aqui que está participando desse tópico puder me dar alguma dica, fico grato.
    Que Deus abençõe a nós todos ............ :-)




  3. Fagundao, boa noite ou bom dia. Afinal passou da meia noite. Meia noite e 3 minutos, hehehe
    Mas vamos lá. Estive pesquisando no google sobre iptables e imagino até que você deve ter pesquisado alguma coisa.
    Mas dê uma olhadinha em :

    http://focalinux.cipsga.org.br/guia/...w-iptables.htm

    http://www.tccamargo.com/linux/tutoriais/iptables.html

    http://www.eriberto.pro.br/iptables/

    Eu considero esse último um tutorial muito bom sobre Iptables.

    Pelo que você deseja fazer, eu creio que tem solução sim.

    Afinal nós da área de informática, e principalmente fuçadores de Linux, sempre encontramos algum caminho. E temos muita ajuda aqui no Underlinux.

    Um forte abraço ............ :-)

    Dê uma olhadinha nesses links e veja se pode te dar alguma luz ..... :-)






Tópicos Similares

  1. openvpn
    Por adenilosn no fórum Servidores de Rede
    Respostas: 1
    Último Post: 29-06-2004, 04:45
  2. openvpn & named
    Por cantisan no fórum Servidores de Rede
    Respostas: 2
    Último Post: 10-06-2004, 18:34
  3. OpenVPN
    Por pssgyn no fórum Servidores de Rede
    Respostas: 3
    Último Post: 16-02-2004, 09:39
  4. Freeswan ou OpenVPN ???
    Por pssgyn no fórum Servidores de Rede
    Respostas: 0
    Último Post: 22-01-2004, 23:42
  5. OpenVpn x FreesWan no Conectiva 8
    Por pssgyn no fórum Servidores de Rede
    Respostas: 0
    Último Post: 14-01-2004, 20:58

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L