+ Responder ao Tópico



  1. #1

    Padrão Dividir Clientes em dois Rádios

    Amigos é o seguinte, como todos sabem uso cartão pcmcia no mikrotik, fornecendo por dhcp para meus clientes, agora que aumentou a carga quero instalar outro cartão e mais uma placa de rede, recebendo um outro link, e preciso dividir metade dos clientes em um cartão, no link 1, e a outra metade em outro cartão, no link 02, sem problema se forem com faixas de ips diferentes os dois cartões, o que eu preciso é que um cartão busque a net em uma linha, e o outro em outra linha, no mesmo mik, alguém sabe fazer ?

  2. #2

    Padrão Re: Dividir Clientes em dois Rádios

    Cara, posso tá falando besteira mas no seu caso parece ser simples veja só.

    Você tem 100 clientes, supomos.

    50 clientes na faixa de ip 192.168.10.0/24 e uma regra de masquerade jogando para a placa de rede 1, ou seja link 1.

    Os outros 50 estarão na faixa de ip 192.168.20.0/24 e uma regra de masquerade jogando para a placa de 2, ou seja o link 2.

    Tipo assim: Source IP 192.168.10.0/24 >>>> Placa de Rede 1 (Masquerade)
    Source IP 192.168.20.0/24 >>>> Placa de Rede 2 (Masquerade)

    Penso eu, dentro dos meus limites de conhecimento com MK, que comecei tem uns meses, que isso deva funcionar.

    Abraços




  3. #3

    Padrão Re: Dividir Clientes em dois Rádios

    Caro Wagner, vc ta querendo fazer isso pra usar 2 link??? se for nao é melhor fazer o load balance???
    desse seu mk, sai 2 link ptp? pq senao, vc nao precisa fazer isso nessa maquina, e sim no seu gateway
    posta ai oq vc quer fazer
    []´s Bene

  4. #4

    Padrão Re: Dividir Clientes em dois Rádios

    Citação Postado originalmente por benematos
    Caro Wagner, vc ta querendo fazer isso pra usar 2 link??? se for nao é melhor fazer o load balance???
    desse seu mk, sai 2 link ptp? pq senao, vc nao precisa fazer isso nessa maquina, e sim no seu gateway
    posta ai oq vc quer fazer
    []´s Bene
    amigo, na realidade o load balance seria a opção mais técnica, mais por falta de conhecimento não to tendo tempo de fazer agora, preciso de uma solução rápida, por isso a idéia de dividir os clientes.



  5. #5

    Padrão Re: Dividir Clientes em dois Rádios

    Citação Postado originalmente por alamdias
    Cara, posso tá falando besteira mas no seu caso parece ser simples veja só.

    Você tem 100 clientes, supomos.

    50 clientes na faixa de ip 192.168.10.0/24 e uma regra de masquerade jogando para a placa de rede 1, ou seja link 1.

    Os outros 50 estarão na faixa de ip 192.168.20.0/24 e uma regra de masquerade jogando para a placa de 2, ou seja o link 2.

    Tipo assim: Source IP 192.168.10.0/24 >>>> Placa de Rede 1 (Masquerade)
    Source IP 192.168.20.0/24 >>>> Placa de Rede 2 (Masquerade)

    Penso eu, dentro dos meus limites de conhecimento com MK, que comecei tem uns meses, que isso deva funcionar.

    Abraços

    Certo, levando em conta que eu não tenho tempo pra estudar o loadbalance, pq meus cliente estão no pé, como dividir.
    criei aqui, duas conexões pppoe cliente, todas duas discam e altenticam, mais quando eu to conectado no radio, ele navega com qualquer uma das conexões pppoe ativadas, e isso não poderia, tem que conectar quando apenas a conexão dele está conectada, alguém sabe fazer isso ?

  6. #6

    Padrão Re: Dividir Clientes em dois Rádios

    Nao entendo muito de PPPoE, mas pelo que percebi, nao adianta vc ter 2 servidores na mesma maquina pq sempre pega o primeiro que acha na rede.... tem uma ideia que ja foi postada aki, mas nunca testei e pode ser que funcione sim, vc criar 2 regras de nat, uma para cada cartao/ether e nao criar bridge entre elas, tenta e posta ai

    []'s Bene



  7. #7

    Padrão Re: Dividir Clientes em dois Rádios

    Citação Postado originalmente por benematos
    Nao entendo muito de PPPoE, mas pelo que percebi, nao adianta vc ter 2 servidores na mesma maquina pq sempre pega o primeiro que acha na rede.... tem uma ideia que ja foi postada aki, mas nunca testei e pode ser que funcione sim, vc criar 2 regras de nat, uma para cada cartao/ether e nao criar bridge entre elas, tenta e posta ai

    []'s Bene
    Andei mesmo dando uma olhada nas regra de nat, mais não consegui...

  8. #8

    Padrão Re: Dividir Clientes em dois Rádios

    Wagner,
    Voce terá que fazer um load balance sim. Eu fiz um prum cliente meu dessa fora:

    clientes com ip 10.10.0.1 até 10.10.0.127 --> acessam o link 01
    clientes com ip acima de 10.10.0.128 -- >acessam o link 02

    funciona 100% sem problemas com msn e tal....




  9. #9

    Padrão Re: Dividir Clientes em dois Rádios

    Citação Postado originalmente por rps67
    Wagner,
    Voce terá que fazer um load balance sim. Eu fiz um prum cliente meu dessa fora:

    clientes com ip 10.10.0.1 até 10.10.0.127 --> acessam o link 01
    clientes com ip acima de 10.10.0.128 -- >acessam o link 02

    funciona 100% sem problemas com msn e tal....

    Amigo, posta ai as configurações pra que eu possa fazer por favor...

  10. #10

    Padrão Re: Dividir Clientes em dois Rádios

    Citação Postado originalmente por rps67
    Wagner,
    Voce terá que fazer um load balance sim. Eu fiz um prum cliente meu dessa fora:

    clientes com ip 10.10.0.1 até 10.10.0.127 --> acessam o link 01
    clientes com ip acima de 10.10.0.128 -- >acessam o link 02

    funciona 100% sem problemas com msn e tal....

    Posta ai a solução por favor



  11. #11

    Padrão Re: Dividir Clientes em dois Rádios

    Wagner desculpe a demora ai, tu vai precisar fazer isso aqui para funcionar :
    ================================================
    [[email protected]] ip firewall mangle> print
    Flags: X - disabled, I - invalid, D - dynamic
    0 chain=prerouting src-address=192.168.0.0/24 action=mark-routing
    new-routing-mark=net1

    1 chain=prerouting src-address=192.168.1.0/24 action=mark-routing
    new-routing-mark=net2
    ================================================
    ================================================
    [[email protected]] ip route> add gateway=10.0.0.2 routing-mark=net1 \
    \... check-gateway=ping
    [[email protected]] ip route> add gateway=10.0.0.3 routing-mark=net2 \
    \... check-gateway=ping
    [[email protected]] ip route> print
    Flags: X - disabled, A - active, D - dynamic,
    C - connect, S - static, r - rip, b - bgp, o - ospf
    # DST-ADDRESS PREFSRC G GATEWAY DISTANCE INTERFACE
    0 ADC 10.0.0.0/24 10.0.0.7 Public
    1 ADC 192.168.0.0/24 192.168.0.1 Local1
    2 ADC 192.168.1.0/24 192.168.1.1 Local2
    3 A S 0.0.0.0/0 r 10.0.0.2 Public
    4 A S 0.0.0.0/0 r 10.0.0.3 Public
    ==============================================

    Espero ter ajudado.
    um bom material didatico pode ser encontrado em:
    http://www.mikrotik.com/docs/ros/2.9/ip/route

    Abraços.

  12. #12

    Padrão Re: Dividir Clientes em dois Rádios

    Tiago,
    Caso tenha mais de 2 link é só criar a mesma regra acrescentando as outras redes?
    Delorto



  13. #13

    Padrão Re: Dividir Clientes em dois Rádios

    Primeira coisa aconselho vc colocar as duas interfaces wireless numa bridge....mesma faixa de ip....um problema ja resolvido...aki mesmo no forum tem um esquema de load balance pelo winbox muito bem explicado...onde vc divide os ip q vao sair por um link ou por outro...
    ip final ate 128 sai por um e de 129 pra cima sai por outro...unico incoveniente que o proxy nao roda...se vc usar proxy vai precisar de outro...

  14. #14

    Padrão Re: Dividir Clientes em dois Rádios

    Não uso proxy, tem como vc me mandar certinho o link para fazer esta divisão por faixa de ip no winbox, não achei.
    Obrigado



  15. #15

    Padrão Re: Dividir Clientes em dois Rádios

    Citação Postado originalmente por terencerocha
    Primeira coisa aconselho vc colocar as duas interfaces wireless numa bridge....mesma faixa de ip....um problema ja resolvido...aki mesmo no forum tem um esquema de load balance pelo winbox muito bem explicado...onde vc divide os ip q vao sair por um link ou por outro...
    ip final ate 128 sai por um e de 129 pra cima sai por outro...unico incoveniente que o proxy nao roda...se vc usar proxy vai precisar de outro...
    no meu caso eu uso proxy, como faz ?

  16. #16

    Padrão Re: Dividir Clientes em dois Rádios

    Citação Postado originalmente por wagnercandioto
    Citação Postado originalmente por terencerocha
    Primeira coisa aconselho vc colocar as duas interfaces wireless numa bridge....mesma faixa de ip....um problema ja resolvido...aki mesmo no forum tem um esquema de load balance pelo winbox muito bem explicado...onde vc divide os ip q vao sair por um link ou por outro...
    ip final ate 128 sai por um e de 129 pra cima sai por outro...unico incoveniente que o proxy nao roda...se vc usar proxy vai precisar de outro...
    no meu caso eu uso proxy, como faz ?
    no caso do web-proxy, a mt ja tem um novo pacote em teste web-proxy-test que corrige isso, use ele no lugar do web-proxy.



  17. #17

    Padrão Re: Dividir Clientes em dois Rádios

    Citação Postado originalmente por terencerocha
    Primeira coisa aconselho vc colocar as duas interfaces wireless numa bridge....mesma faixa de ip....um problema ja resolvido...aki mesmo no forum tem um esquema de load balance pelo winbox muito bem explicado...onde vc divide os ip q vao sair por um link ou por outro...
    ip final ate 128 sai por um e de 129 pra cima sai por outro...unico incoveniente que o proxy nao roda...se vc usar proxy vai precisar de outro...
    Amigos, o esquema que vcs falam é esse aki do fórum de load pelo winbox ou vc usa outro, se for outro por favor, postem ai, no meu caso, eu uso esses dois rádios para os meus clientes, não posso tirar eles do ar pra fazer testes, tenho que tirar do ar, fazer o serviço e recolocar, se não os caras me crucificam vivo, heheheee, tem como vc postar detalhes do esquema por favor ?