+ Responder ao Tópico



  1. #1
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão ADSL como gw padrao e PPP como gw secundario

    Queria saber se alguém já testou a opção de usar o ADSL como gateway padrão, marcar todo o tráfego conhecido (VoIP, http, ssl, pop, smtp) além dos IPs válidos roteados para clientes e enviar todos para um link PPP full. Com isto o tráfego pesado de p2p e outras "futilidades" em geral sairiam pelo adsl.

  2. #2

    Padrão Re: ADSL como gw padrao e PPP como gw secundario

    Citação Postado originalmente por sergio
    Queria saber se alguém já testou a opção de usar o ADSL como gateway padrão, marcar todo o tráfego conhecido (VoIP, http, ssl, pop, smtp) além dos IPs válidos roteados para clientes e enviar todos para um link PPP full. Com isto o tráfego pesado de p2p e outras "futilidades" em geral sairiam pelo adsl.
    Boa pergunta.. não tentei ainda !! Vou tentar e te falo



  3. #3

    Padrão Re: ADSL como gw padrao e PPP como gw secundario

    Grande segio.. eu to pesquisando esta solução para implementar. O patrick tem um sistema chamado vlink, acho que faz isto, mandei uma email para ele, estou aguardando resposta.
    toricamente e possivel, vc define como vc falou o adsl com gw principal e marca os pacotes que e intressante sair pelo ppp fulll com mangle para redirecionar.

    Qualquer novidade posta ae.

    sucesso!!



    Citação Postado originalmente por sergio
    Queria saber se alguém já testou a opção de usar o ADSL como gateway padrão, marcar todo o tráfego conhecido (VoIP, http, ssl, pop, smtp) além dos IPs válidos roteados para clientes e enviar todos para um link PPP full. Com isto o tráfego pesado de p2p e outras "futilidades" em geral sairiam pelo adsl.

  4. #4
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão Re: ADSL como gw padrao e PPP como gw secundario

    Citação Postado originalmente por oyama
    Grande segio.. eu to pesquisando esta solução para implementar. O patrick tem um sistema chamado vlink, acho que faz isto, mandei uma email para ele, estou aguardando resposta.
    toricamente e possivel, vc define como vc falou o adsl com gw principal e marca os pacotes que e intressante sair pelo ppp fulll com mangle para redirecionar.

    Qualquer novidade posta ae.

    sucesso!!
    Blz Oyama? Dúvidas??? um monte... :-D :-D :-D

    Mas tô aqui tentando... qdo fazer funcionar e surgirem as dúvidas posto aqui, pois por eqto nem funcinou ainda. Tenho que ler mais.. 8-)



  5. #5

    Padrão Re: ADSL como gw padrao e PPP como gw secundario

    no mikrotik na logica eu fiz mas tirei pq n tinha certeza que estava correndo os trafegos no link certo.
    Pq cai aquele detalhe, sera q os pacotes amarrados no mangle para all-p2p pega certinho, sei q para bloquear sim, mas para jogar ele no outro link n sei se vai 100% FULL n.

    mas se fosse fazer bastava fazer isso aqui:

    / ip route
    add dst-address=0.0.0.0/0 gateway=100.200.1.1 scope=255 target-scope=10 \
    routing-mark=p2p comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=100.100.1.1 scope=255 target-scope=10 \
    routing-mark=restante comment="" disabled=no

    / ip firewall mangle
    add chain=prerouting p2p=all-p2p action=mark-routing new-routing-mark=p2p \
    passthrough=no comment="p2p" disabled=no
    add chain=prerouting action=mark-routing new-routing-mark=restante \
    passthrough=no comment="restante" disabled=no

    Desculpe se estiver errado.

  6. #6

    Padrão Re: ADSL como gw padrao e PPP como gw secundario

    Desculpe se estiver errado.
    Tá desculpado! :wink:
    routing-mark não pode ser usado para P2P pois utiliza o mesmo gateway.



  7. #7

    Padrão Re: ADSL como gw padrao e PPP como gw secundario

    Citação Postado originalmente por cybersank
    Desculpe se estiver errado.
    Tá desculpado! :wink:
    routing-mark não pode ser usado para P2P pois utiliza o mesmo gateway.
    Cybersank.
    Gostaria de ver aonde esta escrito isso, tem em algum dos howto da mikrotik ou foi por experiencia vivida?
    Valew
    Abracos

  8. #8
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão Re: ADSL como gw padrao e PPP como gw secundario

    Fiz um teste aqui, usando uma das minhas redes locais; usei o routing-mark para esta rede e todo o trafego direcionado para o ADSL, mas as maquinas dessa rede não conseguem acessar meu servidor DNS.

    Meu servidor DNS está ligado a uma das interfaces do MT que faz src-nat dst-nat (dmz) para o mesmo e funciona perfeito.

    Depois que configurei, as maquinas dessa rede não conseguiram mais chegar a este servidor DNS. Criei um DNS server no MT e configurei o resolv.conf das maquinas da rede para o mesmo mas não deu resultado.

    Se colocar o DNS da operadora do ADSL funciona, mas gostaria que fosse consultado meu DNS, mesmo que seja no MT.

    Teria que marcar o trafégo DNS para acessar pela wan do PPP ou apenas configurar o servidor no MT e desativar as configurações do meu servidor (dmz)? Pergunto isso porque se eu quiser que uma das minhas redes locais acessem somente pelo adsl não terei como realizar esta configuração...




  9. #9

    Padrão Re: ADSL como gw padrao e PPP como gw secundario

    Também realizei alguns testes, mas observei que não tiveram grande sucesso. Apesar de perceber os pacotes passando pela regra, a o tráfego foi pouquissimo..
    Obs.: Alguns clientes já deixei fora dessa regra (

    chain=prerouting in-interface=SAIDA_LINK98 src-address=192.168.98.0/24
    p2p=all-p2p action=mark-connection new-connection-mark=p2p passthrough=yes

    chain=prerouting in-interface=SAIDA_LINK98 src-address=192.168.98.0/24
    connection-mark=p2p action=mark-routing new-routing-mark=p2p

    Talvez o que o Cyber comentou seja verídico, se nao conseguir se marcar, mas vamos ter que descobrir alguma solução para isso.

  10. #10
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão Re: ADSL como gw padrao e PPP como gw secundario

    Citação Postado originalmente por Liandro Paulo Carniel
    Também realizei alguns testes, mas observei que não tiveram grande sucesso. Apesar de perceber os pacotes passando pela regra, a o tráfego foi pouquissimo..
    Obs.: Alguns clientes já deixei fora dessa regra (

    chain=prerouting in-interface=SAIDA_LINK98 src-address=192.168.98.0/24
    p2p=all-p2p action=mark-connection new-connection-mark=p2p passthrough=yes

    chain=prerouting in-interface=SAIDA_LINK98 src-address=192.168.98.0/24
    connection-mark=p2p action=mark-routing new-routing-mark=p2p

    Talvez o que o Cyber comentou seja verídico, se nao conseguir se marcar, mas vamos ter que descobrir alguma solução para isso.
    Desta forma só uma parte do UPLOAD dos P2P funciona pelo SAIDA_LINK98... Acho que o Cyber comentou é que as conexões dessa rede (a qual marcou) já possui um GW padrão e e desta forma não adianta marcar os P2P e mandá-los para outra LINK, pois a conexão é estabelecida (new-connection) através desse gw padrão.



  11. #11

    Padrão Re: ADSL como gw padrao e PPP como gw secundario

    Sergio.
    Tenta colocar no /ip route, o ip do se DNS sempre ser consulado pelo seu link DEDICADO, fazendo uma rota Static.
    / ip route
    add dst-address=SEU_DNS/32 gateway=SEU_LINK_DEDICADO scope=255 target-scope=10 comment="ROTA STATICA" disabled=no

    add dst-address=0.0.0.0/0 gateway=100.200.1.1 scope=255 target-scope=10 \
    routing-mark=p2p comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=100.100.1.1 scope=255 target-scope=10 \
    routing-mark=restante comment="" disabled=no

  12. #12
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão Re: ADSL como gw padrao e PPP como gw secundario

    Citação Postado originalmente por tiagomatias
    Sergio.
    Tenta colocar no /ip route, o ip do se DNS sempre ser consulado pelo seu link DEDICADO, fazendo uma rota Static.
    / ip route
    add dst-address=SEU_DNS/32 gateway=SEU_LINK_DEDICADO scope=255 target-scope=10 comment="ROTA STATICA" disabled=no

    add dst-address=0.0.0.0/0 gateway=100.200.1.1 scope=255 target-scope=10 \
    routing-mark=p2p comment="" disabled=no
    add dst-address=0.0.0.0/0 gateway=100.100.1.1 scope=255 target-scope=10 \
    routing-mark=restante comment="" disabled=no
    Thiago, não funciona...

    Mas olha só... não deveria necessitar de adicionar rota para esse DNS uma vez que está ligado ao MT em outra interface e como o sistema é todo roteado as requisições DNS deveriam ser enviadas a este servidor. Quando eu faço um traceroute na minha rede se for endereço da mesma ele nem passa no MT, vai direto ao destino, mas quando adiciono como GW padrao para um src-address qualquer (uma das minhas redes) e faço o mark-routing esta rede simplesmente fica isolada e só consegue sair pelo GW do routing-mark.

    E algum lugar estou vacilando... mas devagar chegamos lá. :-D



  13. #13

    Padrão Re: ADSL como gw padrao e PPP como gw secundario

    Sergio.
    Posta ai o script que esta fazendo tanto do seu /ip route quanto do /ip fireall mangle
    se n quiser postar aqui me manda no email, que posso olhar para ver o que pode ser.

    Abracos.

  14. #14
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão Re: ADSL como gw padrao e PPP como gw secundario

    Citação Postado originalmente por tiagomatias
    Sergio.
    Posta ai o script que esta fazendo tanto do seu /ip route quanto do /ip fireall mangle
    se n quiser postar aqui me manda no email, que posso olhar para ver o que pode ser.

    Abracos.
    fiz igual vc postou... só que coloquei a rede inteira (src-address)...não marquei apenas P2P.



  15. #15

    Padrão Re: ADSL como gw padrao e PPP como gw secundario

    tiagomatias,
    Leia o manual.

    É perfeitamente possível a proeza e é mais simples do que parece.

  16. #16

    Padrão Re: ADSL como gw padrao e PPP como gw secundario

    Citação Postado originalmente por cybersank
    tiagomatias,
    Leia o manual.

    É perfeitamente possível a proeza e é mais simples do que parece.
    Cyber
    ta corrido pra caramba aqui no provedor, mas vou ler esse final de semana sim, apesar que n leio o manual ja faz uns meses ja, mas vou ler sim.
    As vezes ficamos encucados com coisas tao banais que a solucao esta em nossa frente mas n a enchergamos.
    Valew
    Abracos para todos.



  17. #17
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão Re: ADSL como gw padrao e PPP como gw secundario

    heheheheh... como eu suspeitava Cyber... estou fazendo lambança em algum lugar. Vou procurar no manual até entender esse sistema direito. Quando entender e fazer funcinoar eu posto aqui... ou coloco o video no ML. :-D :-D

  18. #18

    Padrão Re: ADSL como gw padrao e PPP como gw secundario

    :mrgreen: