+ Responder ao Tópico



  1. #1

    Padrão XDMCP logando no winnt e dando pau no openoffice

    Boa noite galera
    Estou com o seguinte problema, tenho um laboratorio com um servidor xdmcp e varias maquinas que logam nele via xdmc certo logando na maquina win nT ... bom ate ai tranquilo, mas antes de eu fazer eles logarem na wstacao winodows o openoffice abria nornal em cada usuario, mas agora que logase no windows nt e tenta abrir qualquer coisa do openoffice da o seguinte erro:

    (soffice:bin:16503): GLib-warning **: getpwuid_r(): failed due to unknown id(12295)
    /usr/bin/soffice: line 236: 16503 Falha de sgmentacao "$sd_prog/$sd_binary" "[email protected]"

    O que pode ser ....

    Abraços

  2. #2

    Padrão Re: XDMCP logando no winnt e dando pau no openoffice

    O OpenOffice abre correctamente se vc NAO logar no NT?



  3. #3

    Padrão Re: XDMCP logando no winnt e dando pau no openoffice

    sim sim sem logar no nt o openoffice abre na boa em usuarios locais mas como eu liberaria pra abri o open a esses usuarios do winnt ... e eu nao posso deixar de logar no winnt pois a base de dados aki da faculdade onde trabalho esta em winnt infelizmente


    abracos

  4. #4

    Padrão Re: XDMCP logando no winnt e dando pau no openoffice

    Deixa ver se eu entendim vc tem uma maquina windows NT, e outra Linux com um servidor X..
    ora. o open office esta instalado no Linux, mas os utilizadores estao no windows?! ou é só a base de dados?



  5. #5

    Padrão Re: XDMCP logando no winnt e dando pau no openoffice

    nao .... tem um servidor linux rodando XDMCP pra as estacoes linux conectarem nela pra desktop, e tem o servidor de usuarios que é no windows nt .... eu fiz o teste logando nas estacoes(linux) conectando no servidor XDMCP sem a base de usuario vir do win nt o open office funciona tranquilo ... agora pegando a base de dados de usuario do win nt eles logam normal no xdmc nas estacoes(linux) mas dai da esse erro que enviei anteriormente .....

  6. #6

    Padrão Re: XDMCP logando no winnt e dando pau no openoffice

    Ou seja, os utilizadores da rede estão armazenados no windows NT, correcto?
    bem colega, eu n sei se posso ajudar muito.. de facto nc me akonteçeu tal coisa... mas voce pode experimentar outras coisas...
    tente abrir outros programas e veja se dá o mesmo erro... ou entao faça um pequeno truque que já me resolveu N problemas...
    logue no X normalmente, com os usuarios do NT e tudo... dps abra um Konsole e faça "strace openoffice"
    e analise com atenção.. pode ser alguma lib faltando..
    Um abraço.



  7. #7

    Padrão Re: XDMCP logando no winnt e dando pau no openoffice

    nao esta faltando lib nenhum o que esta acontecendo é que como esta logando no windows nt ele gera um id sequencial ato nao cadastrado nos usuarios linux e nao deia executar porque nao da permissao pra que seja executado ..... pois via root ele executa normalmente e com usuarios locais tambem ... eu so nao sei como que eu vou fazer para dar pernissao pra que execute o openoffice


    abraços