+ Responder ao Tópico



  1. #1
    zamberlan
    Visitante

    Padrão Broffice não inicia no Debian 3.1 Sarge

    Pessoal, me ajudem por favor, não estou conseguindo fazer o BrOffice iniciar no Debian 3.1 Sarge, ja baixei os pacotes, instalei, inclusive já procurei muito na internet, onde fala sobre o erro de atalho do BrOffice, verifiquei se pode ser isso e também não resolveu!!!
    A questão é que quando clico no icone para inicar o programa, ele fica na barra em baixo como se fosse inicar e depois de um tempinho some!!!! alguem me ajude!!!

    A versão do BrOffice é a ultima 2.0.3 !!!!!

    Não sei mais o que fazer, devo ter instalado ele umas 10 vezes já!

  2. #2

    Padrão Re: Broffice não inicia no Debian 3.1 Sarge

    cara...

    abra um terminal e digite ele por console, desta forma vc poderá ver os erros que ocorrem...

    [email protected]:~$ broffice.org-2.0 -write

    aqui como ele abre normal, não aparece nenhum erro, talvez ae possa aparecer, desta forma é mais fácil de resolver problemas..

    valeu



  3. #3
    zamberlan
    Visitante

    Padrão Re: Broffice não inicia no Debian 3.1 Sarge

    Olha o que aparece!! será que falta essa lib ? ou é a versão ?

    [email protected]:~$ broffice.org-2.0 -write
    /etc/broffice.org-2.0/program/javaldx: /lib/libpthread.so.0: version `GLIBC_2.3.3' not found (required by /etc/broffice.org-2.0/program/libuno_sal.so.3)
    /etc/broffice.org-2.0/program/soffice.bin: /lib/libpthread.so.0: version `GLIBC_2.3.3' not found (required by /etc/broffice.org-2.0/program/libuno_sal.so.3)

  4. #4

    Padrão Re: Broffice não inicia no Debian 3.1 Sarge

    cara...

    vc tem q instalar a libc6
    apt-get install libc6

    valeu



  5. #5
    zamberlan
    Visitante

    Padrão Re: Broffice não inicia no Debian 3.1 Sarge

    Agradeço a resposta, mas tinha testado e olha o que deu:

    zamberlan:/home/zamberlan# apt-get install libc6
    Lendo Lista de Pacotes... Pronto
    Construindo Árvore de Dependências... Pronto
    libc6 já é a versão mais nova.
    0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 5 não atualizados.
    zamberlan:/home/zamberlan#

    Será que tem outra solução ?

  6. #6

    Padrão Re: Broffice não inicia no Debian 3.1 Sarge

    cara...

    bem estranho isso... deveria ter funcionado, então instala o libc6-dev
    apt-get install libc6-dev

    mas o arquivo que ele está se referindo é do libc6

    pelo menos aqui é:

    # dpkg -S libpthread.so.0
    libc6: /lib/tls/libpthread.so.0
    libc6: /lib/libpthread.so.0
    valeu



  7. #7
    zamberlan
    Visitante

    Padrão Re: Broffice não inicia no Debian 3.1 Sarge

    Poxa, tb não deu certo, será que é incompatibilidade com o kernel (o meu é o 2.4) ??

    Ele mostra la em cima "(required by /etc/broffice.org-2.0/program/libuno_sal.so.3)".

    Será que falta esse arquivo?
    Apesar de que o arquivo ja ta lá!!!!
    zamberlan:/etc/broffice.org-2.0/program# ls libuno_sal.so*
    libuno_sal.so libuno_sal.so.3 libuno_sal.so.3.1.1
    zamberlan:/etc/broffice.org-2.0/program#

    Já até formatei e reinstalei o linux para ver se dava e nada... baixei a instalação por rpm e converti para deb para ver se poderia ser algo assim e tb não deu...

    Será que existe solução ?

  8. #8

    Padrão Re: Broffice não inicia no Debian 3.1 Sarge

    cara.. é bem estranho mesmo...

    não sei se seria incompatibilidade com o kernel, o negócio é ver nos requisitos do bro..



  9. #9
    zamberlan
    Visitante

    Padrão Re: Broffice não inicia no Debian 3.1 Sarge

    a titulo de curiosidade, consegui fazer funcionar o broffice, recompilei o kernel para o 2.6.16.29 e funcionou...
    Era o kernel 2.4

    obrigado pela ajuda!!!

  10. #10

    Padrão Re: Broffice não inicia no Debian 3.1 Sarge

    bom.. nunca vi os requisitos do broffice...

    mas nao imaginava q o kernel 2.4 tinha algum porém..