Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Kra eu tenho o squiid rodadno no slack 10.2 comproxy transparente file.. fiz assim:

    Na instalação:
    ./configure --enable-default-err-language=Portuguese --enable-err-language="Portuguese" --bindir=/bin --sbindir=/sbin --sysconfdir=/etc/squid --libdir=/lib --enable-delay-pools --enable-linux-netfilter

    No final do squid.conf
    # Proxy transparente
    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on
    coredump_dir /var/cache/squid

    No iptables:
    iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to 3128

    *No meu caso a eth0 é a placa onde estão as estações da rede e a eth1 é onde entra a internet....

    Vo te indica meu professor de squid:
    http://www.linuxman.pro.br/squid/

    Espero q ajude, qualquer coisa posta ai...

  2. --enable-pool ou --enable-epool (2.6)

    isso ajuda na performance !!!



  3. #8
    Su6mund0
    Citação Postado originalmente por Stéfano
    Citação Postado originalmente por Su6mund0
    Desculpe a minha ignorância, mas meu iptables já foi instalando desde o inicio. Se possível detalhe melhor a forma correta de solucionar o problema citado.

    Obrigado!
    Você provavelmente tem os binários do iptables, e não os headers...

    Eu tenho instalado: iptables -V iptables v1.3.3 e também a instalação do iptables em /tmp/source/iptables-1.3.3. Como informo na configuração do squid a localização do iptables, para que possa resolver este problema?

  4. #9
    Su6mund0
    Citação Postado originalmente por tuxson
    Kra eu tenho o squiid rodadno no slack 10.2 comproxy transparente file.. fiz assim:

    Na instalação:
    ./configure --enable-default-err-language=Portuguese --enable-err-language="Portuguese" --bindir=/bin --sbindir=/sbin --sysconfdir=/etc/squid --libdir=/lib --enable-delay-pools --enable-linux-netfilter

    No final do squid.conf
    # Proxy transparente
    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on
    coredump_dir /var/cache/squid

    No iptables:
    iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to 3128

    *No meu caso a eth0 é a placa onde estão as estações da rede e a eth1 é onde entra a internet....

    Vo te indica meu professor de squid:
    http://www.linuxman.pro.br/squid/

    Espero q ajude, qualquer coisa posta ai...
    tuxson
    Obrigado pela ajuda, mas esse tipo de configuração de proxy transparente não fuinciona no squid 2.6.



  5. #10
    Su6mund0
    Caro colegas, finalmente conseguir resolver meu problema com o proxy transparente no squid 2.6.
    O problema em questão foi resolvido, com o carregamento do modulo iptable_nat.


    Obrigado a todos pela ajuda! :-D







Tópicos Similares

  1. proxy transparente ( squid-2.6.STABLE21-3.el5 )
    Por wasley no fórum Servidores de Rede
    Respostas: 3
    Último Post: 28-01-2010, 19:38
  2. Respostas: 4
    Último Post: 21-11-2005, 18:29
  3. PROXY TRANSPARENTE SQUID E HTTPS
    Por IRONWOOD no fórum Servidores de Rede
    Respostas: 1
    Último Post: 13-10-2004, 19:02
  4. Proxy transparente Squid mostra log mas não gera cache
    Por haas no fórum Servidores de Rede
    Respostas: 1
    Último Post: 05-05-2004, 17:55
  5. Autenticação com Proxy Transparente (SQUID)
    Por Hawthorn_ no fórum Servidores de Rede
    Respostas: 6
    Último Post: 23-03-2004, 09:35

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L