Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #21

    Padrão Re: Caros Colegas problema de lentidão tenho um solução

    uma faixa para um usuario normal seria 20 a 25 conexoes..


  2. #22

    Padrão Re: Caros Colegas problema de lentidão tenho um solução

    Só uma pergunta: essa regra de limitar o nº de conexões por cliente funciona quando o Mikrotik é um AP e está no modo bridge???


    Citação Postado originalmente por pro2
    Eu tbm estava com problema de lentidão principalmente das 10:00 as 23:00 e comecei a estudar a minha rede e nada de errado tudo normal.

    Então comecei a da um olhada aqui no forum e vi que o problema podia ser a questão de
    excesso de conexão então limite as coneções da minha rede para 35 por usuario so que esta beleza mais em alguns cliente as vezes fica lento a navegação então fique locou de pessa o que pode ser então descobri que isto so acontecia onde tinha ap com cliente no modo router então a maioria deste cliente tem mais de um máquina e então ficava 35 conexão pra duas máquina então esta regra:
    /firewall filter add chain=forward src-address=10.0.0.0/16 protocol=tcp tcp-flags=syn connection-limit=30,32 action=drop comment="controle de conexão por cliente "

    não dava pra
    ser usada então dando um pesquisa no forum internacional do mikrotik vi um script que gera um laço de criar varias regra em massa exemplo vc quer criar um regra no firewall para da cliente vc usa assim o
    /firewall filter : for i from=1 to=255 do={ Regra + ips . $i) }
    neste caso aqui ele gera a regra para o ip por exemplo do 192.168.1.1 a 192.168.1.254


    voltando ao assunto conexão então gera um script e que adicionou um regra para cada cliente por default coloquei 35 conexões e neste cliente que tinha radio com router eu coloquei 80 conexões acabou o problema aqui.

    este santo remédio foi bom pra o meu caso que era problema de execesso de conexão
    se o de alguem for mo mesmo então ta aqui o remedio

    /firewall filter : for i from=2 to=254 do={ add chain=forward src-address=("10.0.0." . $i) protocol=tcp tcp-flags=syn connection-limit=30,32 action=drop comment="controle de conexão por cliente "}

    a mudañçao que deve ser feita e a seguinte so colocar a faixa de ips que vc usam ai no seu clientes ("10.0.0." . $i) , ("192.168.1." . $i)



  3. #23

    Padrão Re: Caros Colegas problema de lentidão tenho um solução

    Citação Postado originalmente por _AGM_
    Só uma pergunta: essa regra de limitar o nº de conexões por cliente funciona quando o Mikrotik é um AP e está no modo bridge???


    Citação Postado originalmente por pro2
    Eu tbm estava com problema de lentidão principalmente das 10:00 as 23:00 e comecei a estudar a minha rede e nada de errado tudo normal.

    Então comecei a da um olhada aqui no forum e vi que o problema podia ser a questão de
    excesso de conexão então limite as coneções da minha rede para 35 por usuario so que esta beleza mais em alguns cliente as vezes fica lento a navegação então fique locou de pessa o que pode ser então descobri que isto so acontecia onde tinha ap com cliente no modo router então a maioria deste cliente tem mais de um máquina e então ficava 35 conexão pra duas máquina então esta regra:
    /firewall filter add chain=forward src-address=10.0.0.0/16 protocol=tcp tcp-flags=syn connection-limit=30,32 action=drop comment="controle de conexão por cliente "

    não dava pra
    ser usada então dando um pesquisa no forum internacional do mikrotik vi um script que gera um laço de criar varias regra em massa exemplo vc quer criar um regra no firewall para da cliente vc usa assim o
    /firewall filter : for i from=1 to=255 do={ Regra + ips . $i) }
    neste caso aqui ele gera a regra para o ip por exemplo do 192.168.1.1 a 192.168.1.254


    voltando ao assunto conexão então gera um script e que adicionou um regra para cada cliente por default coloquei 35 conexões e neste cliente que tinha radio com router eu coloquei 80 conexões acabou o problema aqui.

    este santo remédio foi bom pra o meu caso que era problema de execesso de conexão
    se o de alguem for mo mesmo então ta aqui o remedio

    /firewall filter : for i from=2 to=254 do={ add chain=forward src-address=("10.0.0." . $i) protocol=tcp tcp-flags=syn connection-limit=30,32 action=drop comment="controle de conexão por cliente "}

    a mudañçao que deve ser feita e a seguinte so colocar a faixa de ips que vc usam ai no seu clientes ("10.0.0." . $i) , ("192.168.1." . $i)
    _AGM_
    Concerteza funciona.
    Pq a bridge do mt trabalha na camada 3 do modelo OSI, aonde podemos fazer regras de filtragem, a bridge executa as regras que passam por dentro dela, no caso /ip firewall filter forward, outro lugar que voce pode fazer as regras diretamente nas filtragem da bridge /interface bridge filter.

    Espero ter ajudado _AGM_

    Abracos

  4. #24

    Padrão

    ninguem arriscou a fazer as regras para queue nao?



  5. #25

    Padrão

    O que acontecera quando ele atingir as 30 conexões ????


    no meu caso melhorou a rede gente .... mas tem clientes que para de navegar ... seria algo da regra ????

  6. #26

    Padrão

    Para o controle de banda eu uso o CBQ, se alguem tive algum interesse eu disponibilizei no meu site os scripts e exemplo...

    http://www.tftecnologia.com.br/cbq.zip

    Valews



  7. #27

    Unhappy radius mikrotik mysql

    ola esto aderindo para o mikrotik ele so altentica no freeradius com mysql gostaria de saber como e queis informações colocar mo mysql se posivel alguem me envia uma tabela de usuario pronta para mim. grato

  8. #28

    Thumbs up apos aplicar a regra 30 conexoes simult

    apos aplicar a regra 30 conexoes simult o cliente nao navega mais nem entra no msn .. eu to vendo no forum aqui . como agente soluciona isso .. porque senao resolvemos uma questao e geramos outra .. agente presisa aplicar 30 conec simul so pra p2p porque do resto deixar liberado ...da uma forca ai galera



  9. #29

    Padrão

    Pessoal, alguém pode me informar como fazer para ver pelo terminal do mk uma regra especifica de queue de um determinado ip, estou tentando adaptador esse comando de criação de regras automatizado para criar regras queues para uma faixa inteira de ip's.

    Obrigado

  10. #30

    Padrão

    o legal Portela tb estou atraz disso tb...

    Valew



  11. #31

    Thumbs up

    Citação Postado originalmente por fernandolv Ver Post
    apos aplicar a regra 30 conexoes simult o cliente nao navega mais nem entra no msn .. eu to vendo no forum aqui . como agente soluciona isso .. porque senao resolvemos uma questao e geramos outra .. agente presisa aplicar 30 conec simul so pra p2p porque do resto deixar liberado ...da uma forca ai galera
    errado, nao que o cara para de navegar, a regra 'e aplicada em flags SYN (inicio de conexao), na verdade a regra se aplica nao nas conexoes estabelecidas e sim em uma nova conexao querendo ser estabelecida, o bloqueio acontece quando tem muita gente navegando por traz de um GW por exemplo vc da internet para uma empresa que esse net chega em um servidor e por traz desse servidor tem mais 20 maquinas por exemplo, imaginamos que essas maquinas todas vao entrar na net ao mesmo, quando elas abrem o browser por exemplo ela faz um requisicao SYN e estabelece ate a pagina terminar de abrir, mas quando ela termina de abrir automaticamente ela ja libera a conexao e n fica como estabelecido.
    Mas no caso do cara estiver usando P2P, o q P2p faz, fica tentando abrir um monte de conexoes ao mesmo tempo 'e ai que o bloqueio entra em acao.
    Mas caso ninguem tiver p2p na rede interna deles, 20 conexoes simultanoes para navegacao e msn 'e o suficiente para 20 maquinas tranquilo, mas vamos pensar que mesmo assim que o pessoal navega muita e fica o tempo inteira fazendo novas conexoes, e chega no limite de 20 conexoes, nao que ele vai parar de navegar e sim os proximos pacotes a serem enviados serao barrados, apenas isso, nao que ele para de navegar por completo.
    espero ter esclarecido a quesao.

    Abracos.

  12. #32

    Padrão Minha rede

    Citação Postado originalmente por pro2 Ver Post
    Eu tbm estava com problema de lentidão principalmente das 10:00 as 23:00 e comecei a estudar a minha rede e nada de errado tudo normal.

    Então comecei a da um olhada aqui no forum e vi que o problema podia ser a questão de
    excesso de conexão então limite as coneções da minha rede para 35 por usuario so que esta beleza mais em alguns cliente as vezes fica lento a navegação então fique locou de pessa o que pode ser então descobri que isto so acontecia onde tinha ap com cliente no modo router então a maioria deste cliente tem mais de um máquina e então ficava 35 conexão pra duas máquina então esta regra:
    /firewall filter add chain=forward src-address=10.0.0.0/16 protocol=tcp tcp-flags=syn connection-limit=30,32 action=drop comment="controle de conexão por cliente "

    não dava pra
    ser usada então dando um pesquisa no forum internacional do mikrotik vi um script que gera um laço de criar varias regra em massa exemplo vc quer criar um regra no firewall para da cliente vc usa assim o
    /firewall filter : for i from=1 to=255 do={ Regra + ips . $i) }
    neste caso aqui ele gera a regra para o ip por exemplo do 192.168.1.1 a 192.168.1.254


    voltando ao assunto conexão então gera um script e que adicionou um regra para cada cliente por default coloquei 35 conexões e neste cliente que tinha radio com router eu coloquei 80 conexões acabou o problema aqui.

    este santo remédio foi bom pra o meu caso que era problema de execesso de conexão
    se o de alguem for mo mesmo então ta aqui o remedio

    /firewall filter : for i from=2 to=254 do={ add chain=forward src-address=("10.0.0." . $i) protocol=tcp tcp-flags=syn connection-limit=30,32 action=drop comment="controle de conexão por cliente "}

    a mudañçao que deve ser feita e a seguinte so colocar a faixa de ips que vc usam ai no seu clientes ("10.0.0." . $i) , ("192.168.1." . $i)
    Fera seguinte.... to com o mesmo problema, porem minha range de ip he diferente 192.168.x.2, vai do 1 - 252, em redes separadas, e naum estou conseguindo coloca pra funfa.. naum manjo mto de mk, soh o basico c vc puder me ajudar, fico mto grato..

    E otra coisa.. vc naum tem alguma lista de porta de spywares para bloquear e tal..



  13. #33

    Smile

    Citação Postado originalmente por rfm Ver Post
    E otra coisa.. vc naum tem alguma lista de porta de spywares para bloquear e tal..
    ta ai amigo.
    /ip web-proxy access
    add src-address=192.168.191.0/24 dst-port=80 action=deny url=%2e%44%4c%4c/%73%70%2e%68%74%6d%6c
    add src-address=192.168.191.0/24 dst-port=80 action=deny url=%2e%64%6c%6c/%73%70%2e%68%74%6d%6c
    add src-address=192.168.191.0/24 dst-port=80 action=deny url=%31%2d%73%65%2e%63%6f%6d/%68%6f%6d%65%2e%68%74%6d%6c
    add src-address=192.168.191.0/24 dst-port=80 action=deny url=%61%69%64=

    ..... tem muito mais, tentei postar mas diz que excede o numero de caracteres, coloquei em um arquivo em txt para voce baixar.
    ta ai o link.
    http://www.linuxap.com.br/firewall/blacklist.txt
    So troque o ip address pelo range do seu IP ai.
    Última edição por tiagomatias; 24-10-2006 às 11:12.

  14. #34

    Smile da uma mao

    [QUOTE=Portela;227781]pro2,

    quais os significados destas velocidades abaixo

    targent-address: 192.168.0.2 - 192.168.0.255 >>>> este e de 2 a 255
    limit at: 32k >>>> ???
    max limit: 75k >>>> ???
    burst limit: 512k >>>> ???
    burst threshold: 64k >>>> ???
    time: 80 >>>> ???
    interface: ether2 >>>>> este e interface de saida
    queue type: ethernet-default >>>>>> ??????
    parent: none >>>>>> ????????
    priority: 8 >>>>>> ??????

    GRATO



  15. #35

    Padrão

    legal essa lista, mais soh uma duvida tem como adicionar td de uma vez, ou tem que ser uma por uma

  16. #36

    Padrão

    [QUOTE=walteramelo;229142]
    Citação Postado originalmente por Portela Ver Post
    pro2,

    quais os significados destas velocidades abaixo

    targent-address: 192.168.0.2 - 192.168.0.255 >>>> este e de 2 a 255
    limit at: 32k >>>> ???
    max limit: 75k >>>> ???
    burst limit: 512k >>>> ???
    burst threshold: 64k >>>> ???
    time: 80 >>>> ???
    interface: ether2 >>>>> este e interface de saida
    queue type: ethernet-default >>>>>> ??????
    parent: none >>>>>> ????????
    priority: 8 >>>>>> ??????

    GRATO
    aqui tu vai tirar suas respostas.
    https://under-linux.org/forums/mikro...om-queues.html



  17. #37

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    ta ai amigo.
    /ip web-proxy access
    add src-address=192.168.191.0/24 dst-port=80 action=deny url=%2e%44%4c%4c/%73%70%2e%68%74%6d%6c
    add src-address=192.168.191.0/24 dst-port=80 action=deny url=%2e%64%6c%6c/%73%70%2e%68%74%6d%6c
    add src-address=192.168.191.0/24 dst-port=80 action=deny url=%31%2d%73%65%2e%63%6f%6d/%68%6f%6d%65%2e%68%74%6d%6c
    add src-address=192.168.191.0/24 dst-port=80 action=deny url=%61%69%64=

    ..... tem muito mais, tentei postar mas diz que excede o numero de caracteres, coloquei em um arquivo em txt para voce baixar.
    ta ai o link.
    http://www.linuxap.com.br/firewall/blacklist.txt
    So troque o ip address pelo range do seu IP ai.
    Putz.. Legal cara vc ter postado isso. Tava tentando montar as minhas, mas tinha pouco conhecimento de portas e hosts que tinham spy e vírus..
    Vlw mesmo..