+ Responder ao Tópico



  1. #1

    Padrão Conexões Simultâneas ( provedor perdendo clientes me ajudem )

    gente estou com problema de Conexões Simultâneas , queria configurar meu mk para 25 conexões por ip , minha faixa de ip é 192.168.254.0 , alguem poderia me ajudar a fazer essa regra , andei tentando fazer uma regra q esta recente aki no forum mais não da certo de Geito nenhum

  2. #2

    Padrão

    Olá Amigo,
    coloca essa regra ae que ela ira controla cada um de teus ips da sua rede,

    /ip firewall filter add chain=forward src-address=192.168.254.0/24 protocol=tcp tcp-flags=syn \
    connection-limit=25,32 action=drop comment="Controle de Conexoes -By Josevaldo \

    E qualquer coisa post ai o resultado para podermos melhor lhe ajudar.
    []' Josevaldo



  3. #3

    Padrão

    Gostaria de entender melhor a opção
    tcp-flags=syn

    O que ela faz?

  4. #4

    Padrão

    essa regra se encaixa no q estou precisando mas minha rede é dhcp e dar ip de 192.168.40.0 a 192.168.44.255 como faria nesta mesma regra para ela controlar toda essa rede?



  5. #5

    Padrão

    Marcos,
    pode criar uma regra:
    /ip firewall filter add chain=forward src-address=192.168.40.0/21 protocol=tcp tcp-flags=syn \
    connection-limit=25,32 action=drop comment="Controle"

  6. #6

    Padrão

    Pessoal, nos testes que andei fazendo aqui limitando o número de conexões simultâneas, o grande problema é que quando o limite de conexões é atingido, a navegação simplesmente "trava", tendo que recarregar a página... Não existe alguma forma de se aplicar essa regra numa queue, para que a página não tenha que ser recarregada sempre?



  7. #7

    Padrão

    Não sei se mais alguém está usando esse esquema de limite de conexões, mas analisando pelo IP - Firewall - Connections, percebi que um cliente meu aparecia muito mais que as 40 conexões atribuidas a ele.

    Aqui usamos a regra abaixo, sendo que há uma lista criada com os ip´s que terão esse controle, e como poderão conferir pelas imagens (aparece mais que 40, não coube todas na tela, mas tem muito mais) e também há o ip do cliente na lista.

    Alguma sugestão?

    chain=forward protocol=tcp tcp-flags=syn connection-limit=40,32
    src-address-list=conx_limit action=drop
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         76.gif
Visualizações:	129
Tamanho: 	21,2 KB
ID:      	32  
    Imagens Anexas Imagens Anexas  

  8. #8

    Padrão Conexões Simultâneas ( provedor perdendo clientes me ajudem )

    Eu também já notei isso, parece que o controle não está funcionando direito...sei lá...não estou entendendo, pensei que era só comigo, mas vejo que outros também enfrentam o mesmo problema...
    No winbox vejo que as regras (drop) são incrementadas, tanto em packets quanto em bytes, mas no número de conexões podemos ver um volume muito maior que o permitido na regra...
    O que está acontecendo realmente?

    t+



  9. #9

    Padrão

    Interessante, vc ta fazendo balanceamento com 3 links, nao seria este o problema?




    Citação Postado originalmente por liandrocarniel Ver Post
    Não sei se mais alguém está usando esse esquema de limite de conexões, mas analisando pelo IP - Firewall - Connections, percebi que um cliente meu aparecia muito mais que as 40 conexões atribuidas a ele.

    Aqui usamos a regra abaixo, sendo que há uma lista criada com os ip´s que terão esse controle, e como poderão conferir pelas imagens (aparece mais que 40, não coube todas na tela, mas tem muito mais) e também há o ip do cliente na lista.

    Alguma sugestão?

    chain=forward protocol=tcp tcp-flags=syn connection-limit=40,32
    src-address-list=conx_limit action=drop

  10. #10

    Padrão

    O balanceamento é com 2 links de origem.

    Como o controle do nr de conexoes é feito no Filter´s e o balanceamento é no Mangle, e analisando todas as regras, não vejo motivo para o sistema não limitar o nr de conexões assim mesmo.

    Já que toda a regra se baseia nos ip´s "src" (origem).
    Ex.: src-address-list=conx_limit

    Vamos ver se mais alguém tem alguma dica sobre o assunto.