Página 3 de 3 PrimeiroPrimeiro 123
+ Responder ao Tópico



  1. #11
    andkaiser
    Citação Postado originalmente por motrius Ver Post
    Olá,
    Reparei que nessa configuração abaixo contem um erro:


    A linha abaix informando que qualquer rede seja aceito pelo squid.
    acl src all 0.0.0.0/0.0.0.0

    Então repare que la embaixo possui uma linha "http_access deny all" o qual está negando qualquer acesso, mude o "deny" para "allow" reinicie o serviço e teste novamente.

    []'s
    Opa... Agora funcionou.

    Eu havia reparado nesta linha, mas imaginei que isso fosse uma implementação de segurança.

    Tanto que cheguei a comentar esta linha em um teste que fiz, mas na ocasião deu erro.

    Meu, muito obrigado pela ajuda.

  2. #12
    andkaiser
    Citação Postado originalmente por Benatto Ver Post
    creio que naum pois eles esta liberando a acl rede primeiro

    se vc deixar o all em allow vc libera tudo ai pode usar proxy externo


    retira a linha acl purge method PURGE
    Opa Benatto.

    Eu havia pensado nisso antes. A ACL rede estava antes da all.
    Eu acredito que esse deny seja para bloquear outras redes, certos? Assim não tem como usarem meu proxy, exato?
    Vou fazer o teste que falou, mas do jeito que o "motrius" passou está funcionando. Mas, não quero deixar meu proxy aberto.

    Obrigado



  3. #13
    motrius
    Que bom que funcionou precisando de ajuda estamos ae.

    Apenas uma correção:
    creio que naum pois eles esta liberando a acl rede primeiro

    se vc deixar o all em allow vc libera tudo ai pode usar proxy externo


    retira a linha acl purge method PURGE
    Realmente ele libero a a "acl rede" primeiro ai está o erro, no caso ela teria que ser liberada por último porque as regras são lidas de cima pra baixo e da esquerda pra direita. Então o Squid leu a liberação da "acl rede" primeiro e logo abaixo bloqueou a rede toda novamente.

    []'s

  4. Citação Postado originalmente por motrius Ver Post
    Que bom que funcionou precisando de ajuda estamos ae.

    Apenas uma correção:


    Realmente ele libero a a "acl rede" primeiro ai está o erro, no caso ela teria que ser liberada por último porque as regras são lidas de cima pra baixo e da esquerda pra direita. Então o Squid leu a liberação da "acl rede" primeiro e logo abaixo bloqueou a rede toda novamente.

    []'s
    ops o squid não le de abixo par acima não

    simplesmente ele ta com o squid aberto agora só basta eu saber o ip dele e navegar usando o proxy dele isto causa uma falta de segurança






Tópicos Similares

  1. Problemas no Squid, 'Memory pools are 'off'; limit: 2.00 MB'
    Por H_Franzin no fórum Servidores de Rede
    Respostas: 3
    Último Post: 31-03-2005, 15:07
  2. Amigos estou com sérios problemas no squid(RunCache)
    Por bandlinux no fórum Servidores de Rede
    Respostas: 1
    Último Post: 04-03-2005, 06:07
  3. Problemas no Squid com firewall
    Por Dick_Vigarista no fórum Servidores de Rede
    Respostas: 4
    Último Post: 03-11-2003, 15:09
  4. Problemas no squid com a porta 8088
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 17-02-2003, 08:42
  5. problemas no squid
    Por roggy no fórum Servidores de Rede
    Respostas: 2
    Último Post: 25-09-2002, 15:12

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L