+ Responder ao Tópico



  1. #1

    Padrão Problemas com programas buralndo o controle P2P

    Boa tarde gente !!! obsevei em um cliente meu q estava com o trfego dele alto o dia todo !!! ai eu olhei o TOSCH .. observando que a porta !! que estava passando era as portas do emule !! ... e o controle de p2p !! estava abilitado !! poremq era algun outro programa !!! q estava burlando o controle !!!.... alguem sabe q programas sao esses .. e como segurar os mesmos......

  2. #2
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    sem chances... com o OBIFUSCATOR, e-mule consegue burlar o shape. Além desse método do e-mule, vários outros softwares P2P usam cripotografia tornando muito difícil a indentificação através de IPP2P, L7 ou outro módulo qualquer que verifica o tipo de pacote para realizar a marcação.



  3. #3

    Smile

    Heheheh... e uma verdadeira queda de braco, tente limitar a quantidade de conexoes simutaneas(tem varios topicos aqui informando como fazer) e posta o resultado se deu ou nao certo.

  4. #4

    Padrão

    Citação Postado originalmente por dumer99 Ver Post
    Boa tarde gente !!! obsevei em um cliente meu q estava com o trfego dele alto o dia todo !!! ai eu olhei o TOSCH .. observando que a porta !! que estava passando era as portas do emule !! ... e o controle de p2p !! estava abilitado !! poremq era algun outro programa !!! q estava burlando o controle !!!.... alguem sabe q programas sao esses .. e como segurar os mesmos......
    Olá Dumer!

    Cara é o seguinte, a depender do perfil dos clientes de tua rede, você poderia DROPar todas as portas altas 1024-65535 e liberar somente as conhecidas dessa ranger, assim você teria total controle sobre todos os p2p.
    Caso tenha interesse em testar, posta ai como é o perfil do uso de tua rede, provavelmente a porta 1863 do msn é uma das q devem passar fora desse drop, as demais vai depender exclusivamente de cada caso.
    Vlw.
    []'s



  5. #5

    Thumbs up Boas Informaçoes

    Primeiramente boa tarde a todos !!! e obrigado pelas respostas que contribuiram muito ao post !!!
    Legal Josevaldo vc pode passar a configuração do Winbox !!! para fechar essas portas !!

    Um amigo meu estav me falando a respeito de marcar pacotes !!! ( tipo marcar o pacote p2p e limitar o mesmo !! alguem ja fez isso ??? se teve bom resultado !! coloque ai pra gente !!! um abrço !!!

  6. #6
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Citação Postado originalmente por dumer99 Ver Post
    Primeiramente boa tarde a todos !!! e obrigado pelas respostas que contribuiram muito ao post !!!
    Legal Josevaldo vc pode passar a configuração do Winbox !!! para fechar essas portas !!

    Um amigo meu estav me falando a respeito de marcar pacotes !!! ( tipo marcar o pacote p2p e limitar o mesmo !! alguem ja fez isso ??? se teve bom resultado !! coloque ai pra gente !!! um abrço !!!
    Acho que não leu as respostas!!! Leia logo acima um pouco... O MT para fazer controle P2P marca os pacotes.

    Tente implementar o que o Oyama mencionou. É uma das formas mais práticas e simples atualmente.



  7. #7

    Padrão Blz Mas onde eu faço essa funçao ?/ e como ??

    Blz sergio !! mas onde eu atribuo essas funçoes !! mencionadas .... e qual e sao as regras da mesma !???? se puder colocar um exemplo !! de um script pu screen do winbox !! ja fica melhor !!! um abraço a todo s...

  8. #8

    Padrão Primeiro teste

    Hoje pela manha !!! eu tinha um cliente !! rasgando o p2p !! assim com odescrito no topico !! ai eu resolvi fazer como o josevaldo aconselhou ... eu dropei pelo firewall as porta de 3500 a 5899 ... na horaa !! a velocidade de Downloads do cliente !! baixou !!! porem eu coloquei essa regra com tempo determindado !! ate as 24:00 para os clientes baixarem deposi das 24:00 ....... a principio o resultado foi satisfatorio !!! essa range de portas eu joguei no chute !! se alguem tiver alguma informaçao dos programs mais utilizados e as suas devidas portas !!! poste ai !!! ou acrescente um comentario no topico !! para melhorar a eficacia !! do combate aos P2P ...umabraço



  9. #9
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Citação Postado originalmente por dumer99 Ver Post
    Blz sergio !! mas onde eu atribuo essas funçoes !! mencionadas .... e qual e sao as regras da mesma !???? se puder colocar um exemplo !! de um script pu screen do winbox !! ja fica melhor !!! um abraço a todo s...
    dumer99, não quero ser grosseiro, mas a opção ali em cima PESQUISAR, você encontra aqui no fórum N posts a respeito disso. Vamos deixar de popular os posts com os mesmos assuntos. Uma pequena amostra da opção PESQUISAR:

    https://under-linux.org/forums/mikro...ighlight=limit
    https://under-linux.org/forums/mikro...ighlight=limit
    https://under-linux.org/forums/mikro...ighlight=limit
    https://under-linux.org/forums/mikro...ighlight=limit
    https://under-linux.org/forums/mikro...+simult%E2neas
    https://under-linux.org/forums/proxy...+simult%E2neas
    https://under-linux.org/forums/mikro...+simult%E2neas
    https://under-linux.org/forums/mikro...+simult%E2neas
    https://under-linux.org/forums/mikro...marcar+pacotes
    https://under-linux.org/forums/mikro...marcar+pacotes
    https://under-linux.org/forums/redes...marcar+pacotes

  10. #10

    Padrão

    Olá Amigo,

    Como lhe falei o uso do bloqueio de portas requer um estudo de sua rede, para ver quais os programas que utilizam portas altas e que não devem ser bloquados.
    Como esta ai no screen, eu não bloqueio direto, eu envio o ip de destino para uma lista, e bloqueio a lista, assim podemos verificar quais os host q estão bloqueados, etc.
    qualquer coisa estamos por aqui para ajudar e testar novas funcionalidade.
    []'s
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         ControlaPorta.JPG
Visualizações:	193
Tamanho: 	166,6 KB
ID:      	8  



  11. #11

    Padrão Claro Segio !! vc esta certo !!!

    E verdade Sergio !!! vc esta certo !!! eu agradeço !!! a indicação dos topicos ja relacionados !!! vou pesquizar !! e aprimorar as regras implementadas no meu MK ... deixo um forte abraço !! e agradecimento pelo auxilio .............

  12. #12

    Padrão

    Oi amigo Josevaldo
    Como faço este esquema de lista tem como vc passar os passos pra fazer isto



  13. #13

    Padrão

    ola Pro2,

    Pela linha de comando faça o seguinte:

    /ip firewall filter add chain=forward out-interface=Link src-address=172.16.0.0/16 protocol=tcp \
    dst-port=1024-1861 action=add-dst-to-address-list address-list=black_list \
    address-list-timeout=1d comment="Marcas Uso Portas Altas - By Josevaldo" disabled=no

    Com essa regra estamos mandando para a black_list os ip de destino q nossa rede 172.16.0.0/16 tentar acessa com as portas altas, nesse exemplo a ranger 1024-1861.

    Agora vamos bloquear a black_list com essa outra regra:

    /ip firewall add chain=forward dst-address-list=black_list action=drop comment="Bloqueio \
    Host p2p e Derivados - By Josevaldo" disabled=no

    vá criando as ranges de ip lá em cima, de acordo com tua utilização de rede...
    []'s
    Josevaldo

  14. #14

    Smile

    Exelente, mais eu não acho uma boa fazer bloqueio de trafego p2p para provedores de acesso, com certesa o cliente vai ligar para o suporte e reclamar que não consegue conectar e nem baixar nada no p2p. O bom mesmo e fazer controle destas praga.



    Citação Postado originalmente por Josevaldo Ver Post
    ola Pro2,

    Pela linha de comando faça o seguinte:

    /ip firewall filter add chain=forward out-interface=Link src-address=172.16.0.0/16 protocol=tcp \
    dst-port=1024-1861 action=add-dst-to-address-list address-list=black_list \
    address-list-timeout=1d comment="Marcas Uso Portas Altas - By Josevaldo" disabled=no

    Com essa regra estamos mandando para a black_list os ip de destino q nossa rede 172.16.0.0/16 tentar acessa com as portas altas, nesse exemplo a ranger 1024-1861.

    Agora vamos bloquear a black_list com essa outra regra:

    /ip firewall add chain=forward dst-address-list=black_list action=drop comment="Bloqueio \
    Host p2p e Derivados - By Josevaldo" disabled=no

    vá criando as ranges de ip lá em cima, de acordo com tua utilização de rede...
    []'s
    Josevaldo



  15. #15

    Padrão Fazendo Como Sugerido Pelo Amigo Oyama

    Gente lendo a posição de nosso colega percebi que realmente bloquear os p2p geral pode causar mais problemas que soluções então vamos fazer o seguinte:
    1º Continuamos a marcar todo o trafego das portas altas, exceto as de serviços já conhecidos (msn, cache, e outros quaisquer).
    2º Adicionamos uma regra no mangle para marcar os pacotes q tiver destino aos ips contidos na black_list (esse nome pode ser mudado de acordo com o gosto/opção), eis a regra:

    /ip firewall mangle add chain=prerouting dst-address-list=black_list action=mark-packet \
    new-packet-mark=host_p2p passthrough=yes comment="Host p2p - By Josevaldo" disabled=no

    3º Limitamos os pacotes que foram marcados e taí, todos os p2p estarão definitivamente controlados (nem só os p2p, bem como todos os programas que utilizarem as portas setadas pelos admin na regra citada nas respostas anteriores). eis a regra:

    /queue add name="host_p2p" dst-address=0.0.0.0/0 interface=all parent=none \
    packet-marks=host_p2p direction=both priority=8 queue=default/default \
    limit-at=64000/64000 max-limit=64000/64000 total-queue=default-small \

    Obs.: Dessa forma estaremos limitando o trafego a 64kb, façam as devidas adaptações para tua rede.
    []'s
    Josevaldo

  16. #16

    Padrão

    tentei adicionar essa regra
    /ip firewall mangle add chain=prerouting dst-address-list=black_list action=mark-packet \
    new-packet-mark=host_p2p passthrough=yes comment="Host p2p - By Josevaldo" disabled=no
    mais o meu mk nao deu a opcao passthrough=yes o que pode ser?



  17. #17

    Padrão

    Josevaldo
    Interessante as suas idéias.

    E mais ainda a separação das portas.
    Mas já que você deixou algumas portas de fora da marcação, gostaria de saber se você conhece quais recursos são utilizados nas portas que você deixou a folga. Conhecendo cada uma, será possivel retirar ou incluir algo se algum cliente reclamar.

    1024-1861
    folga as: 1862 a 1864? o que tem nelas?
    1865-2081
    folga: 2082 -
    2083-3125
    folga: 3126 -
    3127-3305
    folga: 3306 -
    3307-3455
    folga: 3456 -
    3457-7000
    folga: 7001
    7002-8290
    folga: 8291
    8292-8442
    folga: 8443
    8444-49999
    folga: 50000 a 50002
    50003-65535

    E quanto as UDP´s pode limitar todas?
    1024-65535 (UDP)

  18. #18

    Padrão

    Fiz alguns testes e gostaria de discutir com vocÊs.

    Na sugestão passada anteriormente, a sugestão era marcar as portas que eram direcionadas a porta de destino. O certo não deveria ser as portas de origem do nosso cliente (src)?

    Outra dúvida: Ao inves de criar um filter rules com as portas, gravando num ADDRESS List, e depois fazer um Mangle pegando essa Address, marcando o pacote para algum nome qualquer e depois o Queue,
    não daria para fazer tudo no MAngle, ja que ele tem a opção de definir as portas assim como no Filter Rules?



  19. #19

    Padrão

    Citação Postado originalmente por liandrocarniel Ver Post
    Josevaldo
    Interessante as suas idéias.

    E mais ainda a separação das portas.
    Mas já que você deixou algumas portas de fora da marcação, gostaria de saber se você conhece quais recursos são utilizados nas portas que você deixou a folga. Conhecendo cada uma, será possivel retirar ou incluir algo se algum cliente reclamar.

    1024-1861
    folga as: 1862 a 1864? o que tem nelas?
    1865-2081
    folga: 2082 -
    2083-3125
    folga: 3126 -
    3127-3305
    folga: 3306 -
    3307-3455
    folga: 3456 -
    3457-7000
    folga: 7001
    7002-8290
    folga: 8291
    8292-8442
    folga: 8443
    8444-49999
    folga: 50000 a 50002
    50003-65535

    E quanto as UDP´s pode limitar todas?
    1024-65535 (UDP)
    Amigo as portas que estão liberadas ai são para alguns serviços especificos, vou passar elas:
    1º 1862 a 1864? Msn, bastaria a 1863, mas resolvi deixar com essa folga;
    2º folga: 2082 - *
    3º folga: 3126 - Para meu Proxy externo;
    4º folga: 3306 - *
    5º folga: 3456 - Para a entrega de declarações na RF;
    6º folga: 7001 - *
    7º folga: 8291 - Para o Winbox ;
    8º folga: 8443 - *
    9º folga: 50000 a 50002 - Para um serviço do Min. da Saude.
    * esses quatro são para serviços especificos de alguns clientes.

    quanto às udp, eu limito todas, pq basicamente os sites convencionais (www) não o utilizam.
    []'s
    Josevaldo