+ Responder ao Tópico



  1. #1

    Post pppoe-server + Calling-station-id

    Ola todos,

    Estou implantando um servidor linux pppoe e estou tendo problema com o calling-station-id.

    estou usando:

    kernel-2.6.16
    rp-pppoe-3.8
    ppp-2.4.2
    freeradius-1.0.4

    estou tentando fazer uma autenticação mais segura usuario + senha + mac so que o pppoe-server nao manda o campo calling-station-id, ja li varias documentacoes e ninguem explica como verifcar isso !!?

    alguem aqui ja conseguiu fazer isso funcionar !?

    Obrigado.

  2. #2
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão

    Amigo o problema ta na versão do seu ppp

    instala esse
    ftp://ftp.samba.org/pub/ppp/ppp-2.4.4.tar.gz



  3. #3

    Padrão

    como posso implementar isto no meu pppoe-server, para bater o mac tbem, se não ele dropa caso o mac seja diferente correto. e tipo como habilito o kernel mode no pppoe-server para o kernel mais atuals acho que é o 2.6.19

  4. #4
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão

    Voce vai ter que adicionar um campo MAC no dicionario do radius e do pppoe
    e no client do radius e na hora de cadastrar o cliente vai ter que cadastrar o mac tambem...

    ai no ip-up voce sobe fazendo filtro por mac

    Sobre o kernel mode
    dentro da parte de rede do kernel tem la pppoe é so marcar...
    nada de muito complicado.



  5. #5

    Padrão

    certo, então no network do kernel procuro sobre pppoe, e ativo ele, já estara rodando em kernel mode.

  6. #6
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão

    depois tem que iniciar o pppoe-server com a opcao -k que indica o uso do kernel mode



  7. #7

    Post Atualizei pra o ppp-2.44

    Amigo,

    fiz a atualização, na verdade ja tinha feito antes soh q nao tinha funcionado agora tentei novamente e mesmo assim nao funciona.

    qndo atulizei o pppd nao autentica de jeito nenhum.

    Using interface ppp0
    Connect: ppp0 <--> /dev/pts/1
    sent [LCP ConfReq id=0x1 <auth pap> <magic 0x5ed3280f>]
    rcvd [LCP ConfReq id=0x1 <mru 1480> <magic 0x3aa555f8> <callback CBCP>]
    sent [LCP ConfRej id=0x1 <callback CBCP>]
    sent [LCP ConfReq id=0x1 <auth pap> <magic 0x5ed3280f>]
    sent [LCP ConfReq id=0x1 <auth pap> <magic 0x5ed3280f>]
    rcvd [LCP ConfReq id=0x3 <mru 1480> <magic 0x3aa555f8> <callback CBCP>]
    sent [LCP ConfRej id=0x3 <callback CBCP>]
    sent [LCP ConfReq id=0x1 <auth pap> <magic 0x5ed3280f>]
    sent [LCP ConfReq id=0x1 <auth pap> <magic 0x5ed3280f>]
    sent [LCP ConfReq id=0x1 <auth pap> <magic 0x5ed3280f>]
    rcvd [LCP ConfReq id=0x5 <mru 1480> <magic 0x3aa555f8> <callback CBCP>]
    sent [LCP ConfRej id=0x5 <callback CBCP>]
    sent [LCP ConfReq id=0x1 <auth pap> <magic 0x5ed3280f>]
    sent [LCP ConfReq id=0x1 <auth pap> <magic 0x5ed3280f>]


    fica so nisso !!!

  8. #8
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão

    Depois te atualizar os clientes pppoe nao conectam mais ?



  9. #9

    Post Nao autentica mais

    Depois q coloquei o ppp-2.4.4 os clientes nao conectam mais !!! qndo volto para o ppp-2.4.2 funciona normal.

    estou fazendo um teste agora, coloquei o ppp como built-in no kernel agora estou testando para ver no q da !

    mas se vc ja tiver passado por isso me da uma dica ai!!


    valew !

    ah por acaso vc nao teria msn por ai !?
    Última edição por gleydson_barbosa; 03-11-2006 às 10:14.

  10. #10
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão

    gleydson,

    Com o pppoe em kernel mode o load da maquina vai diminuir MUITO.
    Porem apenas consegui fazer ser enviado o mac na versao 2.4.4 do ppp

    voce tem certeza de ter compilado o ppp 2.4.4 com suporte a radius ?
    se compilou lembrou de atualizar os dicionarios com os parametros necessarios ? dicionario do client radius do ppp

    os problemas podem ser varios..

    Sobre o msn infelizmente prefiro o contato pelo forum para que fique registrado futuramente para outros usuarios.



  11. #11

    Post Não autentica

    Scorpion,

    cara coloquei sim com radius support inclusice o radius.so e os outros plugins do ppp estao compilados.

    olha o dump de saida !
    Nov 3 10:48:01 sobral pppd[3461]: pppd 2.4.4 started by root, uid 0
    Nov 3 10:48:01 sobral pppd[3461]: Using interface ppp0
    Nov 3 10:49:37 sobral pppd[3703]: Plugin rp-pppoe.so loaded.
    Nov 3 10:49:37 sobral pppd[3703]: RP-PPPoE plugin version 3.3 compiled against pppd 2.4.4
    Nov 3 10:49:37 sobral pppd[3703]: Plugin radius.so loaded.
    Nov 3 10:49:37 sobral pppd[3703]: RADIUS plugin initialized.
    Nov 3 10:49:37 sobral pppd[3703]: Plugin radattr.so loaded.
    Nov 3 10:49:37 sobral pppd[3703]: RADATTR plugin initialized.
    Nov 3 10:49:37 sobral pppd[3703]: pppd options in effect:
    Nov 3 10:49:37 sobral pppd[3703]: debug^I^I# (from /etc/ppp/options)
    Nov 3 10:49:37 sobral pppd[3703]: nodetach^I^I# (from command line)
    Nov 3 10:49:37 sobral pppd[3703]: logfile /var/log/pppoe.log^I^I# (from /etc/ppp/options)
    Nov 3 10:49:37 sobral pppd[3703]: unit 1^I^I# (from command line)
    Nov 3 10:49:37 sobral pppd[3703]: dump^I^I# (from /etc/ppp/options)
    Nov 3 10:49:37 sobral pppd[3703]: plugin rp-pppoe.so^I^I# (from /etc/ppp/pppoe-server-options)
    Nov 3 10:49:37 sobral pppd[3703]: plugin radius.so^I^I# (from /etc/ppp/pppoe-server-options)
    Nov 3 10:49:37 sobral pppd[3703]: plugin radattr.so^I^I# (from /etc/ppp/pppoe-server-options)
    Nov 3 10:49:37 sobral pppd[3703]: auth^I^I# (from /etc/ppp/pppoe-server-options)
    Nov 3 10:49:37 sobral pppd[3703]: login^I^I# (from /etc/ppp/pppoe-server-options)
    Nov 3 10:49:37 sobral pppd[3703]: pty /usr/sbin/pppoe -n -I eth1 -e 2:00:4f:62:07:bf:af -S 'Netonda'^I^I# (from command line)
    Nov 3 10:49:37 sobral pppd[3703]: noaccomp^I^I# (from command line)
    Nov 3 10:49:37 sobral pppd[3703]: default-asyncmap^I^I# (from command line)
    Nov 3 10:49:37 sobral pppd[3703]: mru 1500^I^I# (from /etc/ppp/options)
    Nov 3 10:49:37 sobral pppd[3703]: mtu 1444^I^I# (from /etc/ppp/options)
    Nov 3 10:49:37 sobral pppd[3703]: nopcomp^I^I# (from command line)

    ----------------------------

    na minha configuracao do arquivo /etc/ppp estou direcionando o log para um arquivo /var/log/pppoe.log qndo o tento conecta olha o log..

    Plugin rp-pppoe.so loaded.
    RP-PPPoE plugin version 3.3 compiled against pppd 2.4.4
    Plugin radius.so loaded.
    RADIUS plugin initialized.
    Plugin radattr.so loaded.
    RADATTR plugin initialized.
    pppd options in effect:
    debug # (from /etc/ppp/options)
    nodetach # (from command line)
    logfile /var/log/pppoe.log # (from /etc/ppp/options)
    unit 3 # (from command line)
    dump # (from /etc/ppp/options)
    plugin rp-pppoe.so # (from /etc/ppp/pppoe-server-options)
    plugin radius.so # (from /etc/ppp/pppoe-server-options)
    plugin radattr.so # (from /etc/ppp/pppoe-server-options)
    auth # (from /etc/ppp/pppoe-server-options)
    login # (from /etc/ppp/pppoe-server-options)
    pty /usr/sbin/pppoe -n -I eth1 -e 4:00:4f:62:07:bf:af -S 'Netonda' # (from command line)
    noaccomp # (from command line)
    default-asyncmap # (from command line)
    mru 1500 # (from /etc/ppp/options)
    mtu 1444 # (from /etc/ppp/options)
    nopcomp # (from command line)
    lcp-echo-failure 20 # (from /etc/ppp/options)
    lcp-echo-interval 120 # (from /etc/ppp/options)
    novj # (from command line)
    novjccomp # (from command line)
    ms-dns xxx # [don't know how to print value] # (from /etc/ppp/options)
    proxyarp # (from /etc/ppp/options)
    10.0.0.1:10.67.15.4 # (from command line)
    nobsdcomp # (from command line)
    nodeflate # (from command line)
    using channel 11
    Using interface ppp3
    Connect: ppp3 <--> /dev/pts/5
    sent [LCP ConfReq id=0x1 <auth pap> <magic 0x936bdf85>]
    rcvd [LCP ConfReq id=0x1 <mru 1480> <magic 0x558922d6> <callback CBCP>]
    sent [LCP ConfRej id=0x1 <callback CBCP>]
    sent [LCP ConfReq id=0x1 <auth pap> <magic 0x936bdf85>]
    sent [LCP ConfReq id=0x1 <auth pap> <magic 0x936bdf85>]
    rcvd [LCP ConfReq id=0x3 <mru 1480> <magic 0x558922d6> <callback CBCP>]
    sent [LCP ConfRej id=0x3 <callback CBCP>]
    sent [LCP ConfReq id=0x1 <auth pap> <magic 0x936bdf85>]
    sent [LCP ConfReq id=0x1 <auth pap> <magic 0x936bdf85>]
    sent [LCP ConfReq id=0x1 <auth pap> <magic 0x936bdf85>]
    rcvd [LCP ConfReq id=0x5 <mru 1480> <magic 0x558922d6> <callback CBCP>]
    sent [LCP ConfRej id=0x5 <callback CBCP>]
    sent [LCP ConfReq id=0x1 <auth pap> <magic 0x936bdf85>]
    sent [LCP ConfReq id=0x1 <auth pap> <magic 0x936bdf85>]
    sent [LCP ConfReq id=0x1 <auth pap> <magic 0x936bdf85>]

    -----------------------------------------------------

    dai fica so nisso, muito estranho, ja fiz todas as atualizacoes possiveis e nada.

    pode ser minha configracoe q esta errada da uma olhada ai.

    /etc/ppp/options

    ms-dns x.x.x.x
    ms-dns x.x.x.x
    debug
    dump
    logfd 2
    logfile /var/log/pppoe.log
    login
    default-asyncmap
    mtu 1444
    mru 1500
    lcp-echo-interval 120
    lcp-echo-failure 20
    proxyarp


    /etc/ppp/pppoe-server-options

    require-pap
    auth
    login
    plugin rp-pppoe.so
    plugin radius.so
    plugin radattr.so

    p.s: estou chamando o pppoe-server com a seguinte linha:

    pppoe-server -I eth1 -S Netonda

    atualizei o freeradius tbm para aversao 1.1.3

    testei o resultado o radlogin e esta normal, coloquei o radius em modo de debug e qndo tento conectar via pppoe nao recebo nenhum requisao de autenticacao no radius.

    ja tentei tirar o radiue colocar a autenticacao para o arquivo /etc/ppp/pap-secrets e tbm nao rola, eh como se o windows nao falesse com o ppp-2.4.4 uma coisa assim.
    Última edição por gleydson_barbosa; 03-11-2006 às 11:01.

  12. #12
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão

    Já sei o problema amigo...


    Você esqueceu de recompilar o rp-pppoe com os headers do ppp 2.4.4

    ou seja... Depois de instalar o novo ppp voce precisa tambem recompilar o rp-pppoe de preferencia baixe a ultima versao la no site deles.

    []´s



  13. #13

    Post Rp-pppoe-3.8

    Scorpion,

    a versao q esta instalada eh a mais nova 3.8, ja tinha recompilado ela depois de atualizar o ppp.

    estou lendo uns scraps em outros forum, o problema parace q esta no CBCP (Callback Control Protocol), ainda nao sem bem direito.

    mas para desencargo fui no diretorio do rp-pppoe-3.8/src

    ./configure
    make
    make install

    normal !!!
    compilo blz mas nao auth....

    ja estou para ficar doido, pois na minha rede o pessoal ja esta clonando mac depois e preciso imprelemtar isso, o pessoal esta roubando conexao depois, fora os virus.

  14. #14
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão

    gleydson_barbosa,

    Instale o ppp 2.4.4

    depois

    de um make clen
    make distclean

    no rp-pppoe

    feito isso confirme se o rp-pppoe esta usando os headers do ppp 2.4.4 para compilar o rp-pppoe



  15. #15

    Post Recompilando tudo

    Scorpion,


    copiei os includes para dir do source do kernel, estou recompilado e para o diretorio padrao /usr/include/..

    vo recompilar tudo e testar.

    depois te to um retorno !!! muito obrigado por sua ajuda.


    uma pergunta vc esta usando isso ai !?

    quais as versoes q vc esta usando ai !?

  16. #16

    Post Nada !!! não funciona !

    Scorpion,

    nada ainda amigo, ja estou quase desistindo.

    vamos la, nesse momento agora:

    slackware-10.2
    kernel-2.6.16
    freeradius-1.1.3
    ppp-2.4.4
    rp-pppoe-3.8

    desse forma nao autentica nem por decreto...

    o q possa ser !!!!!! ????

    qndo recompilei o ppp-2.4.4 copiei os includes para as pasta padroes de sistema e recompilei o rp-pppoe e nada...

    tentei ate copiar os includes do ppp-2.4.4 para o kernel source e recompilar dai deu erro entao deixei os q vem no kernel mesmo.

    parece q esta tudo ok, mas naum rola.. o o meu dmesg

    PPP generic driver version 2.4.2
    PPP Deflate Compression module registered
    PPP BSD Compression module registered
    PPP MPPE Compression module registered

    sera q pode ser o ppp generic driver !?

    mas nao achei uma versao mais recente q esse


    ja nao sei mais o q fazer !!! alguem pode me dar outra dica !?

    Obrigado.
    Última edição por gleydson_barbosa; 03-11-2006 às 13:06.