+ Responder ao Tópico



  1. #1

    Padrão IPTABLES+L7+ipp2p

    galera, boa tarde, se alguém puder me dar uma ajuda ae agradeceria,
    tipo assim estou implementando o IPP2P aqui na minha rede e o layer 7, e no entando não estou obtendo sucesso, já compilei o kernel e nada de subir sempre gera um erro. por exemplo, segue os erros abaixo.
    Layer 7
    iptables -A INPUT -m layer7 --l7proto http
    iptables: No chain/target/match by that name

    IPP2P

    iptables -A FORWARD -m ipp2p --edk --kazaa --gnu --bit --apple --dc --soul --winmx --ares -j DROP

    iptables v1.3.6: Couldn't load match `ipp2p'

    Try `iptables -h' or 'iptables --help' for more information.


    Bom galera se alguem puder me dar um help ae agradeço

  2. #2
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão

    pelo que parece vc esqueceu de dar um

    modprobe ipt_ipp2p



  3. #3

    Padrão

    Citação Postado originalmente por scorpion Ver Post
    pelo que parece vc esqueceu de dar um

    modprobe ipt_ipp2p
    pois o modulo até subiu, mas ele continua dando a zica,

  4. #4
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão

    voce poderia repetir todo o procedimento de instalacao do ipp2p e colar tudo aqui para que eu possa ver o que vc fez errado?



  5. #5

    Padrão

    segue este link aki.
    LinuxIT - Linux e Tecnologia.

    Em relação ao L7 parece que não coloquei no kernel, mas agora que ativei ele da erro na compilação, até mesmo depois de ter aplicado o patch.

  6. #6
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão

    Voce esta usando debian ?
    confirmou se seus diretorios sao os mesmos do artigo ??

    varios fatos podem afetar o funcionamento..



  7. #7

    Padrão

    Citação Postado originalmente por scorpion Ver Post
    Voce esta usando debian ?
    confirmou se seus diretorios sao os mesmos do artigo ??

    varios fatos podem afetar o funcionamento..
    to sim, já verifiquei, os diretórios, sim, mas parece que o pau ta no kernel, pois não compilei ele com suporte, a L7, pois ta dando erro.

    net/ipv4/netfilter/ipt_layer7.c: In function `match':
    net/ipv4/netfilter/ipt_layer7.c:379: error: too few arguments to function `skb_linearize'
    net/ipv4/netfilter/ipt_layer7.c: At top level:
    net/ipv4/netfilter/ipt_layer7.c:473: warning: initialization from incompatible pointer type
    make[3]: *** [net/ipv4/netfilter/ipt_layer7.o] Error 1
    make[2]: *** [net/ipv4/netfilter] Error 2
    make[1]: *** [net/ipv4] Error 2
    make: *** [net] Error 2

  8. #8
    Under-linux.Org Team Avatar de MarcusMaciel
    Ingresso
    Dec 2000
    Localização
    Boston
    Posts
    1.970
    Posts de Blog
    44

    Padrão

    Qual distro voce usa ?



  9. #9

    Padrão

    Citação Postado originalmente por scorpion Ver Post
    Qual distro voce usa ?
    Debian sarge 3.1

  10. #10



  11. #11

    Padrão

    Citação Postado originalmente por scorpion Ver Post
    ok, vou seguir e posto o resultado aki, ok

  12. #12

    Padrão

    beleza o l7 subiu, agora a unica zica é em relação o ipp2p, segue o erro abaixo.
    insmod /usr/local/lib/iptables/libipt_ipp2p.so
    insmod: error inserting '/usr/local/lib/iptables/libipt_ipp2p.so': -1 Invalid module format

    modprobe /usr/local/lib/iptables/libipt_ipp2p.so
    FATAL: Module /usr/local/lib/iptables/libipt_ipp2p.so not found.

    Se puder dar um help-me agora em relação o ipp2p. fico grato.