+ Responder ao Tópico



  1. #1
    cantisan
    Visitante

    Thumbs down Openvpn serviço

    Pessoal,

    Instalei a openvpn sem problemas, só tenho uma dúvida, coloquei no rc.local o comando que executo para iniciar o processo:

    /etc/openvpn/openvpn --config server.conf &

    Mas nunca quando eu dou boot a openvpn está no ar, creio que deve ser algum conflito com o iptables ou algum outro serviço que ainda está iniciando, alguém tem uma dica ? Tem como eu dar um sleep nisso para aguardar que tudo seja iniciado ?

  2. #2

    Padrão

    verifique a localizacao do binario, com certesa nao e em /etc/openvpn/openvpn





    Citação Postado originalmente por cantisan Ver Post
    Pessoal,

    Instalei a openvpn sem problemas, só tenho uma dúvida, coloquei no rc.local o comando que executo para iniciar o processo:

    /etc/openvpn/openvpn --config server.conf &

    Mas nunca quando eu dou boot a openvpn está no ar, creio que deve ser algum conflito com o iptables ou algum outro serviço que ainda está iniciando, alguém tem uma dica ? Tem como eu dar um sleep nisso para aguardar que tudo seja iniciado ?



  3. #3

    Padrão

    O /etc/rc.local, até onde eu me lembre (pode ser que tenha mudado), é executado após os diretórios referentes ao seu runlevel. Se você tem um script de firewall e ele está sendo executado em algum diretório de inicialização, não é isso.

    Mas eu concordo com o quê o amigo acima falou. Provavelmente o binário não se encontra ali.


    Abraços!

  4. #4

    Padrão

    Pelo que eu sei, o comando é openvpn --config file.conf --daemon

    Até!!

    Mtec



  5. #5
    cantisan
    Visitante

    Thumbs down vamos lá..

    Pessoal,

    Desculpe se não fui claro, quando executo o comando que está no rc.local funciona sem problemas, inclusive, fiz um copy & paste para evitar que digitasse algo diferente do que está lá.. a questão é justamente na inicialização, todas as outras linhas que são executadas funcionam, menos a ultima do openvpn.

    Tem como dar um sleep para de repente aguardar "alguma coisa" ? Como ?

  6. #6

    Padrão

    cara...

    vc colocou a linha do openvpn como a última??

    se for isso, veja se antes dela tem algum "exit 0" ou coisa parecida...

    valeu



  7. #7
    cantisan
    Visitante

    Padrão heheeh..

    Tem não sô ! :-)