+ Responder ao Tópico

vnc



  1. #1

    Padrão vnc

    pessoal, tenho um cliente q precisa acessar a maquina dele externamente usando o vnc, mas cmo fazr isso ja q o cliente n tem ip real???
    desde ja agradeço a ajuda dos amigos.

  2. #2

    Padrão

    Redireciona a porta que ele pedir pro vnc pro computador dele e pronto ta resolvido.

    falows



  3. #3

    Padrão

    com essa regra daria certo???

    chain=dstnat dst-address=201.18.x.x protocol=tcp dst-port=5900 action=dst-nat to-addresses=10.0.0.41 to-ports=5900

  4. #4

    Padrão

    /ip firewall nat
    add chain=dstnat dst-address=200.x.x.x protocol=tcp dst-port=4040 action=dst-nat to-addresses=ip interno to-ports=3389

    add chain=dstnat dst-address=200.x.x.x protocol=udp dst-port=4040 action=dst-nat to-addresses=ip interno to-ports=3389

    add chain=srcnat out-interface=WAN src-address=ip interno action=src-nat to-addresses=200.x.x.x to-ports=0-65535

    a porta vc coloca a q vc escolher...WAN é a interface onde entra o seu sinal de internet...

    Posta ae se deu certo.



  5. #5

    Padrão

    Citação Postado originalmente por cgrellier Ver Post
    /ip firewall nat
    add chain=dstnat dst-address=200.x.x.x protocol=tcp dst-port=4040 action=dst-nat to-addresses=ip interno to-ports=3389

    add chain=dstnat dst-address=200.x.x.x protocol=udp dst-port=4040 action=dst-nat to-addresses=ip interno to-ports=3389

    add chain=srcnat out-interface=WAN src-address=ip interno action=src-nat to-addresses=200.x.x.x to-ports=0-65535

    a porta vc coloca a q vc escolher...WAN é a interface onde entra o seu sinal de internet...

    Posta ae se deu certo.
    so umas duvidas:
    200.x.x.x seria o ip do meu server, ou eu teria q usar outro ip real livre???
    Wan = seria a interface q esta conectada com meu router? por onde chega o link???
    desde ja agradeço.

  6. #6

    Padrão Isso...

    Vc usa o ip real do seu MK...o q esta por traz do nat e a wan á a interface q entra o link...

    Vc deve saber em q porta o VNC esta trabalhando e direcionar pra porta 4040 por ex...

    na regra tudo q ven do IP interno + potra x, vai pro IP REAL na porta 4040, entendeu???



  7. #7

    Padrão

    Citação Postado originalmente por cgrellier Ver Post
    Vc usa o ip real do seu MK...o q esta por traz do nat e a wan á a interface q entra o link...

    Vc deve saber em q porta o VNC esta trabalhando e direcionar pra porta 4040 por ex...

    na regra tudo q ven do IP interno + potra x, vai pro IP REAL na porta 4040, entendeu???
    entendi em partes (eita bixinho burro eu!!huahua) eu n teria q fazer o redirecionamento pra q tudo q vinhesse do ipinterno:5900 (porta do nvc) e pro ip externo:5900????

  8. #8

    Padrão Acho q sim...

    Burro nada estamos aki pra aprender rsssssssssssssssssss

    Nao estou no meu MK agora mas tenta ai e diz se funcionou...mas acho q funciona sim.



  9. #9

    Padrão

    Bom pessoal espero poder ajudar sobre casos de que pessoas usem VNC, GoToMyPc, Pc Anyware. pessoal parem de usar esse programa e começem a usar o LOGMEIN que funciona pelo webbroswer e é o melhor que eu ja vi não precisa configurar nada e alem disso pode ser acessado de qualquer maquina....outra coisa tambem que é gratuito...melhor do que isso só 2 disso rsrsr...........

  10. #10

    Padrão

    fiz assim, so q nao funcionou:
    ;;; VNC
    chain=dstnat dst-address=201.x.x.226 protocol=tcp dst-port=5900 action=dst-nat
    to-addresses=10.0.0.41 to-ports=5900

    7 chain=dstnat dst-address=201.x.x.226 protocol=udp dst-port=5900 action=dst-nat
    to-addresses=10.0.0.41 to-ports=5900

    8 chain=srcnat out-interface=wireless src-address=10.0.0.41 action=src-nat to-addresses=201.x.x.226
    to-ports=0-65535

    onde:
    201.x.x.226 é o ip do meu servidor mk
    10.0.0.41 é o ip do meu cliente
    5900 é a porta do nvc
    out-interface=wireless é a interface q o cliente esta conectado

    so q n funcionou, minhas duvidas são:
    - essas regra ficam antes do nat???
    - out-interface é a interface em q meu cliente esta conectado??? desde ja agradeço.
    Última edição por halbebruno; 16-12-2006 às 14:05.



  11. #11

    Padrão Vamos la....

    out-interface=wireless é a interface q o cliente esta conectado

    ta errado é onde o sinal de internet entra no seu MK (wan)
    Ps. Nao se confunda com WLAN....onde quer dizer interface wireless.

    Caso ainda nao funcione troca a porta dst-port=5900 para 4040 por ex

    A regra fica depois do nat.

    Diz ae se funcionou, nao tem o pq de nao funcionar rssssss!!!!!!!!!!

  12. #12

    Padrão

    Citação Postado originalmente por cgrellier Ver Post
    out-interface=wireless é a interface q o cliente esta conectado

    ta errado é onde o sinal de internet entra no seu MK (wan)
    Ps. Nao se confunda com WLAN....onde quer dizer interface wireless.

    Caso ainda nao funcione troca a porta dst-port=5900 para 4040 por ex

    A regra fica depois do nat.

    Diz ae se funcionou, nao tem o pq de nao funcionar rssssss!!!!!!!!!!
    esqueci de quesionar, é dpois do nat e antes da minha regra pro proxy?? ou dpois das 2???



  13. #13

    Padrão

    fiz assim e n funcionou:
    ;;; VNC
    chain=dstnat dst-address=201.x.x.226 protocol=tcp dst-port=4040 action=dst-nat
    to-addresses=10.0.0.41 to-ports=5900

    9 chain=dstnat dst-address=201.x.x.226 protocol=udp dst-port=4040 action=dst-nat
    to-addresses=10.0.0.41 to-ports=5900

    10 chain=srcnat out-interface=public src-address=10.0.0.41 action=src-nat to-addresses=201.18.137.226
    to-ports=0-65535
    obs. a regra esta dpois da minha regra d nat e do proxy

  14. #14

    Padrão

    você pode usar um ip da sua faixa se você tiver algum ipreal sobrando pra fazer isso, faz a regra na firewall tipo 200.223.20.233:5900 direcionada a tal ip da rede interna e se precisa colocar mais depois pra responder no mesmo ip so mudar o numero da porta no firanl tipo colocar a 5991 para outro ip ja, eu faço aqui assim mais naum uso MK uso server linux mesmo com iptables.