+ Responder ao Tópico



  1. #41

    Padrão

    Citação Postado originalmente por Nazzi Ver Post
    Galera, eu uso a action same pra fazer meu redirecionamento, funciona 100%..

    /ip firewall nat
    add chain=dstnat protocol=tcp dst-port=80 src-address-list=Block action=same to-addresses=IP_servidor_web to-ports=porta_do_servidor_web same-not-by-dst=no comment="Controle de Clientes com Falta de Pagamento" disabled=no

    / ip firewall address-list
    add list=Block address=IP_Cliente comment="" disabled=yes

    / ip firewall filter
    add chain=forward protocol=tcp dst-port=porta_do_servidor_web src-address-list=Block action=accept comment="- - - - - - - - - - Bloqueio de Usuarios por Falta de Pagamento - - - - - - - - - -" disabled=no
    add chain=forward protocol=udp dst-port=53 src-address-list=Block action=accept comment="" disabled=no
    add chain=forward src-address-list=Block action=drop comment="" disabled=no

    O que eu gosto nessa bagunça é que eu bloqueio por portas e só preciso adicionar os ips em address-list em firewall.

    Abraços...

    com PPPoe?

  2. #42

    Smile

    bom eu testei e naum deu ceto com redirecionamento para para proxy na porta 3128 , ai desativei o redirecionamneto e ai funcionou , quando eu ativo o redireciomaneto do proxy ai naum funciona.... tenho um servidor proxy separado do mikrotik. rodando o suse linux 9.3...

    alguem tem alguma sugestão para funcionar neste caso ...


    deste de ja agradeço...



  3. #43

    Padrão

    No meu caso da pagina nao pode ser encontrada... quando o cliente tenta navegar... e nao aparece o site que indiquei para o redirecionamento e quando eu digito o site direto no navegador ele entra normal, ou seja o MK nao esta fazendo o redirecionamento normal...
    Outra coisa que percebi eh que quando tiro o proxy do navegador o cliente navega normal mesmo o ip estando bloqueado.

  4. #44

    Padrão

    O problema da navegação sem o proxy eu resolvi movendo a regra de bloqueio para o topo da lista... agora o problema de redirecionamento eu nao consegui...

    O site que configurei nao aparece pro cliente, mas quando o cliente tenta acessar ele via navegador aparece normal. O problema nao esta no servidor web e sim no mk.



  5. #45

    Padrão Pedido

    Cara vc's são demais, aki eu só aprendo cada vez mais e peço o seguinte a vocês, aguem pode montar um passo a passo de todo o procedimento inclusive de como montar o servidor de web, onde fica a pagina de redirecionamento. Desde já agradeço pela estima consieração.

  6. #46

    Padrão

    Citação Postado originalmente por olivionet Ver Post
    Cara vc quer fazer um atraso tipo assim...

    O cliente loga dai cai numa página depois de um certo tempo vai pra página q ele tava navegando ?

    Se for isso msm, me da um tok q eu te passo como eu fiz !! Vlz !!
    Amigo me ajuda então é desta forma mesmo que eu o precisando aki, valeu. um abraço

    Monta um passo a passo

    [email protected]



  7. #47

    Padrão

    Bom.. um passo a passo seria muito interessante,
    vamos reunir informaçoes e organizar isso ai!

  8. #48

    Padrão Redirecionar clientes em atraso para página local

    Ola Alexandre, vc consegui fazer com que fosse emitido esse aviso de tempo em tempo ?



  9. #49

    Padrão

    Ola

    No caso este q fiz e estatico qdo bloqueio o cliente bloqueio de vez

    para fazer isto q vc quer tem q criar um script para habilitar/desabilitar a regra de nat q vc criou para emitir o aviso... e depois criar um agendamento para executar de tempos em tempos por exemplo a cada 30 mim...

    Alexandre

  10. #50

    Padrão Redirecionar clientes em atraso para pagina local

    vc falou sobre melhorar de um jeito a ficar emitindo um aviso de tempo em tempo!

    ve consegui fazer isso ?

    se a resposta for sim.
    tem como vc me ajudar
    grato

    [email protected]



  11. #51

    Padrão Redirecionar clientes em atraso para página local

    se nao for pedir demais, tem como vc me mandar um exemplo ?

    ficarei muito agradecico se for possivel !


    abraço


    Adriano
    [email protected]

  12. #52

    Padrão

    Citação Postado originalmente por vinnyz Ver Post
    O problema da navegação sem o proxy eu resolvi movendo a regra de bloqueio para o topo da lista... agora o problema de redirecionamento eu nao consegui...

    O site que configurei nao aparece pro cliente, mas quando o cliente tenta acessar ele via navegador aparece normal. O problema nao esta no servidor web e sim no mk.
    O problema deve estar na porta que voce escolheu em action dst-nat. Tem que colocar a porta 80 pra funcionar...



  13. #53

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Eai galera quanto tempo, aqui esta corrido esse final de ano, por andei sumido, em falando final de ano um Feliz Natal a todos daqui do forum.

    Ta ai um exemplo bem simples que você pode usar.

    /ip firewall nat
    add chain=dstnat src-address=IP_CLIENTE_BLOQUEADO protocol=tcp dst-port=80 action=dst-nat to-addresses=IP_SERVIDOR_WEB_AVISO to-ports=0-65535 \
    comment="BLOQUEIO" disabled=no
    Acredito que a regra funcionará melhor como está abaixo:

    /ip firewall nat
    add chain=dstnat src-address=IP_CLIENTE_BLOQUEADO protocol=tcp action=dst-nat to-addresses=IP_SERVIDOR_WEB_AVISO to-ports=80 \
    comment="BLOQUEIO" disabled=no

    Se colocar dst=port=80 o mk vai filtrar apenas as requisões desta porta e deixar passar as outras. Outra dica é que voce pode criar uma lista de endereços e atribuir pela guia advanced ao inves de usar src-address em general

  14. #54

    Padrão Bloqueio Com hotspot

    Galera.. pra quem quer bloquear o cliente com um site de aviso e usa hotspot, eu uso uma solução aque que eu mesmo adaptei..

    Olha aeh o tópico que iniciei!!!

    https://under-linux.org/forums/mikro...-servidor.html

    vlw!
    PZ
    Última edição por PabloZ; 25-12-2007 às 22:10.



  15. #55

    Padrão Bloqueio Com hotspot

    Faz o seguinte acesse pelo winbox va na aba ip/hotspot/user e cria uma nova profile com o mone atrasado ou como quizer apos criar o profiles vc so altera a opcão de ADVERTISE seleciona ela e em advertise url vc coloca o endereço ip do mikrotik ex 192.168.x.x/atrasado.html em advertise interval vc coloca o tempo qe quizer em advertise timeout immediately .apos isso vc acessa o seu mikroti via ftp e copia a pasta hotspot dentro dela vc acrescenta a pagina que vc criou com a cobrança do usuario lembrando salve como ex atrasado.html depois e so mudar os usuarios para a nova profile e ele vão receber essa menssagem de acordo com o tempo que vc colocar vc tambem pode reduzir a banda dele.qualquer duvida estamos ai o meu fuciona show.um feliz ano novo para todos.

  16. #56

    Padrão

    meu mkt esta como router.

    tenho esse bloqueio de clientes atrasados funcionando assim:

    ;;; BLOQUEIO - CLIENTES EM ATRASO
    chain=dstnat dst-address=!10.x.x.254 src-address-list=BLOQUEIO-ATRASO action=dst-nat to-addresses=10.x.x.254 to-ports=81

    todo acesso que nao seja ao meu servidor, seja qual for o protocolo e/ou porta é redirecionado para o meu servidor na porta 81.

    dessa forma nao precisa fazer regra para bloqueio dos outros serviços que nao sejam HTTP (porta 80).

    fiz um VirtualHost no apache na portat 81 com a pagina de bloqueio.

    ai so vou no ip firewall address list e adiciono o ip do cliente inadimplente na lista BLOQUEIO-ATRASO

    funfa blz.

    PS: Sobre o aviso de tempos em tempos, eu creio que seja possivel sim, vou tirar um tempo esta semana para fazer esses testes

    Neon



  17. #57

    Padrão

    como direcionar para pagina no proprio MK, via ppoe? alguem sabe?
    beijocas

  18. #58

    Padrão

    Citação Postado originalmente por zipfile Ver Post
    como direcionar para pagina no proprio MK, via ppoe? alguem sabe?
    beijocas

    Eis a solução:

    https://under-linux.org/forums/mikro...ppoe-dhcp.html



  19. #59

    Padrão Exemplo de Bloqueio com Iptables no Linux

    Veja ai um exemplo tambem muito facil de se fazer...

    iptables -t nat -A PREROUTING -p tcp -s IP_DO_CLIENTE -j DNAT --to-destination IP_SERVIDOR_TELA_BLOQUEIO

    Obs: No script acima o bloqueio eh de todas as portas e não apenas a Port 80.

    Espero ter ajudado... Vlws...

  20. #60

    Padrão ERRO direcionar cliente atrazado

    Citação Postado originalmente por tiagomatias Ver Post
    Eai galera quanto tempo, aqui esta corrido esse final de ano, por andei sumido, em falando final de ano um Feliz Natal a todos daqui do forum.

    Ta ai um exemplo bem simples que você pode usar.

    /ip firewall nat
    add chain=dstnat src-address=IP_CLIENTE_BLOQUEADO protocol=tcp dst-port=80 action=dst-nat to-addresses=IP_SERVIDOR_WEB_AVISO to-ports=0-65535 \
    comment="BLOQUEIO" disabled=no

    CARO COLEGAS FIZ ESTE DIRECIONAMENTO CERTO COMO CITADO ACIMA MAS DA UM ERRO QUANDO VOU TENTAR NAVEGAR TIPO NÃO EXIBE A PAGINA CORRETA APENAS DA ESTE ERRO. E SE EU NAVEGAR NORMAL PELO NAVEGADOR SEM O DIRECIONAMENTO A PAGINA DE NOTIFICAÇÃO FUNCIONA SEM PROBLEMAS.

    erro:
    Great Success !
    Apache is working on your cPanel® and WHM™ Server


    If you can see this page, then the people who manage this server have installed cPanel and WebHost Manager (WHM) which use the Apache Web server software and the Apache Interface to OpenSSL (mod_ssl) successfully. They now have to add content to this directory and replace this placeholder page, or else point the server at their real content.
    ATTENTION!

    If you are seeing this page instead of the site you expected, please contact the administrator of the site involved. (Try sending an email to <[email protected]domain>.) Although this site is running cPanel, WebHost Manager, and Apache software it almost certainly has no other connection to cPanel Inc. or the Apache Group. Please do not send mail about this site or its contents to cPanel Inc. or the Apache Group.
    About cPanel:

    cPanel is a leading provider of software for the webhosting industry. If you would like to learn more about cPanel please visit our website at www.cpanel.net. Please be advised that cPanel Inc. is not a web hosting company, and as such has no control over content found elsewhere on this site.
    About Apache HTTP Server:

    The Apache HTTP Server is an open source web server which powers many of the worlds web sites. The Apache HTTP server is part of the Apache Group's many influential projects. Their efforts have helped shape much the world wide web, and they continue to be a dominating force in the web hosting industry.
    http://www.cyberpointcandoi.com.br/s...powered_by.gifhttp://www.cyberpointcandoi.com.br/s.../apache_pb.gif

    este erro q ocorre alguem pode me ajudar.

    e o endereço de bloqueio é este:

    BLOQUEIO DE CLIENTES EM ATRAZO.