O dpkg pergunta se você quer sobreescrever os seus arquivos de configuração, mas eu recomendo fazer um arquivo tar.gz deles antes de atualizar sua versão. Para atualizar, eu recomendo que você encontre aí pela net um repositório não-oficial que contenha os pacotes do Squid. Senão, compila na mão OU utilize o alien para converter um eventual RPM para DEB (Não recomendo).


Abraços!