Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. Citação Postado originalmente por WhiteTiger Ver Post
    cara, tente assim:

    Código :
    # env LANG=iso_8859-1
    # mrtg
    blz, mais quando eu execulto ... ele posta o seguinte :

    [root@logos ~]# env LANG=iso_8859-1
    HOSTNAME=logos
    SHELL=/bin/bash
    TERM=xterm
    HISTSIZE=1000
    OLDPWD=/var/www/mrtg
    USER=root
    LS_COLORS=no=00:fi=00:di=00;34:ln=00;36i=40;33:so=00;35:bd=40;33;01:cd=40;33;01r=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
    MAIL=/var/spool/mail/root
    PATH=/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin
    INPUTRC=/etc/inputrc
    PWD=/root
    LANG=iso_8859-1
    SHLVL=1
    HOME=/root
    LOGNAME=root
    LESSOPEN=|/usr/bin/lesspipe.sh %s
    G_BROKEN_FILENAMES=1
    _=/bin/env


    Porem quando execulto o mrtg ... dá o danado erro :

    [root@logos ~]# /usr/bin/mrtg /var/www/mrtg/mrtg.conf
    -----------------------------------------------------------------------
    ERROR: Mrtg will most likely not work properly when the environment
    variable LANG is set to UTF-8. Please run mrtg in an environment
    where this is not the case. Try the following command to start:

    env LANG=C /usr/bin/mrtg /var/www/mrtg/mrtg.conf
    -----------------------------------------------------------------------

    Porem ... coloquei no crontab:

    */3 * * * * /bin/env LANG=C /usr/bin/mrtg /var/www/mrtg/mrtg.conf

    e ele tá gerando os graficos ...

    Falow ...

  2. e se tentar assim?

    [code]
    # env LANG=iso_8859-1 /usr/bin/mrtg /var/www/mrtg/mrtg.conf
    # mrtg
    [code]



  3. Esse problema também acontece no SARG. Tente fazer da seguinte maneira:

    Código :
    # export LANG=C

    E tentar gerar novamente.


    Abraços!

  4. Citação Postado originalmente por xstefanox Ver Post
    Esse problema também acontece no SARG. Tente fazer da seguinte maneira:

    Código :
    # export LANG=C

    E tentar gerar novamente.


    Abraços!
    Valew mais uma xstefanox,

    Funfou blz ... tá gerando bonitinho ...

    Valew ...






Tópicos Similares

  1. MRTG - Como fazer..???
    Por soyeu no fórum Servidores de Rede
    Respostas: 0
    Último Post: 20-12-2002, 09:36
  2. Mrtg+Squid
    Por uDiVan no fórum Servidores de Rede
    Respostas: 1
    Último Post: 26-11-2002, 15:24
  3. MRTG - urgente !
    Por thiagog no fórum Servidores de Rede
    Respostas: 3
    Último Post: 12-11-2002, 17:20
  4. Mrtg Rodar Automático
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 17-10-2002, 00:10
  5. Squid+Mrtg
    Por uDiVan no fórum Servidores de Rede
    Respostas: 1
    Último Post: 04-10-2002, 08:56

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L