+ Responder ao Tópico



  1. #1

    Angry Proxy que funcione!!!

    Bem, não sei se todos aqui vem acompanhando minha luta para implantar um proxy transparente aqui na faculdade que trabalho, mas quando eu digo LUTA é porque já se tornou uma luta mesmo, e eu estou perdendo feio.
    Não sei porque cargas d'agua que quando eu habilito o serviço de proxy no meu gateway, o upload da minha rede vai nas alturas e cola nos 100%, deixando a navegabilidade totalmente horrível. Já pensei que fosse tudo... hardware, software, placas de rede, minha rede, mas nada resolve o problema.
    Estou usando um Intel Celeron de 2.4 Ghz, 1024 Mb de RAM, HD de 80 GB, 3 Placas de rede Gigabit da 3com e um link dedicado da telemar de 256kbps, tudo isso controlado pelo Debian 3.1 Sarge.

    Então gostaria da ajuda de vocês para que resolva isso, ou seja, será que o Debian pode estar fazendo isso? Qual seria o melhor S.O linux para trabalhar com gateway e proxy transparente? O hardware está satisfatório ou preciso melhorar algo?

    Então é isso galera, espero que vocês possam me ajudar contribuindo com as respostas para essas perguntas, e agradeço a todos desde já.

  2. #2

    Padrão

    Tirando o processador Celeron do seu servidor, ele está satisfatório sim. Em relação à distribuição que você está utilizando, você está bem servido também.

    Agora... você já tentou sniffar a rede para saber para onde estão indo as conexões? As conexões estão partindo do seu próprio servidor ou é uma conexão que passa pelo NAT da sua rede?



  3. #3

    Padrão

    Cara eu não tentei fazer porque eu não sei fazer, hehehe. Mas posso tentar cara, eu não sei mais o que fazer, e se puder me dar umas dicas sobre isso.

  4. #4

    Padrão

    Então não fala que é o proxy que não funciona, hehehe.

    Eu li ali em cima que tu tá usando Debian... instalar o iptraf pra ver de onde tá vindo o tráfego.

    Código :
    # apt-get install iptraf
    # iptraf



  5. #5

    Padrão

    O que eu disse que nao sabia era sniffar, mas vou instalar isso ai e ja te falo.

    [UPDATE]

    Cara estou chegando aqui e tem uma super atividade com a eth0, mesmo com ninguém conectado a internet, não sei bem o que pode estar acontecendo, pois não sei bem analizar esses registros, como posso pegar um relatório disso que está acontecendo para colocar aqui?
    Última edição por juniovitorino; 03-02-2007 às 07:09.

  6. #6

    Padrão

    iptraff vc ve o trafego em tempo real e ve qual ip ta consumindo o upload total...

    com certeza vc deve ter alguma maquina com virus.. aqui tive varios casos de maquinas de clientes.. mas como aqui faço roteamento estatico para cada cliente, um cliente nao atrapalhou o outro (por todo pacote diferente da maquina ser dropado)... apenas ficava lentro para este cliente em questao...



  7. #7

    Padrão

    é mas o foda e que se eu paro o squid, tudo volta ao normal, se fosse uma maquina da rede, o consumo deveria continuar mesmo sem o squid.

  8. #8

    Padrão

    Kra posta seu squid.conf ai pra gente, outra coisa, esse erro so acontece qd se faz download? Se o pessoal ficar so abrindo paginas tb fica lento assim? Qual a versão do squid vc ta usano?
    Eu tenho um proxy com a maquina + ou - nessa configuração da sua em uma rede com 100 máquinas e ta de boa, so q no meu caso eu uso o slackware, + qt a distro isso indifere.



  9. #9

    Padrão

    Citação Postado originalmente por tuxson Ver Post
    Kra posta seu squid.conf ai pra gente, outra coisa, esse erro so acontece qd se faz download? Se o pessoal ficar so abrindo paginas tb fica lento assim? Qual a versão do squid vc ta usano?
    Eu tenho um proxy com a maquina + ou - nessa configuração da sua em uma rede com 100 máquinas e ta de boa, so q no meu caso eu uso o slackware, + qt a distro isso indifere.
    só postando pra sabermos o que está acontecendo ...
    pode ter até uma máquina zumbi na tua rede ... que pode tá enchendo teu cache de besteiras e milhares de conexões .... verifica isso tambem ...
    tira o pessoal da rede ... e verifica só com uma máquina ...
    ai você faz a eliminação ...

    Falow ...

  10. #10

    Padrão

    Citação Postado originalmente por rootmaster Ver Post
    só postando pra sabermos o que está acontecendo ...
    pode ter até uma máquina zumbi na tua rede ... que pode tá enchendo teu cache de besteiras e milhares de conexões .... verifica isso tambem ...
    tira o pessoal da rede ... e verifica só com uma máquina ...
    ai você faz a eliminação ...

    Falow ...
    É já fiz isso também, tirei todo mundo e deixei só a maquina e a net, e continuou. Mas olhem meu squid.conf.

    Código :
    ################################################################################
    ####                  Arquivo de configuração do Squid 2.5.9                ####
    ####                   Por Junio Vitorino - [email protected]                 ####
    ################################################################################
     
     
    	hierarchy_stoplist cgi-bin ?
    	acl QUERY urlpath_regex cgi-bin \? no_cache deny QUERY
     
    ### Cache
     
    	cache_mem 128 MB
    	cache_swap_low 90
    	cache_swap_high 95
    	maximum_object_size 4096 KB
    	minimum_object_size 0 KB
    	maximum_object_size_in_memory 4000 KB
    	cache_replacement_policy lru
    	memory_replacement_policy lru
    	cache_dir ufs /var/spool/squid 300 16 256
    	cache_access_log /var/log/squid/access.log
    	cache_log /var/log/squid/cache.log
    	cache_swap_log /var/log/squid/swap.log
    	debug_options ALL, 2
    	dns_nameservers 200.195.77.226
    #	client_netmask 255.255.255.0 
    	error_directory /usr/share/squid/errors/Portuguese
     
    ### Fim de cache
     
    	hosts_file /etc/hosts
    	refresh_pattern ^ftp:		1440	20%	10080
    	refresh_pattern ^gopher:	1440	0%	1440
    	refresh_pattern .		0	20%	4320
     
    ### Acl's Personalizadas
     
    	acl admin src 10.0.1.230 10.0.1.234
    	acl proibido url_regex -i "/etc/squid/filtros/proibido"
    	acl liberado url_regex -i "/etc/squid/filtros/liberado"
    	acl ext_block url_regex -i "/etc/squid/filtros/ext_block"
    	acl ext_unblock url_regex -i "/etc/squid/filtros/ext_unblock"
    	acl dns_block dstdomain "/etc/squid/filtros/dns_block"
    	acl dns_unblock dstdomain "/etc/squid/filtros/dns_unblock"
    	acl blacklist url_regex -i "/etc/squid/filtros/blacklist"
     
    ### Fim Acl's Personalizadas
     
    ### http_access personalizadas
     
            http_access deny proibido !liberado !admin
            http_access deny ext_block !ext_unblock !admin
    	http_access deny dns_block !dns_unblock !admin
    	http_access deny blacklist !admin
     
    ### Fim http_access personalizadas
     
    ### Acl's Padrões squid.conf
     
    	acl all src 0.0.0.0/0.0.0.0	
    	acl manager proto cache_object
    	acl localhost src 127.0.0.1/255.255.255.255
    	acl to_localhost dst 127.0.0.0/8
    	acl SSL_ports port 443 563	# https, snews
    	acl SSL_ports port 873		# rsync
    	acl Safe_ports port 80		# http
    	acl Safe_ports port 21		# ftp
    	acl Safe_ports port 443 563	# https, snews
    	acl Safe_ports port 70		# gopher
    	acl Safe_ports port 210		# wais
    	acl Safe_ports port 1025-65535	# unregistered ports
    	acl Safe_ports port 280		# http-mgmt
    	acl Safe_ports port 488		# gss-http
    	acl Safe_ports port 591		# filemaker
    	acl Safe_ports port 777		# multiling http
    	acl Safe_ports port 631		# cups
    	acl Safe_ports port 873		# rsync
    	acl Safe_ports port 901		# SWAT
    	acl Safe_ports port 1483	# SQLSERVER
    	acl purge method PURGE
    	acl CONNECT method CONNECT
     
    ### Fim Acl's Padrões squid.conf
     
    ### Http_Access padrão squid.conf
     
    	http_access allow manager localhost
    	http_access deny manager
    	http_access allow purge localhost
    	http_access deny purge
    	http_access deny !Safe_ports
    	http_access deny CONNECT !SSL_ports
    	http_access allow localhost
    	http_access allow all
    	http_reply_access allow all
     
    ### Fim http_access padrão squid.conf
     
    #	icp_access allow all
    #	miss_access allow all
    	visible_hostname gateway.facsal.br
    	coredump_dir /var/spool/squid
     
    ### Transparencia
     
    	httpd_accel_host virtual
    	httpd_accel_port 80
    	httpd_accel_single_host off
    	httpd_accel_with_proxy on
    	httpd_accel_uses_host_header on
    	http_port 3128
     
    ### Fim de Transparencia



  11. #11

    Padrão

    Coloca lá no inicio da tua conf ...

    http_port IP_DA_MAQUINA_SQUID:3128

    ex: http_port 192.168.0.254:3128

    Pra vê se não tem ninguem usando seu proxy de fora ...


    Falow ...

  12. #12

    Wink

    Bom Dia!!!

    Bom eu estava com este problema aqui na empresa.

    Primeiro vc olha se tem alguen usando sua banda. use o comando

    netstat -atun squid ( como root )

    Ai vai te falar todas as maquinas que estao conectadas no proxy se tiver algun ip que nao seja de sua rede interna é pq tem alguen conectado no seu proxy usando sua banda ehhehehe

    Comigo foi assin o cara conectava e ficava disparando span creio eu pq usava a porta 25

    Aguardo seu retorno.



  13. #13

    Padrão

    Caraca, SOD vou ver isso cara, pois aqui estamos com problema de span mesmo, assim que chegar vou ver isso lá, valeu pela dica.

  14. #14



  15. #15

    Padrão

    vc ta louco

    maximum_object_size_in_memory 4000 KB

    uauhauha

    abaixa isso pra 64 KB