+ Responder ao Tópico



  1. #1
    joselitumore
    Visitante

    Padrão Firewall está bloqueando o acesso externo do meu FTP

    ola galera...estou começando com vcs aki no underlinux.....bom...problemas....quando o pessoal usuario de windows (éca) tentam acessar meu ftp da o seguinte erro: usuario pode naum ter permissão nas pastas, verifique as permissões e o tempo limite estorou......porem quem tem linux e tenta acessar o meu ftp via linux consegue acessar nrmal.....pelo internet explorer chega ateh pedir usuario e senha, depois que da o erro....alguem ja passou por isso ou pode me dar uma luz? abraços...obs uso vsftpd

  2. #2

    Padrão

    As máquinas GNU/Linux estão em alguma rede diferente? Tentando acessar por uma porta diferente? Já verificou o modo passivo/ativo do servidor?

    Abraços!



  3. #3
    wrochal
    Visitante

    Padrão

    Caro,

    Desative do Browser a opção de Passivo, e veja se seu servidor firewall carrega o modulo ip_nat_ftp.

    Abraços,

  4. #4
    joselitumore
    Visitante

    Padrão

    Primeiramente obrigado pela atenção....Bomo em relação ao passivo/ativo como verifico isso? e sobre os modlos do ftp tenho tres modulos levantados anted de qq regra de iptables ... modprobe iptable_nat modprobe ip_nat_ftp e modprobe ip_conntrack_ftp



  5. #5
    joselitumore
    Visitante

    Padrão

    A rede la meu amigo esta na mesma faixa..eth0 pra internet e eth1 (192.168.0.0) para rede local o linus tem o ip 192.168.0.254......o problema eh que local o ftp funciona tando pelo Firefox ou pego Internet explorer......agora externo só quem usa linux conseguiu acessar meu ftp...que usa IE naum conseguiu acessar....

  6. #6

    Padrão

    Kra uma vez eu tive esse problema e resolvi assim:
    Clica no menu
    Ferramentas
    Oções da Internet
    Avançadas
    Usar FTP passivo (para compatibilidade com firewalls e modems DLS)

    Ai vc desmarca essa opção...
    Outra coisa, se a pessoa usar um cliente FTP em vez do IE funciona?

    Espero ter ajudado



  7. #7
    joselitumore
    Visitante

    Padrão deu certo

    uai raoaiz...num eh que deu certo..desativei o negocio la e foi...vlw obrigado a todos