+ Responder ao Tópico



  1. #1

    Padrão VMware em kernel 2.6.20

    Fala galera, como estão as coisas??

    pessoal, estou com um problema aqui pra rodar o wmware com kernel 2.6.20, alguém já teve este tipo de problema???

    estou usando a última versão do vmware, quando executo o vmware-config.pl aparece o seguinte erro:

    Using 2.6.x kernel build system.
    make: Entering directory `/tmp/vmware-config0/vmmon-only'
    make -C /lib/modules/2.6.20lgf-01/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
    make[1]: Entering directory `/usr/src/linux-2.6.20'
    CC [M] /tmp/vmware-config0/vmmon-only/linux/driver.o
    In file included from /tmp/vmware-config0/vmmon-only/linux/driver.c:80:
    /tmp/vmware-config0/vmmon-only/include/compat_kernel.h:21: error: syntax error before "compat_exit"
    /tmp/vmware-config0/vmmon-only/include/compat_kernel.h:21: warning: type defaults to `int' in declaration of `_syscall1'
    /tmp/vmware-config0/vmmon-only/include/compat_kernel.h:21: warning: function declaration isn't a prototype
    /tmp/vmware-config0/vmmon-only/include/compat_kernel.h:21: warning: `_syscall1' declared `static' but never defined
    make[2]: *** [/tmp/vmware-config0/vmmon-only/linux/driver.o] Error 1
    make[1]: *** [_module_/tmp/vmware-config0/vmmon-only] Error 2
    make[1]: Leaving directory `/usr/src/linux-2.6.20'
    make: *** [vmmon.ko] Error 2
    make: Leaving directory `/tmp/vmware-config0/vmmon-only'
    Unable to build the vmmon module.

    For more information on how to troubleshoot module-related problems, please
    visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
    "http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

    Execution aborted.
    pelo que percebi o vmware ainda não dá suporte a este kernel, será que é isso mesmo???

    valeu

  2. #2

    Padrão

    Tá com cara de biblioteca faltando.



  3. #3

    Padrão

    será??? mas se eu der boot com o kernel 2.6.19.1 funciona belezudo...

    por isso to achando que é pendência de kernel 2.6.20...

    a versão 5.5.3 do vmw saiu antes do kernel 2.6.20

    valeu

  4. #4

    Padrão

    Então, mas continua sendo problema de biblioteca. Alguns programas geralmente utilizam os headers dos kernels para compilar algumas coisas de forma otimizada (Ou não compilar, como é o seu caso) ou fazer algumas solicitações ao SO por meio do kernel.



  5. #5

    Padrão

    o negócio será esperar a próxima versão do vmw, ainda mais agora com a implementação do kvm ao kernel..

  6. #6
    ivanmunix
    Visitante

    Padrão Corrigindo o VMware para kernel 2.6.20 >

    Procurem a pasta 'lib/modules/source/' a partir da raiz da instalação do vmware;
    Descompactem (desagrupem) os 3 arquivos .tar...

    dentro da pasta vmmon-only editem o arquivo include/compat-kernel.h e comentem a linha 21 onde está um dos bugs.

    dentro da pasta vmnet-only editem o arquivo driver.c na linha 1179 e userif.c 629:
    modifiquem de CHECKSUM_HW para CHECKSUM_PARTIAL.
    "uma modificação recente no kernel que usava essa macro para verificações de checksum em rede foi modificada com macros proprias para melhoria da performance."
    é só...

    Enjoy.



  7. #7

    Padrão

    cara...

    comentei a linha no arquivo lib/modules/source/vmmon-only/include/compat-kernel.h

    no arquivo ../vmnet-only/driver.c a linha 1179 não tem o que você disse, e dentro desse arquivo também não tem...

    no arquivo ../userif.c a linha 629 já estava CHECKSUM_PARTIAL

    depois de fazer, mandei instalar e continuou o problema...

    estou usando vmware 5.3.3

    valeu

  8. #8

    Padrão

    cara..

    deu belezudo...

    só comentando a linha do compat_kernel, depois que fiz a modificação reempacotei o diretório e boa...

    valeu



  9. #9

    Padrão

    rapaiz...

    fui testar a parada aqui.. pensa na instabilidade da gota serena... não prestou não..

    chego dá tilt no KDE

  10. #10
    ivanmunix
    Visitante

    Padrão Versões e Patchs

    Esqueci de informar, o procedimento é dirigido ao VMware versão 5.5.2 build-29772 para Linux.

    Para quem teve problemas, envie o log do erro no forum que poderei ajuda-los.



  11. #11

    Padrão Vmware em 2.6.20

    Luciano... sou iniciante em linux, mas ja tive esse problema que estás mensionando.

    Bom... consegui com uns amigos um pacote que resolveu esse problema.

    Porcura na net: vmware-any-anyupdate106.tar.gz

    roda o vmware-config.pl normalmente, porem, quando ele perguntar se voce quer compilar os tais módulos que ta dando erro no seu, vc para o processo (ctrl C) e instala esse pkt que eu to te falando.
    Ele instala umas paradinhas no teu micro e depois reinicia o config.pl automaticamente...
    Dai tudo vai funcionar direito.

    Slackware 11
    Vmware 5.5.3
    Kernel 2.6.20

    Abraços...

    RDantas
    Última edição por RDantas; 04-03-2007 às 17:07.