Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Citação Postado originalmente por erolf Ver Post
    ixxx... eu não mexi no firewal não... tenho que adicionar essas linhas de comando no firewal.... e qual o arquivo para ser editado ???

    # modprobe iptable_nat
    # iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE
    # echo 1 > /proc/sys/net/ipv4/ip_forward
    # iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128
    Kra existe um firewall iptables ai ? Se num tive ja na hora de implementa...
    Agora se tive ai vc tem q v com quem implemento onde ta o script, esse negocio de script de firewall e foda dos q eu vi cada um coloca o seu em um lugar diferente e com nome diferente, eu por exemplo crio uma pasta scripts em / e coloco todos os scripts meus la, no meu caso o meu script de firewall eu chamo de firewall.sh.

    Agora vc disse anteriormente q tinha colocado esses comandos em /etc/rc.d/rc.local se vc fez isso entao ta blz pq esse arquivo inicia junto com o sistema, portanto essas regras são carregadas.

  2. Citação Postado originalmente por tuxson Ver Post
    Kra veja bem pq o squid e um firewall a nivel de aplicação (camada 7 OSI) qu e trabalha especificamente na porta 80, tanto é que no firewall vc mandou redirecionar apenas a porta 80 pro squid: "iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128"
    O https trabalha na porta 443

    outra coisa, qd vc vai la no navegador e marca a opção de Proxy manual cetando o seu proxy como fica?

    Uma dica, seu squid.conf mude esta linha:
    http_port 3128
    para:
    http_port 192.168.0.1:3128

    No caso eu coloquei o IP 192.168.0.1 como exemplo + coloque o do seu server la, isso serve pra evitar q pessoas não autorizadas usem seu proxy sem q vc saiba, fazendo isso vc limita seu proxy somente a sua rede interna.
    é isso mesmo... a regra de redirecionamento está tratando apenas da porta 80, então não é pra ter influência alguma sobre o recebimento de e-mails através do outlook...

    veja se não existe alguma outra regra de iptables com os comandos:

    # iptables -L -n -v -t filter
    # iptables -L -n -v -t nat
    # iptables -L -n -v -t mangle
    com estes comandos é pra aparecer regras apenas na tabela nat, em PREROUTING e POSTROUTING...

    veja também com está a política padrão, é pra estarem ACCEPT em todas...

    bom para testes e aprendizagem, vá por eliminatória, tire a regra de redirecionamento, tire o proxy, deixe tudo liberado, se funciona, ative o proxy, sete manualmente o proxy no programa, volte como proxy transparente.. e assim vai...

    valeu



  3. bom... deixa eu entender melhor....
    tenho o arquivo /etc/rc.d/rc.local certo... la eu tenho os comandos:

    # modprobe iptable_nat
    # iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE
    # echo 1 > /proc/sys/net/ipv4/ip_forward
    # iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128

    tendo isso não precisso mecher em firewall nada.....

    fiz alguns teste... seu eu desativar o proxy no navegador - não funciona
    se eu ativar o proxy no navegador colocar o ip do servidor 192.168.0.1 e na porta colocar 80... funciona....
    que eu entendo que ele esta redirecionando para a porta 80 mas não esta achando o ip do servidor....???


    Agradeço a todos.. pela ajuda.

  4. cara...

    é assim, quando você seta manualmente o proxy no navegador, você irá colocar os seguintes dados:
    - ip do servidor proxy
    - porta do proxy

    neste caso a porta é a 3128 e não a 80...

    quando você usa proxy transparente, coloca-se a regra de redirecionamento do iptables, esta regra joga o tráfego da porta 80 para a 3128 que é a porta do proxy,.. assim não precisa configurar nada no navegador...

    pelo que deu a entender, você configurou no navegador para usar a porta 80, mas você deve colocar a 3128...



  5. sim... sim... isso eu sei....

    seu expecificar a porta 80 no lugar da 3128... e funcionar é por esta redirecionando as portas... mas não esta localizando o ip do proxy...

    esse é o meu problema.... seu deixar tudo sem proxy... até navega... mas colocando o ip do site.. no lugar do endereço....
    Última edição por erolf; 26-02-2007 às 14:23.






Tópicos Similares

  1. Problemas com SENAO e Squid (proxy transparente)
    Por roneyeduardo no fórum Redes
    Respostas: 4
    Último Post: 31-05-2005, 21:33
  2. Problemas com squid
    Por _edinh0_ no fórum Servidores de Rede
    Respostas: 0
    Último Post: 11-04-2003, 09:33
  3. Problemas com Squid
    Por egriga no fórum Servidores de Rede
    Respostas: 6
    Último Post: 17-02-2003, 20:12
  4. Problemas com squid e rota
    Por ATNunes no fórum Servidores de Rede
    Respostas: 1
    Último Post: 10-02-2003, 11:22
  5. Squid proxy transparente
    Por Itise no fórum Servidores de Rede
    Respostas: 1
    Último Post: 30-01-2003, 12:00

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L