+ Responder ao Tópico



  1. #1

    Padrão Virtual Hosts

    Pessoal,

    Estou tentando configurar um Virtual Hosts no Apache, mas está ocorrendo um problema: As imagens não são mostradas. Somente o texto é visualizado. As imagens ficam com um "X" (caracteristico de que não conseguiu exibir).

    Meu Virtual Hosts está configurado da seguinte forma:


    NameVirtualHost ip_usado_pelo_servidor
    <VirtualHost ip_usado_pelo_servidor>
    ServerName teste.meudominio.com.br
    DocumentRoot /var/www/teste/
    </VirtualHost>


    Alguém tem idéia do que possa ser o problema? Ao diretório teste já dei a permissão 775.

  2. #2

    Padrão

    cara...

    eu configurei aqui mas baseado em nome

    Código :
    <VirtualHost teste.dominio.com>
        DocumentRoot /var/www/teste
        ServerName teste.dominio.com
        <Directory /var/www/teste>
            Options Indexes Multiviews FollowSymLinks
            AllowOverride none
            Order Allow,Deny
            Allow from All
        </Directory>
    </VirtualHost>

    lembrando que o "teste.dominio.com" está configurado no DNS...

    esse VirtualHost nao tem endereço ou só tem IP?

    valeu



  3. #3

    Padrão

    tem endereço, sim. o apache está fazendo o virtual host certo, tanto que abre a página, mas acontece que as imagens não são mostradas, somente o texto da página. eu já havia tentado tbm pelo nome e acontece a mesma coisa.

  4. #4

    Padrão

    Kra eu fiz uns testes aki e funcionou blz...

    Olha o jeito q ta o meu:

    ScriptAlias /cgi-bin/ "/server/www/default/cgi-bin/"

    <Directory "/server/www/default/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
    </Directory>


    <VirtualHost 192.168.0.254>
    ServerName www.teste.com.br
    DocumentRoot /server/www/default/html/teste
    </VirtualHost>


    Posta seu http.conf e a estrutura das pastas ai pra gente da uma olhada...
    Última edição por tuxson; 06-03-2007 às 10:00.



  5. #5

    Padrão

    uhmm...

    é verdade... agora que me toquei, funciona mas só nao aparecem as imagens...

    cara... me diz uma coisa, você testou em um micro na mesma rede do servidor, em rede externa, testou no mesmo micro que está o apache, o micro que vc fez o testes está atrás de algum firewall/proxy???

  6. #6
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão

    Cola aqui a parte do httpd.conf que tem "EnableSendfile" por favor.
    Se estiver on muda pra off.



  7. #7

    Padrão

    Dá uma olhada para ver se não tem um alias idiota por aí.

  8. #8

    Padrão

    lucianogf

    tenho sim um proxy e firewall...funcionam no mesmo servidor que está instalado o apache. os testes foram tanto interno quanto externo e sempre aconteceu o mesmo problema: só o texto é mostrado.


    psy

    Essa tag não existe no meu httpd.conf. Ela serve pra que? Quando tentei colocar, o servidor retornou o seguinte:

    Configuration syntax error detected. Not reloading.

    Syntax error on line 1062 of /etc/apache/httpd.conf:
    Invalid command 'EnableSendfile', perhaps mis-spelled or defined by a module not included in the server configuration



  9. #9
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão

    Adiciona lá:

    "EnableSendfile" "On"

    Ele usa o core do apache, entao nao é modulo :P

  10. #10

    Padrão

    psy,

    eu já havia tentado colocar e a mensagem que retornou foi a que enviei no post acima. Tentei novamente, com o On, letra O em maiusculo, mas mesmo assim nada.
    É preciso reinstalar o apache?