+ Responder ao Tópico



  1. #1

    Padrão PPPoE Server não vai nem...

    Fala galera, td certo??

    Pessoal, to aqui queimando a cabeça pra montar um servidor pppoe...

    puta merda, a princípio parecia fácil pacarai, mas não funciona nem com bomba...

    ou eu não soube procurar na net a resposta para meu problema ou eu sou um zé roéla...

    fiz tudo conforme vi a net, quando o cliente windows vai conectar aparece as mensagens no log:

    Using interface ppp0
    Connect: ppp0 <--> /dev/pts/4
    LCP: timeout sending Config-Requests
    Terminating on signal 15
    Connection terminated.
    Using interface ppp0
    Connect: ppp0 <--> /dev/pts/5
    LCP: timeout sending Config-Requests
    Terminating on signal 15
    Connection terminated.
    Using interface ppp0
    Connect: ppp0 <--> /dev/pts/6
    Terminating on signal 15
    Connection terminated.
    Modem hangup
    meu pppoe-server-options está assim:

    auth
    require-chap

    login
    lcp-echo-interval 10
    lcp-echo-failure 2
    ms-dns 10.0.0.254
    #ms-dns meu_dns_secundário
    netmask 255.255.255.255
    defaultroute
    noipdefault
    usepeerdns
    logfile /var/log/pppoe-server.log
    executo o servidor com o comando:

    pppoe-server -C Teste -L 10.0.0.1 -p /etc/ppp/faixa-ip -I eth0
    coloquei login e senha dentro do pap-secrets e no chap-secrets da seguinte forma:

    "login" * "senha" <ip>
    na conexão do windows a parte de segurança está em modo avançado e na parte de "permitir estes protocolos" está marcado tudo, exceto a ultima opção...

    alguém sabe me dizer onde estou errando???

    estou com a cabeça tão quente que é capas de eu confundir virgula com ponto e A com a...

    valeu

  2. #2

    Padrão

    Citação Postado originalmente por lucianogf Ver Post
    Fala galera, td certo??

    Pessoal, to aqui queimando a cabeça pra montar um servidor pppoe...

    puta merda, a princípio parecia fácil pacarai, mas não funciona nem com bomba...

    ou eu não soube procurar na net a resposta para meu problema ou eu sou um zé roéla...

    fiz tudo conforme vi a net, quando o cliente windows vai conectar aparece as mensagens no log:



    meu pppoe-server-options está assim:



    executo o servidor com o comando:



    coloquei login e senha dentro do pap-secrets e no chap-secrets da seguinte forma:



    na conexão do windows a parte de segurança está em modo avançado e na parte de "permitir estes protocolos" está marcado tudo, exceto a ultima opção...

    alguém sabe me dizer onde estou errando???

    estou com a cabeça tão quente que é capas de eu confundir virgula com ponto e A com a...

    valeu


    Opa, tive uma bromquinha mais concegui resolver ...

    Montei no FC3 e Tá funfando blz,

    No meu pppoe-server-options tá assim

    # PPP options for the PPPoE server
    # LIC: GPL
    require-pap
    login
    lcp-echo-interval 10
    lcp-echo-failure 2


    e no meu pptpd.conf tá assim ...

    ###############################################################################
    # $Id: pptpd.conf,v 1.10 2006/09/04 23:30:57 quozl Exp $
    #
    # Sample Poptop configuration file /etc/pptpd.conf
    #
    # Changes are effective when pptpd is restarted.
    ###############################################################################

    # TAG: ppp
    # Path to the pppd program, default '/usr/sbin/pppd' on Linux
    #
    ppp /usr/sbin/pppd
    option /etc/ppp/options.pptpd
    logwtmp
    speed 115200
    debug
    localip 192.168.0.200
    remoteip 192.168.0.120-140

    e no meu pptpd.opitions ficou assim ...

    ###############################################################################
    # $Id: options.pptpd,v 1.11 2005/12/29 01:21:09 quozl Exp $
    #
    # Sample Poptop PPP options file /etc/ppp/options.pptpd
    # Options used by PPP when a connection arrives from a client.
    # This file is pointed to by /etc/pptpd.conf option keyword.
    # Changes are effective on the next connection. See "man pppd".
    #
    # You are expected to change this file to suit your system. As
    # packaged, it requires PPP 2.4.2 and the kernel MPPE module.
    ###############################################################################

    name pptpd
    nodefaultroute
    debug
    dump
    lock
    nobsdcomp
    auth
    #require-mppe-128
    ms-dns 192.168.0.200
    ms-wins 192.168.0.1
    noipx
    proxyarp


    Dá uma olhada se bate alguma coisa ai ...

    e na parte do das Senhas PAP e CHAP tá assim ...

    # Secrets for authentication using CHAP
    # client server secret IP addresses
    teste pptpd teste 10.1.1.2

    # Secrets for authentication using PAP
    # client server secret IP addresses
    teste pptpd teste 10.1.1.2

    Espero que de pra te dar uma luz ...

    qualquer coisa ...

    Linux: VPN no Conectiva 8 com o PPTPD [Artigo]

    Falow ...



  3. #3

    Padrão

    você montou um servidor pppoe ou pptp ??

    no meu caso é PPPoE...

  4. #4

    Padrão

    Citação Postado originalmente por lucianogf Ver Post
    você montou um servidor pppoe ou pptp ??

    no meu caso é PPPoE...
    á cara, foi mal ... no meu caso foi o pptpd ...

    desculpa ai não ter perguntado antes ...

    Achei esses tuto aqui :

    Linux: Configurando um PPPOE Server [Dica]
    https://under-linux.org/5758-pppoe-r...bandlimit.html

    O bom é que a resposta acima serve pra alguem que quiser montar uma VPN ...com o pptpd ...

    Falow ...
    Última edição por rootmaster; 05-03-2007 às 18:32.



  5. #5

    Padrão

    esses ae foram dois dos que eu vi pela net...

    quero montar um server pppoe puro... sem radius

    depois vou implementar radius

  6. #6

    Padrão

    Citação Postado originalmente por lucianogf Ver Post
    esses ae foram dois dos que eu vi pela net...

    quero montar um server pppoe puro... sem radius

    depois vou implementar radius
    acho que isso te resolve eu creio,posta ae o se deu certo ou não depois, ok.

    Linux: Configurando um PPPOE Server [Dica]



  7. #7

    Padrão

    o camarada...

    esse artigo é o mesmo que o rootmaster postou acima... e é um dos que usei pra configurar...

    e nao vai nem ca porra...

    valeu

  8. #8
    leandro_ntc
    Visitante

    Thumbs up Ja verificou o firewall

    Olá, tenho um pppoe-server + radius + mysql funcionando, deu um bom trabalho pra configurar tudo e criar as interfaces de interação com o usuário mas hoje não tenho problemas!

    Seguinte, pelo que pude perceber teu pppoe-server esta desconectando os usuários porque não está recebendo as mensagens de verificação da conexão(lcp)

    Using interface ppp0
    Connect: ppp0 <--> /dev/pts/4
    -->>> LCP: timeout sending Config-Requests
    Terminating on signal 15
    Connection terminated.

    Esta opção é configurada no arquivo pppoe-server-options nas seguintes linhas:

    lcp-echo-interval 10
    lcp-echo-failure 2

    que quer dizer, enviar 2 pedidos de lcp(ping) num intervalo de 10 segundos entre um e outro e se não houver resposta ele desconecta o cara, isso para que se o usuário esqueça de desconectar e simplismente desligue o pc ele não fique mantendo a conexão ativa.

    Acredito que teu firewall ou o firewall da própria maquina do cliente estão bloqueando as respostas desses pacotes e por isso a conexão cai.
    Não sei se estou falando besteira e as vezes vc até já verificou isso mas é o que eu acho que está acontecendo, se precisar de ajuda no pppoe+radius+mysql posso te ajudar, por enquanto é isso, obrigaod!



  9. #9

    Padrão

    cara..

    eu tinha pensado no firewall também, mas fiz testes aqui sem firewall algum, e não deu...

  10. #10



  11. #11