+ Responder ao Tópico



  1. #1

    Padrão Priorizar serviço voip da VONO

    alguem já conseguiu isso? moro onde tenho grandes chances de sucesso instalando voip e por ter numero para receber ligações achei a vono a melhor.

    mas como priorizar o link para quando o telefone entrar em ação a velocida ficar garantida pra ele.

    tipo assim tenho 25 cliente e 5 vonos, e fazer esses vonos estarem com preferencia no link. sabe pra evitar engasgos. 1 cliente meu tá a 2 km sem visada nenhuma e consegue usar o vono normal hehe.

    a solução seria algo como marcar pacotes e definir uma prioridade pra eles?

    nao sei se é o ip da vono mas meus atas de vez em quando se comunicam com o ip 200.146.79.165:1571
    Última edição por jhonnyp; 15-03-2007 às 23:50.

  2. #2

    Padrão

    vc pode separar o voip em um link reservado apenas para o voip...

    vamos supor q vc tenha 2mb ..

    vc reserva 1.5mb para acesso.. e 512k para o voip.. vc cria 2 classes mae.. 1 de 1.5m e outra de 512..

    ai basta marcar o voip e jgoar para a classe de 512k.. e o resto.. no 1.5mb ..

    eh a melhor maneira de deixar o voip 100% ...



  3. #3

    Padrão

    O primeiro passo é liberar as portas de entrada do serviço VONO no servidor principal:

    / ip firewall nat
    add chain=dstnat dst-address=200.199.242.66 protocol=tcp dst-port=4040 \
    action=dst-nat to-addresses=0.0.0.0-255.255.255.255 to-ports=8000-65535 \
    comment="LIBERA O DAS PORTAS DE ENTRADA \(SERVI O VONO\)" disabled=no
    add chain=dstnat dst-address=200.199.242.66 protocol=udp dst-port=4040 \
    action=dst-nat to-addresses=0.0.0.0-255.255.255.255 to-ports=8000-65535 \
    comment="" disabled=no
    add chain=dstnat dst-address=200.199.242.66 protocol=udp dst-port=8000-65535 \
    action=dst-nat to-addresses=0.0.0.0-255.255.255.255 to-ports=8000-65535 \
    comment="" disabled=no
    add chain=dstnat dst-address=200.199.242.66 protocol=tcp dst-port=1571 \
    action=accept comment="" disabled=yes

    Onde o 200.199.242.66 é o ip do link principal,,,,

    O segundo passo é priorizar o tráfego VOiP, marcando os pacotes VOiP...

    / ip firewall mangle
    add chain=prerouting protocol=udp
    new-connection-mark=voip_in p
    add chain=prerouting connection-m
    new-packet-mark=VOIP_IN passt
    add chain=prerouting protocol=udp
    new-connection-mark=voip_out
    disabled=no
    add chain=prerouting connection-m
    new-packet-mark=VOIP_OUT pass

    E logo criar a banda mínima em uma queue tree

    / queue tree
    add name="voip_in" parent=global-in packet-mark=VOIP_IN limit-at=64000 queue=default \
    priority=8 max-limit=64000 burst-limit=0 burst-threshold=0 burst-time=0s \
    disabled=no
    add name="voip_out" parent=global-out packet-mark=VOIP_OUT limit-at=64000 queue=default \
    priority=8 max-limit=64000 burst-limit=0 burst-threshold=0 burst-time=0s \
    disabled=no

    Nesta regra acima, garantimos o mínimo de 64k pro VOiP (o que já é suficiente),... Qualquer dúvida, entra em contato...

  4. #4

    Padrão tô com um dilema

    da forma citada acima da dica do amigo CATV não resolveria só na saída? e na entrada? (que entendo ser o maior problema)
    abraços,
    Robson Farias



  5. #5

    Padrão

    nao sei se daria de fazer da forma que o catv falou pois meu link é adsl, e muda de ip né. dai nao sei se daria certo. tenho medido aqui com o uso do vono dá em media 24 kbps. isso ligando de vono para fixo, agora de vono para vono da quase 100kbps.

    alguem ja mediu no mk o consumo de um telextreme usando ata?

  6. #6

    Padrão

    amigos fiz aqui a regra do catv mas nao consegui mui link é adsl, coloquei o meu ip real de agora. fiz as regras la e tudo. mas nada de resultados. tipo as regras no nat que habilita o udp nas portas 8000:65535, vai subindo o contador bastante até. so que por exemplo, no queue tree nao sai do zero.



  7. #7

    Padrão

    catv, o ip do link vc se refere é o nosso ip? tipo o que obtenha atraves do pppoe, ou ele tem que ser fixo, ou é o ip da Vono?

  8. #8

    Padrão

    olhe meus print
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         vono.gif
Visualizações:	222
Tamanho: 	17,5 KB
ID:      	454   Clique na imagem para uma versão maior

Nome:	         vonoman.gif
Visualizações:	202
Tamanho: 	16,4 KB
ID:      	455  

    Clique na imagem para uma versão maior

Nome:	         vonoqueue.gif
Visualizações:	176
Tamanho: 	13,9 KB
ID:      	456  



  9. #9

    Padrão

    Citação Postado originalmente por jhonnyp Ver Post
    olhe meus print
    Isso mesmo... O IP seria o fixo... como não tem (ADSL), tenta colocar no lugaro do dst address, coloca o in interface como pppoe out... Posta o resultado......

  10. #10

    Padrão

    ops, achei o porque do queue nao contar nada, eu copiei e coloquei o que vc fez e as minhas eu fiz em minuscula e a sua em maisculo hehe.

    Mas ainda ha algo estranho, pois no mangle, tem 2 regras que fazem a mesma coisa marcando os mesmos pacotes, é assim mesmo? pq do jeito que ta a queue tree o voip in nao conta, e pela visualização só são marcadas conexões como voipout

    parece que a de voipout ta sobrepondo a voip_in
    Última edição por jhonnyp; 17-03-2007 às 10:51.



  11. #11

    Padrão

    desabilitei a regra no mangle do voip out dai sim ele marca com voip in, então tenho certeza que a do voip out ta sobrepondo a do voip_in. afinal deve ter algo errado,

  12. #12

    Padrão

    Citação Postado originalmente por jhonnyp Ver Post
    desabilitei a regra no mangle do voip out dai sim ele marca com voip in, então tenho certeza que a do voip out ta sobrepondo a do voip_in. afinal deve ter algo errado,
    Esta regra utilizo em diversos provedores e funciona beleza... Acho que possívelmente por ser ADSL está dando esta pane... Tenta fazer o que eu disse anteriormente... Muda no mangle a regra do VOiP out o dst-nat (o ip do link), para in interface (coloca a interface pppoe do adsl)... posta o resultado.......



  13. #13

    Padrão

    fiz assim e deu o controle do voip ja ta funcionando agora. o do voip in. na regra do mangle do voip in coloquei em in interface pppo2 out1. agora ta certo fiz umas ligações e ele ta marcando. no queue tree coloquei em priority 1 em vez de 8, ouvi dizer que é pra dar a preferencia a essa regra. funcionou blz.

    agora a regra do voip_out ainda não ta fechando..

    Para voip é conexões udp? tentei assim no mangle em voipout coloquei em vez de prerouting, coloquei postrouting e escolhi outinterface a pppoe. agora ele ta marcando até os 2 tipos voip in e voip out. mas da de ver que o voip out ele tem um uso bem mais baixo. então deve faltar algo ainda.

    e mais. percebi que ele marca tdas as conexões udp, e no caso elas nem sempre são de voip. é assim mesmo?

    CATV, tem como vc me add no msn, dai vc entrar no meu mk pra dar uma mão. dai depois passo pra galera do forum a solução

    [email protected]

  14. #14

    Padrão

    pessoal. parece que eu consegui. to testando mas pelo visto ja ta controlando td certinho. vou almoçar, depois eu aviso e se deu certo mesmo dai eu posto o que fiz.

    Obrigado pela ajuda pessoal.



  15. #15

    Smile

    Citação Postado originalmente por catvbrasil Ver Post
    O primeiro passo é liberar as portas de entrada do serviço VONO no servidor principal:

    / ip firewall nat
    add chain=dstnat dst-address=200.199.242.66 protocol=tcp dst-port=4040 \
    action=dst-nat to-addresses=0.0.0.0-255.255.255.255 to-ports=8000-65535 \
    comment="LIBERA O DAS PORTAS DE ENTRADA \(SERVI O VONO\)" disabled=no
    add chain=dstnat dst-address=200.199.242.66 protocol=udp dst-port=4040 \
    action=dst-nat to-addresses=0.0.0.0-255.255.255.255 to-ports=8000-65535 \
    comment="" disabled=no
    add chain=dstnat dst-address=200.199.242.66 protocol=udp dst-port=8000-65535 \
    action=dst-nat to-addresses=0.0.0.0-255.255.255.255 to-ports=8000-65535 \
    comment="" disabled=no
    add chain=dstnat dst-address=200.199.242.66 protocol=tcp dst-port=1571 \
    action=accept comment="" disabled=yes

    Onde o 200.199.242.66 é o ip do link principal,,,,

    O segundo passo é priorizar o tráfego VOiP, marcando os pacotes VOiP...

    / ip firewall mangle
    add chain=prerouting protocol=udp
    new-connection-mark=voip_in p
    add chain=prerouting connection-m
    new-packet-mark=VOIP_IN passt
    add chain=prerouting protocol=udp
    new-connection-mark=voip_out
    disabled=no
    add chain=prerouting connection-m
    new-packet-mark=VOIP_OUT pass

    E logo criar a banda mínima em uma queue tree

    / queue tree
    add name="voip_in" parent=global-in packet-mark=VOIP_IN limit-at=64000 queue=default \
    priority=8 max-limit=64000 burst-limit=0 burst-threshold=0 burst-time=0s \
    disabled=no
    add name="voip_out" parent=global-out packet-mark=VOIP_OUT limit-at=64000 queue=default \
    priority=8 max-limit=64000 burst-limit=0 burst-threshold=0 burst-time=0s \
    disabled=no

    Nesta regra acima, garantimos o mínimo de 64k pro VOiP (o que já é suficiente),... Qualquer dúvida, entra em contato...

    Catv,

    na marcação dos pacotes, em /ip firewall mangle, onde diz que os pacotes são VoIP? nao vi voce colocar porta, etc... só o nome VoIP, mas de onde o sistema vai saber que os pacotes são VoIP ?

  16. #16

    Padrão

    Citação Postado originalmente por evertonhorst Ver Post
    Catv,

    na marcação dos pacotes, em /ip firewall mangle, onde diz que os pacotes são VoIP? nao vi voce colocar porta, etc... só o nome VoIP, mas de onde o sistema vai saber que os pacotes são VoIP ?
    Valeu... Realmente a regra saiu incompleta..Anota ae a correta......


    / ip firewall mangle
    add chain=prerouting protocol=udp dst-port=5060 action=mark-connection \
    new-connection-mark=voip_in passthrough=yes comment="VOIP-IN" disabled=no
    add chain=prerouting connection-mark=voip_in action=mark-packet \
    new-packet-mark=VOIP_IN passthrough=yes comment="" disabled=no
    add chain=prerouting protocol=udp src-port=5060 action=mark-connection \
    new-connection-mark=voip_out passthrough=yes comment="VOIP-OUT" \
    disabled=no
    add chain=prerouting connection-mark=voip_out action=mark-packet \
    new-packet-mark=VOIP_OUT passthrough=yes comment="" disabled=no