+ Responder ao Tópico



  1. #1

    Padrão Acesso Mikrotik pela net (Ajuda ai pessoal)

    Estou com o seguinte problema, tenho uma torre com o Mikrotik instalado, ocorre que tenho um link com IP dinamico, toda vez que preciso usar o winbox alguém tem que ir onde esta minha torre pra ver o ip pra mim. Moro distante de onde esta minha torre, sera que existe alguma forma de eu configurar o DNS do milrotik para que eu consiga ter acesso ao meu sistema sem ter que ir na minha torre pra pegar o IP da net????

  2. #2



  3. #3
    Avatar de marcelomg
    Ingresso
    Jan 2006
    Localização
    São Lourenço do Sul, Brazil
    Posts
    1.476

    Padrão

    Tem sim,
    Primeiro faça seu cadastro no Free Dynamic DNS / Free Domain Names

    Adicione esse Script:
    :log info "DDNS: Begin"

    :global ddns-user "USUARIO"
    :global ddns-pass "SENHA"
    :global ddns-host "*1"
    :global ddns-interface "pppoe-out1"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"
    Agora voce deve agendar a execução do Script:
    Agendar...
    -----------------------------------------------------------
    add name="ChangeDns" on-event=DDNS start-date=jan/01/1970 \
    start-time=00:00:00 interval=1h comment="DNS DIMAMICO BY \
    MARCELO MG" disabled=no

    Abraços t+

  4. #4

    Padrão

    amigo,
    achoq vc deveria usar uma solucao mais inteligente, por exemplo, criar uma rede so para administracao...dai toda vez q vc for ter acesso, entre por essa rede..



  5. #5

    Padrão

    Citação Postado originalmente por fbig Ver Post
    amigo,
    achoq vc deveria usar uma solucao mais inteligente, por exemplo, criar uma rede so para administracao...dai toda vez q vc for ter acesso, entre por essa rede..
    posta aí a sua solução para ele...

  6. #6

    Padrão

    Uso no Meu Server a solução que o marcelomg postou. Uso isso a mais de 1 ano e nunca tive problema. É a solução mas inteligente que existe pra quem não tem IP Fixo.

    Bem Melhor do que ter que acessar uma máquina na rede interna e depois acessar o winbox pela Rede Interna.

    Só que o amigo esqueceu que para acessar uma máquina da rede interna ele tambémprecisaria do IP e alguém teria que ir pegar pra ele.

    Quer dizer: Não mudaria nada, apenas pioraria e dificultaria as coisas.


    Vlw !!! Marcelomg , Solução inteligente.

    ChangeIp.



  7. #7

    Padrão Realmente, a solução do Marcelo é uma das mais inteligentes !!!

    E não nê atenção a quem não entendeu essa solução... para um bom entendedor, um pingo é uma letra. Ignore os demais !

  8. #8

    Padrão

    A solução do marcelomg é sem duvida a melhor, mas considero interessantíssima a possibilidade de criar uma rede interna p/ administracao. Aqui, tenho as duas, pq a conexao com ip dinamico da pau, vc continua tendo acesso ao mikrotik p/ ver o que houve. E pode ainda levar internet ate os clientes pela rede interna, nao deixando os clientes sem acesso, bastando para isso apenas mudar as rotas do mikrotik. Sem falar que p/ acessar o mikrotik vc nao estara consumindo seu link.



  9. #9

    Padrão A solução do Marcelo é ideal para acessar o MK estando FORA DA REDE INTERNA !

    Pois uma vez na rede interna, não haveria nenhuma complicação...

    Pelo que entendí, este tópico foi iniciado por Gregory, pedindo auxílio para acessar seu MK por meio do seu link, que possui IP dinâmico.

    Ele explica ainda que mora distante de sua torre em que se encontra o tal MK (distante pode significar até outra cidade...), deixando sub-entendido que quer acessar pelo "IP da net" (LINK de entrada da internet).

    Como não dá maiores explicações, subentende-se que não possui acesso pela rede interna...

    Portanto, nesse caso, a melhor solução seria o DNS dinâmico apresentado.

  10. #10

    Padrão Valeu mesmo marcelo

    Citação Postado originalmente por marcelomg Ver Post
    Tem sim,
    Primeiro faça seu cadastro no Free Dynamic DNS / Free Domain Names

    Adicione esse Script:
    :log info "DDNS: Begin"

    :global ddns-user "USUARIO"
    :global ddns-pass "SENHA"
    :global ddns-host "*1"
    :global ddns-interface "pppoe-out1"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"
    Agora voce deve agendar a execução do Script:
    Agendar...
    -----------------------------------------------------------
    add name="ChangeDns" on-event=DDNS start-date=jan/01/1970 \
    start-time=00:00:00 interval=1h comment="DNS DIMAMICO BY \
    MARCELO MG" disabled=no

    Abraços t+
    ___________
    Cara, seguinte, nao entendi muito bem, vc falou sobre o cadastro, ja ate tengo cadastro no no-ip, so que nao entendi essas configs que vc me passou, elas sao feitas dentro do MIk???? em que lugar devo faze-las



  11. #11
    Avatar de marcelomg
    Ingresso
    Jan 2006
    Localização
    São Lourenço do Sul, Brazil
    Posts
    1.476

    Padrão

    Citação Postado originalmente por Gregory Ver Post
    ___________
    Cara, seguinte, nao entendi muito bem, vc falou sobre o cadastro, ja ate tengo cadastro no no-ip, so que nao entendi essas configs que vc me passou, elas sao feitas dentro do MIk???? em que lugar devo faze-las
    Pelo Winbox, lá vc cola o texto atualizado em SYSTEM SCRIPT (vc cola o script atualizado com seu usuario e senha do changeip)
    depois vc agenda a execução do script em SYSTEM SCHEDULER.
    Não sei se no No-Ip funciona, recomendo fazer seu cadastro em Free Dynamic DNS / Free Domain Names pq vc pode acessar seu mk ou winbox de qualquer lugar da net usando uma url tipo :meumkbox.ddns.com

  12. #12

    Padrão Acessando mikrotik remotamente

    Irmão se vc conseguir essa resposta posta para min. obrigado
    Última edição por lourival_silva; 23-04-2007 às 00:26.



  13. #13

    Cool Bom

    Eu uso o No-Ip há um ano e meio e sempre que eu quero acessar de qualquer lugar eu acesso pelo meu hostname o winbox !

    Eh show, basta apenas vc cadastrar no seu modem ou roteador a porta que vc quer que redirecione os acessos de fora se ele usar firewall.