+ Responder ao Tópico



  1. vou postar o script para quem ainda naum sabe. está aí!!




    :global ddnsuser "usuário"
    :global ddnspass "Senha"
    :global ddnshost "Domínio criado no Changeip"
    :global ddnsinterface "Interface da Internet"

    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={
    :if ([:typeof [/ip route get $int routing-mark ]] = nothing ) do={
    :global ddnsinterface [/ip route get $int interface]
    }
    }
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip 0.0.0.0/0 }
    :if ([ :typeof $ddnsip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
    } else={
    :if ($ddnsip != $ddnslastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ ut [/tool dns-update name=$ddnshost address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip
    } else={
    }
    }

  2. Citação Postado originalmente por masterbeto Ver Post
    cara se tem como usar o dyndns eu nao sei pq nao achei nada falando sobre isso eu tenho conta no dyndns e no no-ip, mas por nao encontrar nada sobre nenhum dos 2, criei uma conta nesse changeip pq vi o post do forum gringo dizendo q funcionava... e funcionou entao eh melhor usar o q ja funciona do q se bater com outro q ninguem sabe se funfa ^^
    caro amigo do forum por favor me explilca passo a passo como fazer para configurar no mk as regras do dyndns ou do tal changeip sinceramente nao consegui. se puder pegar desde o inicio a criaçao do usuario, senha e host ate a configuraçao e execuçao e teste do mk ficaria muito agradecido. perdoe pelo tempo q vai tomar mas precisando pode contar.
    abraços



  3. No meu caso só funcionou com esse script aqui:

    :log info "DDNS Begin"
    :global ddns-user "userr"
    :global ddns-pass "senha"
    :global ddns-interface "Interface (escreva identico)"
    :global ddns-host "seudominio.changeip.org"
    :global ddns-ip [/ip address get [/ip address find interface=$ddns-interface] address]
    :if {[ :typeof $ddns-lastip] = nil } do={ :global ddns-lastip 0.0.0.0/0 }
    :if {[ :typeof $ddns-ip] = nil} do={
    :log info "DDNS: No addres present on your interface, plesae check."
    } else={
    # :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending update!"
    :log info [/tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    # :global ddns-lastip $ddns-ip
    # } else={
    # :log info ("DDNS: No change.")
    # }
    }
    :log info ("DDNS: End.")

  4. Amigo se seu modem DSL não estiver em Bridge, esqueça pois não vai funcionar mesmo. Tem que estar em Bridge.

    Qualquer coisa me add no msn...


    cliforsouza@hotmail.com





  5. amigos este script so funciona no changeip ou posso colocar no NO-IP?






Tópicos Similares

  1. Dyndns No-IP no Mikrotik teria como
    Por Jonatanmcc no fórum Redes
    Respostas: 2
    Último Post: 01-05-2008, 00:59
  2. Usando DNSALIAS ou NO-IP no Mikrotik ?
    Por GIGANET no fórum Redes
    Respostas: 1
    Último Post: 07-05-2007, 07:38
  3. NO-IP no Mikrotik.. alguem já usou???
    Por gilbertoandrade no fórum Redes
    Respostas: 3
    Último Post: 05-03-2007, 15:59
  4. No-ip no mikrotik
    Por JefersonSoares no fórum Redes
    Respostas: 5
    Último Post: 16-06-2006, 22:15
  5. No-ip e Apache! como?
    Por Lincoln no fórum Servidores de Rede
    Respostas: 8
    Último Post: 30-01-2006, 10:18

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L