+ Responder ao Tópico



  1. #1

    Question Problemas com chroot

    Ja tinha o slack11 instalado em uma partição aqui do meu hd.
    Instalei o xp64 em outra partição.

    Quando fui restaurar o lilo me deparei com um problema que nunca tinha visto.

    # cd mnt/
    # mkdir slack
    # mount /de/sda3 slack/
    # chroot slack/

    chroot: cannot execute \bin\sh : exec format error

  2. #2
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão

    Você tá usando um CD com arquitetura diferente da do Slack11 pra bootar?

    chroot /dev/sda3 /bin/bash



  3. #3

    Padrão

    Citação Postado originalmente por psy Ver Post
    Você tá usando um CD com arquitetura diferente da do Slack11 pra bootar?

    chroot /dev/sda3 /bin/bash
    Estou usando o cd do slack11 mesmo.


    chroot /dev/sda3 /bin/bash

    chroot: cannot change root directory to /dev/sda3 : not a directory


    Depois tentei


    chroot /mnt/slack /bin/bash

    chroot: cannot execute \bin\bash : exec format error

  4. #4

    Padrão

    Achei estranho esse erro.

    Ja restaurei o lilo outras vezes e nunca tive esse problema.



  5. #5
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão

    Se você tá usando o CD do Slack boota direto no seu sistema com ele, quando iniciar digita:

    bare.i root=/dev/sda3 noinitrd ro

    ou sata.i, etc, de acordo com o que mais te serve.

  6. #6

    Padrão

    Tentei inicializar o sistema desse modo e não deu certo.

    sata.i root=/dev/sda3 noinitrd ro

    Entra em um loop infinito com o seguinte erro
    kmod: failed to exec /sbin/modprobe -k -s binfmt -464c,errno = 8


    huge26.s root=/dev/sda3 noinitrd ro

    Exibe o seguinte erro 5 vezes.
    request_module: runaway loop modprobe binfmt -464c



  7. #7

    Padrão Erro na senha

    Citação Postado originalmente por psy Ver Post
    Se você tá usando o CD do Slack boota direto no seu sistema com ele, quando iniciar digita:

    bare.i root=/dev/sda3 noinitrd ro

    ou sata.i, etc, de acordo com o que mais te serve.
    Olá, bem eu tbm estou com um problema semelhante ao do nosso amigo acima, porem segui oque vc flw e funcionou até certo ponto, por que ele chegou na tela de login e num tem forma de eu conseguir acessar o sistema, ele pede Login e senha porem todas as senhas conhecidas (senha do root do sistema por exemplo) naum entra nem a pau vc teria alguma ideia de como resolver isso???


    dese ja agredeço.

  8. #8
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão

    Cara na verdade a única coisa que ele faz com essa opção é chamar o sistema de boot e bootar o seu sistema operacional normalmente. Ele não altera nada nem chama nenhum outro recurso, então todos os usuários e senhas do seu sistema atualmente instalado são os que são válidos ali.



  9. #9

    Padrão

    Citação Postado originalmente por psy Ver Post
    Cara na verdade a única coisa que ele faz com essa opção é chamar o sistema de boot e bootar o seu sistema operacional normalmente. Ele não altera nada nem chama nenhum outro recurso, então todos os usuários e senhas do seu sistema atualmente instalado são os que são válidos ali.
    Muito Obrigado pela resposta amigo, porem testei exatamente os usuarios que eu tenho no sistema, inclusive o root, eu não obtive sucesso.

    mesmo assim vlw. se tiver mais alguma ideia, por que eu preciso recuperar o boot do slackware.

    té +++

  10. #10

    Padrão

    Psy,

    Tem ideia de algo mais que posso tentar aqui ?

    Estou com saudades do meu slack ja =(



  11. #11
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão

    Godzilla, no seu caso voce pode sempre tentar com o mount:

    mount -o dev,rw /mnt/hda1

    Entra no etc, edita o shadow e remove a parte da senha do root, salva e reboota, ai faz o que eu falei acima e loga denovo como root e so da enter quando pedir a senha.

    No caso do Skorpyon ate onde eu sei esse tipo de erro e' de dev, e vem com problemas de compilacao de kernel, etc.

    Um workaround que voce pode fazer e' montar ele com o mount como eu expliquei e gerar uma imagem de boot pra bootar ele do windows.

    Mounta ele, cria o arquivo com:

    dd if=/dev/sda3 of=slackware.lnx bs=512 count=1
    chmod +x slackware.lnx

    Copia o arquivo pra raiz do windows (c
    Edita o arquivo de boot do windows (boot.ini) e adiciona nele:

    [boot loader]
    timeout=5
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect
    c:\slackware.lnx="Slackware"

    Salve e reboota, e abre ele pelo boot manager do Windows mesmo... Uma vez dentro do sistema e' facil proseguir.

  12. #12



  13. #13

    Padrão

    Citação Postado originalmente por psy Ver Post
    Godzilla, no seu caso voce pode sempre tentar com o mount:

    mount -o dev,rw /mnt/hda1

    Entra no etc, edita o shadow e remove a parte da senha do root, salva e reboota, ai faz o que eu falei acima e loga denovo como root e so da enter quando pedir a senha.

    No caso do Skorpyon ate onde eu sei esse tipo de erro e' de dev, e vem com problemas de compilacao de kernel, etc.

    Um workaround que voce pode fazer e' montar ele com o mount como eu expliquei e gerar uma imagem de boot pra bootar ele do windows.

    Mounta ele, cria o arquivo com:

    dd if=/dev/sda3 of=slackware.lnx bs=512 count=1
    chmod +x slackware.lnx

    Copia o arquivo pra raiz do windows (c
    Edita o arquivo de boot do windows (boot.ini) e adiciona nele:

    [boot loader]
    timeout=5
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect
    c:\slackware.lnx="Slackware"

    Salve e reboota, e abre ele pelo boot manager do Windows mesmo... Uma vez dentro do sistema e' facil proseguir.
    vlw amigo, obrigado, na verdade o que aconteceu e o seguinte, estou com um HD meio pauliado, ele e de 20GB ai o que eu fiz, peguei um de 10GB e fiz um ghost para ele porem não funcionou ele naum copiou como estava o antigo sabe, por acaso vc poderia me falar um programa de clonar hd's que funciona bem com os sistemas de arquivo em linux???

    desde já agradeço.