Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. marcelo eu ja tinha postado uma regra para isso

    It works only for http connections not https connections, as transparent web proxy does not support https connections.

    Imagine, that you have only one public IP address i.e. xxx.xxx.xxx.xxx, but want to host 3 web servers:

    123.com@192.168.0.2
    abc.com@192.168.0.3
    456.com@192.168.0.4
    1. Configure your web proxy

    /ip web-proxy
    set enabled=yes src-address=0.0.0.0 port=8080 hostname="your.proxy" \
    transparent-proxy=yes parent-proxy=0.0.0.0:0 \
    cache-administrator="webmaster" max-object-size=4096KiB cache-drive=system \
    max-cache-size=unlimited max-ram-cache-size=unlimited
    /ip web-proxy access
    add dst-port=23-25 action=deny comment="block telnet & spam e-mail relaying" \
    disabled=no
    add dst-port=80 action=allow comment="Enable Http Connection" disabled=no
    2. Configure Static DNS of domains to resolve to internal ip

    /ip dns static add name=123.com address=192.168.0.2
    /ip dns static add name=abc.com address=192.168.0.3
    /ip dns static add name=456.com address=192.168.0.4
    /ip dns static add name=www.123.com address=192.168.0.2
    /ip dns static add name=www.abc.com address=192.168.0.3
    /ip dns static add name=www.456.com address=192.168.0.4
    3. Configure NAT to redirect traffic to webproxy

    /ip firewall nat
    add chain=dstnat in-interface=outside dst-address=xxx.xxx.xxx.xxx protocol=tcp \
    dst-port=80 action=redirect to-ports=8080 comment="" disabled=no
    The traffic for 123.com will be like this:

    The web proxy will redirect traffic to the 123.com internal ip address which is 192.168.0.2

    Internet --> xxx.xxx.xxx.xxx:80 ---> xxx.xxx.xxx.xxx:8080 --> 192.168.0.2:80

    I hope this would be helpful

    mais mesmo assim ta ai o link

    Multiple Web Servers - MikroTik Wiki

  2. Citação Postado originalmente por balisteri Ver Post
    marcelo eu ja tinha postado uma regra para isso

    It works only for http connections not https connections, as transparent web proxy does not support https connections.

    Imagine, that you have only one public IP address i.e. xxx.xxx.xxx.xxx, but want to host 3 web servers:

    123.com@192.168.0.2
    abc.com@192.168.0.3
    456.com@192.168.0.4
    1. Configure your web proxy

    /ip web-proxy
    set enabled=yes src-address=0.0.0.0 port=8080 hostname="your.proxy" \
    transparent-proxy=yes parent-proxy=0.0.0.0:0 \
    cache-administrator="webmaster" max-object-size=4096KiB cache-drive=system \
    max-cache-size=unlimited max-ram-cache-size=unlimited
    /ip web-proxy access
    add dst-port=23-25 action=deny comment="block telnet & spam e-mail relaying" \
    disabled=no
    add dst-port=80 action=allow comment="Enable Http Connection" disabled=no
    2. Configure Static DNS of domains to resolve to internal ip

    /ip dns static add name=123.com address=192.168.0.2
    /ip dns static add name=abc.com address=192.168.0.3
    /ip dns static add name=456.com address=192.168.0.4
    /ip dns static add name=www.123.com address=192.168.0.2
    /ip dns static add name=www.abc.com address=192.168.0.3
    /ip dns static add name=www.456.com address=192.168.0.4
    3. Configure NAT to redirect traffic to webproxy

    /ip firewall nat
    add chain=dstnat in-interface=outside dst-address=xxx.xxx.xxx.xxx protocol=tcp \
    dst-port=80 action=redirect to-ports=8080 comment="" disabled=no
    The traffic for 123.com will be like this:

    The web proxy will redirect traffic to the 123.com internal ip address which is 192.168.0.2

    Internet --> xxx.xxx.xxx.xxx:80 ---> xxx.xxx.xxx.xxx:8080 --> 192.168.0.2:80

    I hope this would be helpful

    mais mesmo assim ta ai o link

    Multiple Web Servers - MikroTik Wiki
    Vou Testar aqui, obrigado pela receita.



  3. balisteri, o wb proxy tem q estar na porta 8080?
    ip web-proxy
    set enabled=yes src-address=0.0.0.0 port=8080 hostname="your.proxy" \

  4. nesta configuração diz que sim, mais isso no transparente



  5. Citação Postado originalmente por balisteri Ver Post
    nesta configuração diz que sim, mais isso no transparente
    Meu web Proxy ta na porta padrão 3128, terei que mudar?






Tópicos Similares

  1. Acessar DVR na rede local pela internet - Mikrotik
    Por rodrigocleal14 no fórum Redes
    Respostas: 6
    Último Post: 02-07-2015, 14:51
  2. Respostas: 1
    Último Post: 03-03-2013, 07:49
  3. Respostas: 3
    Último Post: 13-04-2007, 06:58
  4. Taxa de transferência da rede local
    Por Duca no fórum Servidores de Rede
    Respostas: 5
    Último Post: 23-02-2006, 09:12
  5. Servidor VSFTP nao aceita conexoes de fora da rede local
    Por Sergio Jr no fórum Servidores de Rede
    Respostas: 2
    Último Post: 12-12-2005, 16:42

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L