Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. #7
    Avatar de marcelomg
    Ingresso
    Jan 2006
    Localização
    São Lourenço do Sul, Brazil
    Posts
    1.476

    Padrão

    Citação Postado originalmente por balisteri Ver Post
    marcelo eu ja tinha postado uma regra para isso

    It works only for http connections not https connections, as transparent web proxy does not support https connections.

    Imagine, that you have only one public IP address i.e. xxx.xxx.xxx.xxx, but want to host 3 web servers:

    [email protected]
    [email protected]
    [email protected]
    1. Configure your web proxy

    /ip web-proxy
    set enabled=yes src-address=0.0.0.0 port=8080 hostname="your.proxy" \
    transparent-proxy=yes parent-proxy=0.0.0.0:0 \
    cache-administrator="webmaster" max-object-size=4096KiB cache-drive=system \
    max-cache-size=unlimited max-ram-cache-size=unlimited
    /ip web-proxy access
    add dst-port=23-25 action=deny comment="block telnet & spam e-mail relaying" \
    disabled=no
    add dst-port=80 action=allow comment="Enable Http Connection" disabled=no
    2. Configure Static DNS of domains to resolve to internal ip

    /ip dns static add name=123.com address=192.168.0.2
    /ip dns static add name=abc.com address=192.168.0.3
    /ip dns static add name=456.com address=192.168.0.4
    /ip dns static add name=www.123.com address=192.168.0.2
    /ip dns static add name=www.abc.com address=192.168.0.3
    /ip dns static add name=www.456.com address=192.168.0.4
    3. Configure NAT to redirect traffic to webproxy

    /ip firewall nat
    add chain=dstnat in-interface=outside dst-address=xxx.xxx.xxx.xxx protocol=tcp \
    dst-port=80 action=redirect to-ports=8080 comment="" disabled=no
    The traffic for 123.com will be like this:

    The web proxy will redirect traffic to the 123.com internal ip address which is 192.168.0.2

    Internet --> xxx.xxx.xxx.xxx:80 ---> xxx.xxx.xxx.xxx:8080 --> 192.168.0.2:80

    I hope this would be helpful

    mais mesmo assim ta ai o link

    Multiple Web Servers - MikroTik Wiki
    Vou Testar aqui, obrigado pela receita.

  2. #8
    Avatar de marcelomg
    Ingresso
    Jan 2006
    Localização
    São Lourenço do Sul, Brazil
    Posts
    1.476

    Padrão

    balisteri, o wb proxy tem q estar na porta 8080?
    ip web-proxy
    set enabled=yes src-address=0.0.0.0 port=8080 hostname="your.proxy" \



  3. #9

    Padrão

    nesta configuração diz que sim, mais isso no transparente

  4. #10
    Avatar de marcelomg
    Ingresso
    Jan 2006
    Localização
    São Lourenço do Sul, Brazil
    Posts
    1.476

    Padrão

    Citação Postado originalmente por balisteri Ver Post
    nesta configuração diz que sim, mais isso no transparente
    Meu web Proxy ta na porta padrão 3128, terei que mudar?



  5. #11

    Padrão olaa amigo!!!

    Citação Postado originalmente por marcelomg Ver Post
    Meu web Proxy ta na porta padrão 3128, terei que mudar?
    alguns dias atraz, tive esse msm problema!!

    o meu grade amigo catv.. q me solucionou sabe...
    e os fdp ainda bane ele...
    fodzz : /

    mudando de assunto...
    tpw...
    vai em...

    IP -FIREWALL - NAT

    CHAIN =DSTNAT
    DST ADRRESS = IP REAL..IP RECEBIDO DA OPERADORA
    PROTOCOL =6 TCP
    DST.PORT = 8080

    NA ABA ACTION
    ACTION =DST-NAT
    TO ADRRESS= IP DO CLIENTE Q ESTA COM UM SERVER ESCUTANDO NA PORTA 8090
    TO PORTS = 8080


    e isso amigo!
    espero ter ajudado!!
    testa e posta..
    flww!!

  6. #12

    Padrão aeww

    alguns dias atraz, tive esse msm problema!!

    o meu grade amigo catv.. q me solucionou sabe...
    e os fdp ainda bane ele...
    fodzz : /

    mudando de assunto...
    tpw...
    vai em...

    IP -FIREWALL - NAT

    CHAIN =DSTNAT
    DST ADRRESS = IP REAL..IP RECEBIDO DA OPERADORA
    PROTOCOL =6 TCP
    DST.PORT = 8080

    NA ABA ACTION
    ACTION =DST-NAT
    TO ADRRESS= IP DO CLIENTE Q ESTA COM UM SERVER ESCUTANDO NA PORTA 8090
    TO PORTS = 8080


    e isso amigo!
    espero ter ajudado!!
    testa e posta..
    flww!!