Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. Amigo boa noite..

    Primeiramente vc precisar de colocar o seu script dentro de system scripts adicionar copie o codigo e jogue lá. Vc so vai precisar de editar isso aqui q escrevi em baixo e pronto. salve e de um run script.



    :log info "DDNS: Begin"

    :global ddns-user "no de usuario que vc criou no change ip"
    :global ddns-pass "sua senha de acesso criada la"
    :global ddns-host "*1"
    :global ddns-interface "sua interface de saida"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"

    Citação Postado originalmente por ivovid Ver Post
    amigo boa noite !!

    eu tb to passando pelo mesmo problema , fiz o cadastro no changeip.com,
    ja crieia minha conta e la mostrou um ip pra mim ip xxx.xxx.142.141

    ate ai blz , agora desculpa minha falta de conhecimento + vc poderia me explicar como faço pra colocar o script:

    como e onde alterar o script??


    :log info "DDNS: Begin"

    :global ddns-user "YOURUSERID"
    :global ddns-pass "YOURPASSWORD"
    :global ddns-host "*1"
    :global ddns-interface "EXACTINTERFACENAME"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"


    desde agradeço sua atenção

  2. #7
    fabiano2006
    acho que com esse programinha vai ajudar


    Satélite Download






Tópicos Similares

  1. Load balance pcc com links ip dinamico , como fazer?
    Por julinribeiro no fórum Redes
    Respostas: 21
    Último Post: 25-10-2017, 08:41
  2. Respostas: 2
    Último Post: 11-05-2011, 09:07
  3. Respostas: 3
    Último Post: 08-09-2009, 18:07
  4. Como saber o IP?
    Por fabiocatelani no fórum Redes
    Respostas: 1
    Último Post: 25-11-2004, 18:44
  5. como saber o ip?
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 10-09-2004, 00:33

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L