+ Responder ao Tópico



  1. #1

    Padrão Configurar um servidor DNS de cache

    Senhores

    Estou tendo problemas a respeito de resolucao de nomes.
    Utilizo os DNS da BrasilTelecon. Tenho uma maquina rodando iptables (nat) e squid, a distro é o CentOS 4.3.
    Nao tenho DHCP rodando aqui, configurei as maquinas clientes com IP fixo (10.11.x.x).

    Os erros que o squid indica é:

    A URL Solicitada nao pode ser recuperada.
    No DNS Record !
    O Cache foi incapaz de resolver o nome contido na URL !


    Quando da este erro, tenho que aguardar até 1 minuto e atualizar a pagina para voltar ao normal.
    Fiz o seguinte teste.
    Até o site do google da este erro. Peguei o IP do google, e quando deu este erro, eu digitei http://ip_do_google, e funcionou legal. Dai cheguei a conclusao que o problema esta no DNS.

    Entao vi a necessidade de rodar um DNS somente para cache de paginas.
    Nao quero criar dominios, somente um DNS que registre em cache as paginas acessadas, evitando que as maquinas windows faça pesquina no DNS da Operadora, e sim, utilize o DNS da minha rede, agilizando a navegação !

    Ja li alguns tutoriais, mas nao vi assunto sobre DNS cache.

    Na maquina, esta instalado o BIND 9.2.4-2 (vi atraves do comando rpm -q bind)
    Mas nao encontrei um daemon chamado BIND, e sim o NAMED.

    Eu tenho que configurar o BIND ou o NAMED para criar um DNS de cache ?

    Obrigado a todos !

  2. #2

    Padrão

    basta rodar o dns normalmente.. se possivel, dentro de OPTIONS coloque assim

    listen-on {
    127.0.0.1;
    10.0.0.1;
    }

    coloque para listar apenas nos ips INTERNOS e o localhost.. ja que seu dns vai ser apenas para consultas internas

    o squid vai ficar inclusive MAIS rapido com um DNS local !!



  3. #3

    Padrão

    alexandrecorrea

    Desculpe amigo, mas onde fica o OPTIONS que vc indicou ?

    O named ja esta em execução, mas ainda continua dando o erro de DNS.
    Preciso de ajuda, pois todos conectados a rede passam pelo mesmo problema !

    Na opcao nameserver do squid, eu utilizo o ip da maquina onde estou configurando o named ?

    O que altero nos arquivos /etc/resolv.conf e host.conf ?

    Lembrando que ja coloquei o ip da maquina DNS nas opções de DNS do windows xp. Entao o gateway ficou 10.11.0.254 e o DNS preferencial ficou 10.11.0.254, pois estou rodando na mesma maquina o iptables (nat), squid e named !

    A pagina de erro do squid é esta aqui:

    A URL solicitada não pode ser recuperada

    --------------------------------------------------------------------------------

    Na tentativa de recuperar a URL: Google

    O seguinte erro foi encontrado:

    Incapaz de determinar o endereço IP através do nome do host

    O servidor DNS retornou:

    Refused: The name server refuses to perform the specified operation.
    Isso significa que:


    O cache foi incapaz de resolver o nome do host presente na URL.
    Verifique se o endereço está correto.

    --------------------------------------------------------------------------------

    Generated Wed, 23 May 2007 20:21:04 GMT by proxy.tedute.com.br (squid/2.5.STABLE6)

  4. #4

    Padrão

    e ai!
    vou me intrometer
    hehehhehe
    no resolve vc pode coloca 127.0.0.1
    desculpa a pergunta, naum leva a mau naum...
    mas vc libero a porta 53 UDP do seu firewall pra INPUT?

    abraço



  5. #5

    Padrão

    o options fica em /etc/named.conf

  6. #6

    Padrão

    Citação Postado originalmente por pichorra Ver Post
    e ai!
    vou me intrometer
    hehehhehe
    no resolve vc pode coloca 127.0.0.1
    desculpa a pergunta, naum leva a mau naum...
    mas vc libero a porta 53 UDP do seu firewall pra INPUT?

    abraço

    PICHORRA

    Sim, a porta 53 TCP e UDP estao abertas no firewall !



  7. #7

    Smile

    Senhores

    Desculpe a demora, voltei de viajem ontem, e só agora pude fazer os testes.
    Ja resolvi o problema.
    Instalei o NAMED, e tranquilo, troquei o DNS das maquinas clientes, e esta funcionando perfeitamente !
    Alterei o rc.named para executar no boot.

    Agradeço a ajuda de todos !

    Abraços !

    Ricardo