+ Responder ao Tópico



  1. Citação Postado originalmente por Roberto21 Ver Post
    Tinha em outra parte do forum...


    Redirecionando para um site da net

    ip firewall nat

    no nat logo depois do mascaramento
    add chain=dstnat protocol=tcp src-address-list=Clientes_block action=dst-nat \
    to-addresses=ip_do_site_do_aviso to-ports=80 comment="" disabled=no

    ip firewall address-list

    add list=Clientes_block address=ip_do_cliente comment="Fulano de tal" disabled=no

    Funciona perfeitamente para quem tem um site de aviso

    De qualquer forma eu vou testar ! Obrigado !

  2. Citação Postado originalmente por catvbrasil Ver Post
    A classificação seria pelo IP do cliente... Vou mandar alguma coisa abaixo pra ter uma idéia da coisa...


    REDIRECIONAMENTO DE CLIENTES PARA PÁGINA INICIAL (PPPOE)

    /ip firewall nat
    add chain=dstnat src-address=10.0.0.1-10.0.0.253 dst-address=!10.0.0.2 \
    protocol=tcp dst-port=80 connection-limit=!1,24 action=dst-nat \
    to-addresses=10.0.0.2 to-ports=81 comment="REGRA PARA DEFINIR PÁGINA \
    INICIAL" disabled=no

    Esta regra acima define quem será a página inicial do cliente. Quando o mesmo entra no PPPoE, será direcionado automaticamente para a página sua que está no servidor local (dentro da rede). Para criar um servidor web simples em uma máquina windows, utilizei o soft "ironwall". Esta regra deve ser colocada logo após a regra de NAT, para seguir a irarquia de priorização do firewall. No exemplo acima o src-address é uma faixa de ips (10.0.0.1-10.0.0.253), na qual é redirecionada para o servidor web (winxp com ironwall) no ip 10.0.0.2. Para ser redirecionado automaticamente para sua página inicial, criei um código fonte dentro desta página inicial, recarrengando ela mesma, gerando assim, algumas conexões simultâneas e mudando automaticamente de página. Basicamente a regra funciona a ação do "conection limit".
    PS: A porta padrão do irowall foi alterada para a 81.


    BLOQUEIO DE CLIENTE PARA PÁGINA INICIAL

    /ip firewall nat
    add chain=dstnat src-address=10.0.0.1 dst-address=!10.0.0.2 protocol=tcp \
    dst-port=80 action=dst-nat to-addresses=10.0.0.2 to-ports=81 comment="REGRA \
    PARA DIRECIONAR CLIENTE PARA UMA MESMA PÁGINA \(D BITO\) - SISTEMA \
    INTELIGÊNTE DE BLOQUEIO" disabled=yes

    Esta regra é a mesma de cima, somente retirando o "conection limit" o mikrotik entenderá que em todas as circustâncias ele deve sempre redirecionar o cliente para o servidor (10.0.0.2). Neste caso o cliente 10.0.0.1 está bloqueado. A mesma página HTML pode ser utilizada (está em anexo), pois quando a mesma for redirecionada após os 10 segundos, irá voltar para ela mesma, criando um loop na qual o cliente não conseguirá sair e exibirá apenas aquela mensagem padrão de bloqueio. O ideal para ficar show, é incluir uma regra como a debaixo para este mesmo cliente, para bloquear todos os serviços, exceto o da página.

    REGRA ANEXA PARA BLOQUEIO DE CLIENTES

    /ip firewall nat
    add chain=src-nat src-address=10.0.0.1 protocol=!tcp \
    src-port=!80 action=drop comment="BLOQUEIO DE CLIENTE" \
    disabled=yes

    Com esta regra acima de exceção, o mikrotik bloqueará todas as portas e protocolos, menos a porta 80 e o protocolo tcp.

    Em anexo o ironwall e os arquivos da página inicial de testes... Dúvidas? Entre em contato que a gente desenvolve qualquer coisa!!!
    david, eu to tentando postar essas regras so que num conssegui botar para funfa.
    tem uma coisa eu uso uma faixa de ip diferente das pppoe no caso meu pc que seria o servidor de paginas 172.16.0.1 os ips dos clientes pppoe 10.0.0.1 ate 10.0.0.254....

    como devo fazer neste caso.. tem possibilidade de fazer esse direcionamento sem ser por pppoe tbm, eu uso pppoe e ips/mac



  3. Oi Pessoal Gosto Muito Do FÓrun E Estou Entrando Para Poder Aprender E Trocar IdÉias

    Valeu

  4. Citação Postado originalmente por catvbrasil Ver Post
    É isso mesmo, eu consegui desenvolver uma regra para isso, em PPPoE... Estou preparando o material para soltar aqui para a galera... Funciona da seguinte forma:

    Quando o cliente loga a primeira vez e abre o broswer, via PPPoE, aparece a página que você define ou aviso, após 10 segundos (ou mais), ele é redirecionado automaticamente para a página inicial dele... Também tem uma derivada desta regra que quando o cliente é bloqueado só consegue entrar na página definida, que pode ser somente a página do provedor ou um aviso de débitos... Show de bola pra os provedores que trabalham com PPPoE, pois só encontrávamos isso em HOTSPOT.

    TEm mais, dependendo pode-se colocar a janela com redirecionamento ou como pop-up, bastando apenas modificar um código HTML. Você poderá utilizar páginas existentes na web, ou com um simples soft, transformar sua máquina windows em um servidor web interno. Aqui testei da seguinte forma:

    1º teste: Redirecionando os clientes para uma página qualquer na web, podendo ser um simples aviso, hospedado em qualquer lugar e também para uma página qualquer... Funcionou perfeitamente, tanto para forçamento de página inicial, quanto de bloqueio.

    2º teste: No meu notebook, coloquei um soft e transformei-o em um server web, no frontpage criei minha página personalizada... Quando o cliente entra na internet pela primeira vez é redirecionado para a minha página personalizada (criei um aviso, com logos e etc), após 10 segundo ele é redirecionado automaticamente para a página dele inicial... Funciona 100% também... Estou preparando o material e em breve disponibilizarei....
    ´
    O melhor de tudo é que realmente esta tela inicial só aparece quando ele loga a primeira vez, evitando assim a fadiga de toda vez abrir o explorer e aparecer ela.... Show!!
    muito bom esse tipo de regra
    dessa forma fica ótimo de anunciar promoçoes futuras que o provedor venha oferecer.

    ótima dica mais uma vez catv

    abraço



  5. Bom Catvbrasil, muito bom seus topicos, mas o problema é que esta regra bloqueia msn ?, pois utilizei uma regra desta e funcinou legal, mas no bloqueio de clientes atrazados ele bloqueva apenas sites, quer dizer, paginas de internet, mas infelizmente o msn nao era bloqueado.

    obrigado






Tópicos Similares

  1. Respostas: 2
    Último Post: 21-06-2016, 17:51
  2. Respostas: 16
    Último Post: 15-10-2015, 15:35
  3. Respostas: 2
    Último Post: 12-07-2014, 09:42
  4. Respostas: 3
    Último Post: 24-08-2012, 12:34
  5. Pegar pagina inicial do cliente sem hotspot e pppoe
    Por cleciorodrigo no fórum Redes
    Respostas: 4
    Último Post: 27-01-2008, 17:12

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L