+ Responder ao Tópico



  1. #1

    Smile mikrotik nao faz cache

    olá amigos, estou com um problema no meu server, o mikrotik esta devidamente configurado e pppoe limitacao de banda controle de MAC porem percebi q ele nao esta fazendo cache, nao tem consulmo de HD, e quando limpo os temporarios da maquina local ela carrega tudo novamente, alguem poderia me ajudar me mandar um script, me passar a configuracao minima da maquina pra fazer cache, estou precisando muito obrg a todos!!

  2. #2

    Padrão

    Citação Postado originalmente por eri Ver Post
    olá amigos, estou com um problema no meu server, o mikrotik esta devidamente configurado e pppoe limitacao de banda controle de MAC porem percebi q ele nao esta fazendo cache, nao tem consulmo de HD, e quando limpo os temporarios da maquina local ela carrega tudo novamente, alguem poderia me ajudar me mandar um script, me passar a configuracao minima da maquina pra fazer cache, estou precisando muito obrg a todos!!
    quando vc entra dentro de webproxy ele mostra clientes conectados ?



  3. #3

    Padrão

    nao apenas os que eu coloco manualmente no browser ja verifiquei a regra do firewall mas mesmo assim o que eu coloco manualmente nao faz cache

  4. #4

    Padrão

    verifique se a regra de redirecionamento está antes de todas as outras...e se está ativado o proxy transparente dentro das conf do webproxy...

    confs abaixo...

    ip web-proxy print
    enabled: yes
    src-address: 0.0.0.0
    port: 3128
    hostname: "proxy"
    transparent-proxy: yes
    parent-proxy: 0.0.0.0:0
    cache-administrator: "[email protected]"
    max-object-size: 4096KiB
    cache-drive: system
    max-cache-size: 2048000KiB
    max-ram-cache-size: 131072KiB
    status: running
    reserved-for-cache: 2048000KiB
    reserved-for-ram-cache: 131072KiB

    Redireciona para porta do Proxy
    chain=dstnat src-address=xxx.xxx.xxx.xxx/24 protocol=tcp dst-port=80 action=redirect to-ports=3128


    t+



  5. #5

    Padrão

    amigos a regra do firewall esta primeiro o redirecionamento da porta 3128 e depois a do nat porem observei que o nat esta sendo mais acessado q a regra do redirecionamento, e no status do proxy nao aparece usuarios logados alguem poderia deixar o Msn pra que eu possa ter melhores informacoes realmente estou precisando resolver isso obrg

  6. #6

    Padrão

    Citação Postado originalmente por eri Ver Post
    amigos a regra do firewall esta primeiro o redirecionamento da porta 3128 e depois a do nat porem observei que o nat esta sendo mais acessado q a regra do redirecionamento, e no status do proxy nao aparece usuarios logados alguem poderia deixar o Msn pra que eu possa ter melhores informacoes realmente estou precisando resolver isso obrg
    Coloque esta regra que funcionará perfeitamente:

    add chain=dstnat in-interface=!LINK protocol=tcp dst-port=80 action=redirect \
    to-ports=3128 comment="WEB-PROXY" disabled=no


    Explicando:

    Quando definimos o "in-interface" em !LINK criamos uma exceção ou seja, incluimos todas as interfaces no redirecionamento, menos a de saida do link da internet. Desta forma, apenas 1 regra abrange todas as interfaces e fará funcionar perfeitamente sem nenhum erro... Testa ae e posta os resultados...



  7. #7

    Padrão

    Cat a regra e justamente essa fiz pelo manual que vc fez que por sinal é muito bom mas nao estou conseguindo cache de forma alguma, infelizmente tenho q voltar a forma antiga pois nao posso perder muito tempo.
    desde já agradeco a todos que me deram uma forca grande abraco a todos.

    se alguem quizer fazer um acesso ao meu server e fazer um orcamento pra deixar ele redomdinho agradeco!


    Erivaldo Silva
    seja livre use Linux!

  8. #8

    Padrão

    Citação Postado originalmente por eri Ver Post
    Cat a regra e justamente essa fiz pelo manual que vc fez que por sinal é muito bom mas nao estou conseguindo cache de forma alguma, infelizmente tenho q voltar a forma antiga pois nao posso perder muito tempo.
    desde já agradeco a todos que me deram uma forca grande abraco a todos.

    se alguem quizer fazer um acesso ao meu server e fazer um orcamento pra deixar ele redomdinho agradeco!


    Erivaldo Silva
    seja livre use Linux!
    ola amigo, esta com dificuldade sobre o cache..
    as regras correta ja esta no manual, mas acho que vc esta com dificuldade de colocar elas em pratica, lei novamente, se não conseguir, addiciona ai, que posso te ajudar.
    [email protected]

    não deixa probelmas dominar sua vida, seja autonomo.



  9. #9

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Coloque esta regra que funcionará perfeitamente:

    add chain=dstnat in-interface=!LINK protocol=tcp dst-port=80 action=redirect \
    to-ports=3128 comment="WEB-PROXY" disabled=no


    Explicando:

    Quando definimos o "in-interface" em !LINK criamos uma exceção ou seja, incluimos todas as interfaces no redirecionamento, menos a de saida do link da internet. Desta forma, apenas 1 regra abrange todas as interfaces e fará funcionar perfeitamente sem nenhum erro... Testa ae e posta os resultados...
    tenho uma duvida ~sobre o cache, por exemplo, uma interface wireless com 30 clientes conectado, como faço pra 5 desses clientes não usar cache, apenas 25 usar ser redirecionado para o cache.


    obrigado

    saip

  10. #10

    Padrão

    Citação Postado originalmente por saip Ver Post
    tenho uma duvida ~sobre o cache, por exemplo, uma interface wireless com 30 clientes conectado, como faço pra 5 desses clientes não usar cache, apenas 25 usar ser redirecionado para o cache.


    obrigado

    saip
    Esses 5 clientes em questão, são permanentes, ou seja, nunca passarao pelo CACHE??? Ou vc quer q quando o contador de clientes do cache atinja 30 clientes exclua 5???

    Caso seja a prieiraopçao... basta vc retirar da regra ((( add chain=dstnat in-interface=!LINK protocol=tcp dst-port=80 action=redirect \
    to-ports=3128 comment="WEB-PROXY" disabled=no
    ))) os 5 clientes em quastao...

    Ja a segunda nao sei se tem como fazer isso... e se tem nao vejo vantagem.. é sinal de q seu sistema cache esta AFOGADO.. entao esta na hora de adicionar outro e fazer com q caso uma requisiçao nao seja encontrada no primeiro faça a busca no segundo e assim por diante...

    Espero ter ajudado... ABRAÇOS



  11. #11

    Padrão

    Citação Postado originalmente por saip Ver Post
    tenho uma duvida ~sobre o cache, por exemplo, uma interface wireless com 30 clientes conectado, como faço pra 5 desses clientes não usar cache, apenas 25 usar ser redirecionado para o cache.


    obrigado

    saip
    Pô, muito simples!!!!

    Faça o seguinte, crie uma range de IP para os 25 clientes e uma range de IP diferente, na mesma interface para os outros 5 clientes... Adicione a seguinte regra abaixo:

    add chain=dstnat dst-address=!192.168.0.0 in-interface=!LINK protocol=tcp dst-port=80 action=redirect \
    to-ports=3128 comment="WEB-PROXY" disabled=no


    Onde o ip 192.168.0.0 é o range de IP dos 5 clientes... esta regra inclui todos os clientes, menos os clientes que estão na faixa de IP 192.168.0.XX... Caso queira clientes no web-proxy, mande para qualquer range que não seja esta setada. Caso deseje clientes fora do web-proxy, coloque-os dentro da range 192.168.0.XX...

    Dúvidas??? Estamos aqui...

    PS: Estou em viagem pelo Brasil, visitando provedores e ensinando wireless e mikrotik!!! rsssssssss
    Última edição por catvbrasil; 27-06-2007 às 02:47.

  12. #12

    Padrão cache pra alguns clientes

    o que preciso mesmo, é que 5 fique fora do cache, esses clientes eu que vou determinar, e vai ser permanente, exemplo, tenho 30 clientes, com ip final 2 ate32, quero que os clientes de ip final 2,3,4,5 e 6, na passe pelo cache. e que os outros continuam usando cache.




    obrigado

    saip



  13. #13

    Padrão

    Citação Postado originalmente por saip Ver Post
    o que preciso mesmo, é que 5 fique fora do cache, esses clientes eu que vou determinar, e vai ser permanente, exemplo, tenho 30 clientes, com ip final 2 ate32, quero que os clientes de ip final 2,3,4,5 e 6, na passe pelo cache. e que os outros continuam usando cache.




    obrigado

    saip
    Da forma que lhe passei vai funcionar perfeitmente...

  14. #14

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Da forma que lhe passei vai funcionar perfeitmente...
    só pra entender melhor, meus clientes estão conectado pelo ip 192.168.1.xx, o ip da interface que os clientes estão conectado é 192.168.1.1 assim vou criar uma nova range de ip 192.168.10.1 aplicar essa regra que vc citou, e os clientes que não quiser colocar pro cache eu coloco nessa ranger de ip. outra coisa, a interface ´LINK que vc citou, é a de entrada do link, ou de saida pros clientes?




    obrigado

    saip



  15. #15

    Padrão

    Citação Postado originalmente por saip Ver Post
    só pra entender melhor, meus clientes estão conectado pelo ip 192.168.1.xx, o ip da interface que os clientes estão conectado é 192.168.1.1 assim vou criar uma nova range de ip 192.168.10.1 aplicar essa regra que vc citou, e os clientes que não quiser colocar pro cache eu coloco nessa ranger de ip. outra coisa, a interface ´LINK que vc citou, é a de entrada do link, ou de saida pros clientes?




    obrigado

    saip
    Perfeitamente!!! Na regra o LINK é a interface de saida da internet (publica)... Crie ae e posta os resultados...

  16. #16
    danielmenezes
    Visitante

    Padrão

    voltando a dificuldade original do colega, sobre o web-proxy nao funcionar com pppoe ... estou enfrentando o mesmo problema.

    para que entandam o caso, esse MK eh cliente wireless, para condominios.
    tenho 1 interface wlan (wavelan - cartao orinoco gold) e uma interface lan (ether1 - realtek)

    nessa lan eu setei o pppoe, q funciona, e o web-proxy esta ativo e transparente .. porem soh funciona qndo eu manualmente configuro o browser ..

    alguma dica???

    valeuu



  17. #17

    Padrão

    [[email protected] MK] ip firewall nat> add chain=dstnat in-interface=!LINK protocol=
    tcp dst-port=80 action=redirect /
    ...to-ports=3128 comment="WEB-PROXY" disabled=no
    input does not match any value of interface
    [[email protected] MK] ip firewall nat>


    No meu ta dando esse resultado e meu proxy realmente nao esta funcionando, quando tiro o proxy do navegador para de navegar...