+ Responder ao Tópico



  1. #1

    Padrão Nomes na Rede Local

    Saudações galera, já vi diversos tópicos com este conteúdo mas nenhum me ajudou a resolver.
    Então resolvi postar este:

    Eu tenho atualmente o Debian instalado:
    Linux linux 2.6.17-2-k7 #1 SMP Wed Sep 13 17:18:46 UTC 2006 i686 GNU/Linux

    Ele está funcionando redondinho na net e tudo mais, porem quando vou pingar nomes internos da rede ele nao acha nenhum nome:

    linux:/# ping backup
    ping: unknown host backup

    De outras maquinas windows pinga normalmente. Gostaria de saber o que está faltando, se é alguma opção no Samba.

    Desde já agradeço a atenção.

  2. #2

    Padrão

    acho q isso tem haver com DNS.... uma vez na faculdade... a gente fez um server pra resolver ping de nomes desse jeito.... só q como faz um pouco de tempo nao me lembro como q faz .....

    mas é DNS sim...



  3. #3

    Padrão

    Mas estou usando o mesmo DNS que resolve para maquinas windows. E funcona normal. Sei lá o que pode ser.

  4. #4

    Padrão

    Caro amigo, quem resolve nomes em uma rede windows é o protocolo netbios, mais pode ser implementado no seu dns essa resolução, se não me engano existe uma maneira de vc adicionar isso automaticamente no seu dns, de mais uma procurada no nosso grande amigo google que vc vai achar.



  5. #5

    Padrão

    Ando procurando faz tempo... Tentei com o pacote winbind, sem sucesso. Se alguém já passou por isso e puder me ajudar, agradeço.

  6. #6

    Padrão

    você precisa de um DNS corretamente configurado!
    aqui eu uso dhcp+dns para que as estações se adicionem automaticamente, mas também não basta simplesmente colocar uma configuração no servidor de dns e dhcp, mas no caso de maquinas inux para que ele se adicione corretamente é preciso outras confs
    e não esquecer que todas as maquinas da rede devem ter seu servidor dns interno como servidor principal

    é por aí!

    abraços



  7. #7
    geofesteiro
    Visitante

    Padrão tente ai

    se a sua quantidade de maquinas nao for muito grande da pra voce tenta cadastra dentro do /etc/hosts
    as maquinas e os ips para que enquanto nao funcione o dns fique certo pelo - por enquanto ficaria assim
    [[email protected] webmaster]# vi /etc/hosts

    192.168.1.11 suporte

    [[email protected] webmaster]# ping -a suporte
    PING suporte (192.168.1.11) 56(84) bytes of data.
    64 bytes from suporte (192.168.1.11): icmp_seq=1 ttl=128 time=0.363 ms
    64 bytes from suporte (192.168.1.11): icmp_seq=2 ttl=128 time=0.167 ms
    64 bytes from suporte (192.168.1.11): icmp_seq=3 ttl=128 time=0.163 ms

    --- suporte ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 2000ms
    rtt min/avg/max/mdev = 0.163/0.231/0.363/0.093 ms

    flow espero ter ajudado

  8. #8

    Padrão

    pelo IP vc consegue pingar??

    vc usa no Debian apenas a internet ou acessa arquivos tb? o samba esta inst. e configurado?

    pois aqui ao inst. a linux ele pegou o IP pegou a net mais não a rede pois estava sem o samba