+ Responder ao Tópico



  1. #1

    Padrão Regra proxy no MK tipo delay_pool's do squid

    Olá galera!

    Sou meio novato no mk e to com o seguinte problema:

    Preciso limitar o Download de arquivos por IP (uso proxy transparente no MK)
    Tipo ip 192.x.x.21 podera realizar download's diários de até 10MB. Depois o usuario navega na net normal, mas não baixa mais arquivos. Ou se for baixar baixar a 10k.

    Com o squid agente fazia +- assim:

    delay_pools ..
    .....
    delay_parameters 3000/3000 1000/1000
    O usuario navega normal +- a 64, mas so faz download a 1k.
    Pode ainda colocar uma url_regex -i .jpeg, .mp3 .mov. Para limitar o download dos mesmos a uma velocidade bem baixa.

    Como posso adaptar isto para o Mk.

    Agradeço a todos.

  2. #2

    Padrão

    Citação Postado originalmente por cvr Ver Post
    Olá galera!

    Sou meio novato no mk e to com o seguinte problema:

    Preciso limitar o Download de arquivos por IP (uso proxy transparente no MK)
    Tipo ip 192.x.x.21 podera realizar download's diários de até 10MB. Depois o usuario navega na net normal, mas não baixa mais arquivos. Ou se for baixar baixar a 10k.

    Com o squid agente fazia +- assim:

    delay_pools ..
    .....
    delay_parameters 3000/3000 1000/1000
    O usuario navega normal +- a 64, mas so faz download a 1k.
    Pode ainda colocar uma url_regex -i .jpeg, .mp3 .mov. Para limitar o download dos mesmos a uma velocidade bem baixa.

    Como posso adaptar isto para o Mk.

    Agradeço a todos.

    Olá amigo blz?

    Infelizmente os recursos do proxy do mikrotik ainda são bem limitados, para vc ter esse serviço vc precisa realmente configurar um servidor proxy no linux, pois no mk vc por enquanto é dificil conseguir, a não ser q vc faça uma adaptação de algum script para essa finalidade...
    Última edição por gilbertoandrade; 18-06-2007 às 08:44.



  3. #3

    Padrão

    Não da para fazer a nivel de firewall, vi um script que faz uma coisa parecida. Ele verifica a quantidade de download do ip/faixa e dependendo da quantidade de download ele limita a banda do cliente, tipo um FAP da Hugless/Hilk's.

    :local sum; :local traf;
    et sum 0
    /ip firewall rule forward {
    :foreach i in [find] do={:incr sum}
    :for i from=1 to=$sum do={
    set traf [get [find comment=("192.168.32.0" . $i)]
    bytes]
    et traf ($traf/1073741)
    :if ($traf>1) do={:log facility=System-Info message=("192.168.32.0" . $i .
    " mensagem ")}}
    }

  4. #4

    Padrão

    Citação Postado originalmente por cvr Ver Post
    Não da para fazer a nivel de firewall, vi um script que faz uma coisa parecida. Ele verifica a quantidade de download do ip/faixa e dependendo da quantidade de download ele limita a banda do cliente, tipo um FAP da Hugless/Hilk's.

    :local sum; :local traf;
    et sum 0
    /ip firewall rule forward {
    :foreach i in [find] do={:incr sum}
    :for i from=1 to=$sum do={
    set traf [get [find comment=("192.168.32.0" . $i)]
    bytes]
    et traf ($traf/1073741)
    :if ($traf>1) do={:log facility=System-Info message=("192.168.32.0" . $i .
    " mensagem ")}}
    }

    Muito interessante amigo...



  5. #5

    Padrão

    Alguém ai pode ajudar a adaptar o script ?


    Ficaria muito grato.

  6. #6

    Padrão Segue eses passos

    Tem um passo a passo, naum tem erro da serto com certeza.
    https://under-linux.org/wiki/index.php/Mikrotik



  7. #7

    Padrão

    Citação Postado originalmente por cvr Ver Post
    Não da para fazer a nivel de firewall, vi um script que faz uma coisa parecida. Ele verifica a quantidade de download do ip/faixa e dependendo da quantidade de download ele limita a banda do cliente, tipo um FAP da Hugless/Hilk's.

    :local sum; :local traf;
    et sum 0
    /ip firewall rule forward {
    :foreach i in [find] do={:incr sum}
    :for i from=1 to=$sum do={
    set traf [get [find comment=("192.168.32.0" . $i)]
    bytes]
    et traf ($traf/1073741)
    :if ($traf>1) do={:log facility=System-Info message=("192.168.32.0" . $i .
    " mensagem ")}}
    }

    Amigo deixa te perguntar, aonde conseguiu esse script? Vc saberia dizer um site ou um lugar com scripts para MK, as vezes algum e util, hehhe! Valeu...

  8. #8
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Citação Postado originalmente por mtmassa Ver Post
    Amigo deixa te perguntar, aonde conseguiu esse script? Vc saberia dizer um site ou um lugar com scripts para MK, as vezes algum e util, hehhe! Valeu...
    Google é seu amigo...

    Laserwifi.com Foros de información inalámbrica

    MikroTik RouterOS V2.7 Scripting Manual

    http://www.mikrotik.com/testdocs/ros...g1_content.php



  9. #9

    Padrão

    eu conseguir fazer o script mas ele ta meio doido, hora funciona e tem horas que não funciona, se alguem conseguiu fazer com quer ele funcione certo daria para mandar o script certo ...