+ Responder ao Tópico



  1. #1

    Padrão Erro Recompilar Squid

    Pessoal to recompilando meu squid pra aplicar o delay pools mas quando dou squid -z da o erro abaixo:

    [[email protected] sbin]# ./squid -z
    2007/07/11 16:40:35| Creating Swap Directories
    FATAL: Failed to make swap directory /var/spool/squid/00: (13) Permission denied
    Squid Cache (Version 2.6.STABLE13-20070621): Terminated abnormally.
    CPU Usage: 0.001 seconds = 0.000 user + 0.001 sys
    Maximum Resident Size: 0 KB
    Page faults with physical i/o: 0
    [[email protected] sbin]#


    Alguém sabe dizer o que??

    Meu squid.con segue abaixo

    ######### INICIO ##########
    http_port 3128
    visible_hostname LosT.madalenasofia.com.br

    cache_mem 100 MB
    cache_dir ufs /var/spool/squid 100 16 256
    cache_access_log /var/log/squid/access.log
    cache_log /var/log/squid/cache.log
    cache_store_log /var/log/squid/store.log

    ######### REGRAS ##########
    acl all src 10.0.0.0/255.0.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80 8080 21 70 210 1025-65535
    acl Safe_ports port 443 563
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT
    acl avi url_regex -i .*\.avi$
    acl mp3 url_regex -i .*\.mp3$
    acl viv url_regex -i .*\.viv$
    acl mpeg url_regex -i .*\.mpeg$
    acl wma url_regex -i .*\.wma$
    acl wmv url_regex -i .*\.wmv$
    acl mov url_regex -i .*\.mov$
    acl Sites url_regex -i "/etc/squid/block.txt"
    acl meebo src 69.36.226.109
    acl cisco_free src 10.0.2.0/24
    acl time_free time MTWHF 18:00-24:00

    ########## ACAO ##########
    http_access allow manager localhost
    http_access allow cisco_free time_free
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access deny avi
    http_access deny mov
    http_access deny wmv
    http_access deny mp3
    http_access deny viv
    http_access deny wma
    http_access deny mpeg
    http_access deny meebo
    #http_access deny block-hosts
    #http_access deny block-path
    #http_access deny aplicativos_cisco !time_free
    http_access deny Sites
    http_access allow all

  2. #2

    Padrão

    cache_mem abaixa ele pra 64mb !!!

    cache_dir .. troque o 100 para um numero maior (este eh o espaço que o squid vai usar para guardar objetos, 100mb eh pouco)

    o seu problema ao iniciar o squid é que ele nao esta tendo permissão para criar a arquitetura do diretorio de SWAP (cache_dir) faça o seguinte:


    chown squid:squid /var/spool/squid
    chown -R squid:squid /var/spool/squid/*

    chmod 700 /var/spool/squid
    chmod 700 -R /var/spool/squid/*

    depois execute o squid -z ..

    e rode o squid normalmente



  3. #3

    Padrão

    fiz o que vc falou amigo mas ta dando o mesmo problema

    [[email protected] sbin]# ./squid -z
    2007/07/12 11:22:03| strtokFile: /etc/squid/block.txt not found
    2007/07/12 11:22:03| aclParseAclLine: WARNING: empty ACL: acl Sites url_regex -i "/etc/squid/block.txt"
    2007/07/12 11:22:03| WARNING cache_mem is larger than total disk cache space!
    2007/07/12 11:22:03| Creating Swap Directories
    FATAL: Failed to make swap directory /var/spool/squid/00: (13) Permission denied
    Squid Cache (Version 2.6.STABLE13-20070621): Terminated abnormally.
    CPU Usage: 0.001 seconds = 0.000 user + 0.001 sys
    Maximum Resident Size: 0 KB
    Page faults with physical i/o: 0
    [[email protected] sbin

  4. #4

    Padrão

    Citação Postado originalmente por martysouza Ver Post
    fiz o que vc falou amigo mas ta dando o mesmo problema

    [[email protected] sbin]# ./squid -z
    2007/07/12 11:22:03| strtokFile: /etc/squid/block.txt not found
    2007/07/12 11:22:03| aclParseAclLine: WARNING: empty ACL: acl Sites url_regex -i "/etc/squid/block.txt"
    2007/07/12 11:22:03| WARNING cache_mem is larger than total disk cache space!
    2007/07/12 11:22:03| Creating Swap Directories
    FATAL: Failed to make swap directory /var/spool/squid/00: (13) Permission denied
    Squid Cache (Version 2.6.STABLE13-20070621): Terminated abnormally.
    CPU Usage: 0.001 seconds = 0.000 user + 0.001 sys
    Maximum Resident Size: 0 KB
    Page faults with physical i/o: 0
    [[email protected] sbin
    O erro citado agora é outro.
    Faça assim,

    # rm -rf /var/spool/squid/


    2007/07/12 11:22:03| strtokFile: /etc/squid/block.txt not found
    2007/07/12 11:22:03| aclParseAclLine: WARNING: empty ACL: acl Sites url_regex -i "/etc/squid/block.txt"

    Essa mensagem acima é de não encontrar o arquivo block.txt

    OU


    falta algum conteúdo para ele interpretar na hora de iniciar o squid.
    Coloque alguma coisa que não atrapalhe a navegação. Algum site do Japão sei la algo assim.

    Conforme o Alexandre informou.

    Dê permissões na pasta recursivamente para o usuário que vc tem para rodar o squid.

    chown squid:squid /var/spool/squid
    chown -R squid:squid /var/spool/squid/*

    chmod 744 /var/spool/squid
    chmod 744 -R /var/spool/squid/*



  5. #5

    Padrão

    esse WARNING eh porque seu arquivo de regras esta vazio.. pode desconsiderar

    o outro erro FATAL eh o que eu disse.. abaixa seu cache_mem para 32MB e aumenta o cache_dir para 1024

  6. #6

    Padrão

    o primeiro erro esta dando por causa que nao esta tendo acesso ao diretorio do squid
    mude as permicoes so diretorio onde vai ficar o cache do squid para o usuario squid.

    no outro quando vc criar uma regra lendo em um arquivo ( exmplo.txt) este arquivo tera que estar com conteudo.
    Valeu quanquer coisa e so chamar



  7. #7

    Padrão

    Cara com a compilação tudo ok., o problema agora é que num funfou o meu squid., como poden ver abaixo eu levanto o serviço mas os clientes não navegam.

    [[email protected] ~]# cd /usr/sbin/
    [[email protected] sbin]# ./squid
    2007/07/19 17:10:01| WARNING cache_mem is larger than total disk cache space!
    [[email protected] sbin]#

    Tenho um firewall fazendo nat tudo certinha com regra pro proxy-transparrente mas num funfa

    meu conf do squid

    # NETWORK OPTIONS
    # -----------------------------------------------------------------------------

    http_port 3128 transparent


    # OPTIONS WHICH AFFECT THE NEIGHBOR SELECTION ALGORITHM
    # -----------------------------------------------------------------------------


    # TAG: hierarchy_stoplist

    #hierarchy_stoplist cgi-bin ?

    # TAG: no_cache

    acl QUERY urlpath_regex cgi-bin \?
    no_cache deny QUERY


    # OPTIONS WHICH AFFECT THE CACHE SIZE
    # -----------------------------------------------------------------------------

    # TAG: cache_mem (bytes)

    cache_mem 128 MB

    # TAG: cache_swap_low (percent, 0-100)
    # TAG: cache_swap_high (percent, 0-100)

    cache_swap_low 90
    cache_swap_high 95

    # TAG: maximum_object_size (bytes)

    maximum_object_size 4096 KB



    # LOGFILE PATHNAMES AND CACHE DIRECTORIES
    # -----------------------------------------------------------------------------

    # TAG: cache_dir

    cache_dir ufs /var/spool/squid 100 20 20

    # TAG: cache_access_log

    cache_access_log /var/log/squid/access.log

    # TAG: cache_log

    cache_log /var/log/squid/cache.log



    # ACCESS CONTROLS
    # -----------------------------------------------------------------------------

    # TAG: acl



    acl all src 10.0.0.0/255.255.0.0
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl to_localhost dst 127.0.0.0/8
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl CONNECT method CONNECT
    #acl liberar url_regex -i "/etc/squid/liberar.reg"
    #acl negar url_regex -i "/etc/squid/negar.reg"
    acl avi url_regex -i .*\.avi$
    acl mp3 url_regex -i .*\.mp3$
    acl viv url_regex -i .*\.viv$
    acl mpeg url_regex -i .*\.mpeg$
    acl wma url_regex -i .*\.wma$
    acl wmv url_regex -i .*\.wmv$
    acl mov url_regex -i .*\.mov$


    ########################################################
    # ACLŽs para Portal CAPES
    ########################################################
    acl portal_capes url_regex -i "/etc/squid/portalcapes.txt"


    # TAG: http_access

    http_access allow manager localhost
    http_access deny manager
    #http_access allow liberar
    #http_access deny negar
    http_access deny avi
    http_access deny mov
    http_access deny wmv
    http_access deny mp3
    http_access deny viv
    http_access deny wma
    http_access deny mpeg
    http_access allow all
    http_reply_access allow all
    always_direct allow all
    http_access allow all

    # Opcoes para suportar proxy transparente.
    #httpd_accel_host virtual
    #httpd_accel_port 80
    #httpd_accel_with_proxy on
    #httpd_accel_uses_host_header on

    # Deny requests to unknown ports
    #http_access deny !Safe_ports

    # Deny CONNECT to other than SSL ports
    #http_access deny CONNECT !SSL_ports




    ##########################################################
    # Redirecionamento para o MCT
    ##########################################################
    cache_peer prx.mct.gov.br parent 80 0 no-query
    cache_peer_access prx.mct.gov.br allow portal_capes
    always_direct allow !portal_capes


    http_reply_access allow all portal_capes



    # TAG: icp_access

    icp_access allow all portal_capes

    visible_hostname PROXY-FIREWALL

  8. #8

    Padrão

    cara... voce LEU bem o post anterior meu ??

    a mensagem de erro eh 'curta e grossa'

    o cache_mem ta maior que o cache_dir !!!

    o cache_mem NUNCA deve passar de 25% do total de memoria RAM porem, o cache_dir voce precisa aumenta-lo .. para 1GB +- se quiser um desempenho melhor !!!



  9. #9

    Padrão

    cara vi sim rtesolvi esse problema., só mpra citar meu server tem 3gb de memória., inicio o squid mas as estações não navegam.,to fazendo o NAT certinho., minha regra de proxy-transparente tbm ta correta mas continua sem funfar minha estruta do server ta assim

    ETH0:ip real
    ETH1:ip da rede interna

    Mesmo indo no navegador do usuário e colocando la o ip e a porta não consegue navegar