+ Responder ao Tópico



  1. #1

    Padrão Melhor forma de Load Balance p 3 links

    olá amigos, atualmente eu tenho 2 links e faço load balance sempre surgem alguns probleminhas, tipo radio n funcionam, bancos etc... tava pensando em um metodo de se separar tipo dividir os clientes tantos usam 1 tantos usam outro e assim por diante.. gostaria de saber se alguem usa esse tipo de conf e se é a melhor opção... esse meu func blz mas tem esses problemas tem q fazer regrinha pra isso ou aquilo.. desde ja agradeço a boa vontade de todos... vlw

  2. #2

    Padrão

    eh uma boa ideia.. outra boa ideia.. é balancear por serviço...

    por exemplo:

    www, ftp, smtp, pop3 sai por um link.. o resto sai pelo outro...
    estes servicos que o usuario usa com maior frequencia voce coloca em um link de melhor qualidade.. o restante.. joga para os outros links...



  3. #3

    Padrão

    amigo eu to tentando fazer desse jeito, tipo 20 clientes por u mlink e 20 por outro, ainda nao consegui, mas to tentanto. se eu conseguir depois te ajudo ai. flw

  4. #4

    Padrão

    This example will run the scripts gw_1 or gw_2 which change the default gateway depending on the status of one of the gateways:

    [[email protected]] system script> add name=gw_1 source={/ip route set
    {... [/ip route find dst 0.0.0.0] gateway 10.0.0.1}
    [[email protected]] system script> add name=gw_2 source={/ip route set
    {.. [/ip route find dst 0.0.0.0] gateway 10.0.0.217}
    [[email protected]] system script> /tool netwatch
    [[email protected]] tool netwatch> add host=10.0.0.217 interval=10s timeout=998ms \
    \... up-script=gw_2 down-script=gw_1
    [[email protected]] tool netwatch> print
    Flags: X - disabled
    # HOST TIMEOUT INTERVAL STATUS
    0 10.0.0.217 997ms 10s up
    [[email protected]] tool netwatch> print detail
    Flags: X - disabled
    0 host=10.0.0.217 timeout=997ms interval=10s since=feb/27/2003 14:01:03
    status=up up-script=gw_2 down-script=gw_1

    [[email protected]] tool netwatch>

    Without scripts, netwatch can be used just as an information tool to see which links are up, or which specific hosts are running at the moment.

    Let's look at the example above - it changes default route if gateway becomes unreachable. How it's done? There are two scripts. The script "gw_2" is executed once when status of host changes to up. In our case, it's equivalent to entering this console command:

    [[email protected]] > /ip route set [/ip route find dst 0.0.0.0] gateway 10.0.0.217

    The /ip route find dst 0.0.0.0 command returns list of all routes whose dst-address value is 0.0.0.0. Usually, that is the default route. It is substituted as first argument to /ip route set command, which changes gateway of this route to 10.0.0.217

    The script "gw_1" is executed once when status of host becomes down. It does the following:

    [[email protected]] > /ip route set [/ip route find dst 0.0.0.0] gateway 10.0.0.1

    It changes the default gateway if 10.0.0.217 address has become unreachable.

    Here is another example, that sends e-mail notification whenever the 10.0.0.215 host goes down:

    [[email protected]] system script> add name=e-down source={/tool e-mail send
    {... from="[email protected]" server="159.148.147.198" body="Router down"
    {... subject="Router at second floor is down" to="[email protected]"}
    [[email protected]] system script> add name=e-up source={/tool e-mail send
    {... from="[email protected]" server="159.148.147.198" body="Router up"
    {.. subject="Router at second floor is up" to="[email protected]"}
    [[email protected]] system script>
    [[email protected]] system script> /tool netwatch
    [[email protected]] system netwatch> add host=10.0.0.215 timeout=999ms \
    \... interval=20s up-script=e-up down-script=e-down
    [[email protected]] tool netwatch> print detail
    Flags: X - disabled
    0 host=10.0.0.215 timeout=998ms interval=20s since=feb/27/2003 14:15:36
    status=up up-script=e-up down-script=e-down

    [[email protected]] tool netwatch>



  5. #5

    Thumbs up

    Citação Postado originalmente por alexandrecorrea Ver Post
    eh uma boa ideia.. outra boa ideia.. é balancear por serviço...

    por exemplo:

    www, ftp, smtp, pop3 sai por um link.. o resto sai pelo outro...
    estes servicos que o usuario usa com maior frequencia voce coloca em um link de melhor qualidade.. o restante.. joga para os outros links...

    Amigo você tem a receita ai ?
    queria testar pra ver como fica !
    obrigado !

  6. #6

    Padrão

    Citação Postado originalmente por fabianojean Ver Post
    olá amigos, atualmente eu tenho 2 links e faço load balance sempre surgem alguns probleminhas, tipo radio n funcionam, bancos etc... tava pensando em um metodo de se separar tipo dividir os clientes tantos usam 1 tantos usam outro e assim por diante.. gostaria de saber se alguem usa esse tipo de conf e se é a melhor opção... esse meu func blz mas tem esses problemas tem q fazer regrinha pra isso ou aquilo.. desde ja agradeço a boa vontade de todos... vlw
    Load Balancing over Multiple Gateways - MikroTik Wiki



  7. #7

    Padrão

    Olá pessoal, fiz um load balance, funcionou blz, mas oproblema é site de bancos, como faço para direcionar a porta 44 pra somente umlink e acabar com oproblema? Agradeço...

  8. #8

    Padrão

    Citação Postado originalmente por jhonnyp Ver Post
    amigo eu to tentando fazer desse jeito, tipo 20 clientes por u mlink e 20 por outro, ainda nao consegui, mas to tentanto. se eu conseguir depois te ajudo ai. flw
    Olá amigo, tem um wiki aqui no forum, só ñ sei onde, tô usando assim como vc quer, uso uma range de IP de xxx.xxx.xxx.1 a xxx.xxx.xx.253 sendo q de 1 a 127 os clientes estão no link1 e de 128 a 253 estão no link2, se ñ achar vou postar as regras blz? VAleu!



  9. #9

    Thumbs up

    Não entenderão!
    Nao e fazer grupos e sim colocar um serviço para um dos links para que ele saia sempre pelo mesmo link !

    Alguem sabe como fazer para http pop smtp msn sair por um link e o resto por outro ?

    por favor se alguem souber coloque as regras para nos !

    Obrigado !

  10. #10

    Padrão

    Citação Postado originalmente por Giovani.couto Ver Post
    Não entenderão!
    Nao e fazer grupos e sim colocar um serviço para um dos links para que ele saia sempre pelo mesmo link !

    Alguem sabe como fazer para http pop smtp msn sair por um link e o resto por outro ?

    por favor se alguem souber coloque as regras para nos !

    Obrigado !
    / ip firewall mangle
    add chain=prerouting protocol=tcp dst-port=80 action=mark-routing new-routing-mark=link2 \
    passthrough=yes comment="Marca conexoes na porta 80 c/ a marca link2 - by antoni" disabled=no
    add chain=prerouting routing-mark=link2 action=mark-packet new-packet-mark=link2 passthrough=yes \
    comment="Marca pacotes da porta 80 c/ a marca link2" disabled=no

    É só adaptar para as portas que vc quer!



  11. #11

    Unhappy Como faço para dois Links ?

    Tenho dois modems adsl já roteados cada um com as seguintes redes:

    Link 1 = 192.168.1.0/24 1MB
    Link 2 = 192.168.0.0/24 1MB

    Obs: Lembrando que esses modems tem seus ips diferentes: 201.0.0.0/24
    Se alguém puder me ajudar como posso usar os dois no meu MK? pode deixar um script também desde já agradeço.

    Me ajudem!!!

  12. #12

    Padrão

    Tem que fazer balanceamento de carga. Dá uma pesquisada que tem vários posts, inclusive com exemplos.