Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #7

    Padrão

    Citação Postado originalmente por lfaria Ver Post
    Implementei o "Controle de P2P" em minha rede com pequenas modificações. O ambiente que uso é de rede local com algumas máquinas em wireless, 2 adsl e uma Lan House, sem provedor Internet, por enquanto.

    O controle P2P funciona. Me ajudou a ter um controle de banda sob o p2p.

    Uma observação, faço controle de banda com Simple queue. A impressão que tive foi que o controle de banda do p2p é independente do controle de banda do usuário.

    Eu estarei adaptando esse conceito a uma conexão VoIp que tenho, pois algumas ocasiões o VoIp tem o mau hábito de consumir mais banda do que precisa.

    Uma dificuldade que tenho é fazer o "mark-routing" sair apenas por um dos meus links. Toda vez que ativo o "mark-routing" (terceira regra do magle, do roteiro) o p2p (Shareaza especificamente) não conecta mais.

    Como já fundi a cabeça por hoje, vou continuar pesquisando.

    De qualquer forma, parabéns pelo trabalho.
    Sobre o shareazza nao conectar denovo verifique por onde as informacoes estao voltando pq se estiver saindo por um link e voltando por outro link ele vai acontecer isso mesmo

  2. #8

    Padrão

    Mauricio,
    é sabido que um programa chamado ARES, utiliza criptografia entre os Hosts conectados para fazer o download e o upload, e essa criptografia não passa pela QUEUE dos Mikrotik, e em casos mais extremos como o do LIMEWARE em sua última versão não respeita nem a QUEUE geral do cliente. Já fiz vários testes de bancada tentando controlar o tráfego destes programas, e inclusive levei pros professores da certificação MKT em São Paulo nos darem um solução. NÃO EXISTE MEIO de controlar esse tráfego. A única alternativa é de colocar uma limitação na INTERFACE FÍSICA, ou seja, se é uma interface eth, vc coloca ela com Max-limit 64K, mas todo o tipo de tráfego é passado por ela a 64K.
    Chupa essa manga....



  3. #9

    Padrão

    Citação Postado originalmente por masterwesley Ver Post
    Sobre o shareazza nao conectar denovo verifique por onde as informacoes estao voltando pq se estiver saindo por um link e voltando por outro link ele vai acontecer isso mesmo
    Fiz novos testes e após o mark-routing consegue conectar. Então o vilão é mesmo o route.

    Dei um export na regra: ( ip route )

    add dst-address=0.0.0.0/0 gateway=10.0.1.1 scope=255 target-scope=10 routing-mark=p2p comment="" disabled=yes

    Obs:

    10.0.1.1 é o link de saída que eu quero usar.
    Está desabilitada devido ao problema, se eu habilitar, para e não conecta.
    Todo meu tráfego está no gateway 10.0.1.2

    Ainda não saquei onde estou errando.

  4. #10

    Padrão

    Citação Postado originalmente por brenovale Ver Post
    Mauricio,
    é sabido que um programa chamado ARES, utiliza criptografia entre os Hosts conectados para fazer o download e o upload, e essa criptografia não passa pela QUEUE dos Mikrotik, e em casos mais extremos como o do LIMEWARE em sua última versão não respeita nem a QUEUE geral do cliente. Já fiz vários testes de bancada tentando controlar o tráfego destes programas, e inclusive levei pros professores da certificação MKT em São Paulo nos darem um solução. NÃO EXISTE MEIO de controlar esse tráfego. A única alternativa é de colocar uma limitação na INTERFACE FÍSICA, ou seja, se é uma interface eth, vc coloca ela com Max-limit 64K, mas todo o tipo de tráfego é passado por ela a 64K.
    Chupa essa manga....
    Vamos lá, papo de enxirido... :-)

    Não respeita o controle de banda colocado para o cliente?
    Não respeita número de conexões simultâneas?
    Putz!



  5. #11

    Padrão

    Respondendo:
    Não.
    Para você controlar o Número de conexões, é melhor fazê-lo marcando pacotes, e como vai marcar pacotes se não sabe o que são??
    A não ser que limite número de conexões pra tudo, daí seu cliente, com um P2P, chega no limite que vc determinou e o MKT começa a dropar o resto das conexões, daí o cara num navega, num abre MSN, num faz nada... ;-)

  6. #12

    Padrão

    Citação Postado originalmente por brenovale Ver Post
    Respondendo:
    Não.
    Para você controlar o Número de conexões, é melhor fazê-lo marcando pacotes, e como vai marcar pacotes se não sabe o que são??
    A não ser que limite número de conexões pra tudo, daí seu cliente, com um P2P, chega no limite que vc determinou e o MKT começa a dropar o resto das conexões, daí o cara num navega, num abre MSN, num faz nada... ;-)
    Certo.

    Refinando a coisa, marca-se conexões p2p, marca-se pacotes p2p, aplica-se limite de conexões ao p2p. É isso?

    Só tem que traduzir isso em comandos..,. ;-)