+ Responder ao Tópico



  1. #1

    Padrão PPPoe - Problemas com MTU

    Olá pessoal...

    Estou tentando montar um servidor pppoe e estou tendo o seguinte problema:

    Quando conecto autentica normal, mas quando tento navegar a conexao cai...
    Andei olhando os logs e encontrei o seguinte

    Aug 31 15:39:09 barrao pppoe-server[6863]: Session 4 created for client 00:1a:4d :a1:2b:2f (172.16.0.5) on eth0 using Service-Name 'InoveNet'
    Aug 31 15:39:09 barrao pppd[6863]: Plugin rp-pppoe.so loaded.
    Aug 31 15:39:09 barrao pppd[6863]: RP-PPPoE plugin version 3.3 compiled against pppd 2.4.2b3
    Aug 31 15:39:09 barrao pppd[6863]: Plugin radius.so loaded.
    Aug 31 15:39:09 barrao pppd[6863]: RADIUS plugin initialized.
    Aug 31 15:39:09 barrao pppd[6863]: Plugin radattr.so loaded.
    Aug 31 15:39:09 barrao pppd[6863]: RADATTR plugin initialized.
    Aug 31 15:39:09 barrao pppd[6863]: pppd 2.4.2b3 started by root, uid 0
    Aug 31 15:39:09 barrao pppd[6863]: Using interface ppp0
    Aug 31 15:39:09 barrao pppd[6863]: Connect: ppp0 <--> /dev/pts/3
    Aug 31 15:39:11 barrao pppd[6863]: PAP peer authentication succeeded for marcelo
    Aug 31 15:39:11 barrao pppd[6863]: not replacing existing default route to eth1 [192.168.100.1]
    Aug 31 15:39:11 barrao pppd[6863]: local IP address 172.16.0.1
    Aug 31 15:39:11 barrao pppd[6863]: remote IP address 172.16.0.10
    Aug 31 15:39:14 barrao pppoe[30253]: Packet too big! Check MTU on PPP interface
    Aug 31 15:39:25 barrao pppoe[6864]: send (sendPacket): No buffer space available
    Aug 31 15:39:56 barrao last message repeated 22 times
    Aug 31 15:40:00 barrao last message repeated 14 times
    Aug 31 15:40:01 barrao /USR/SBIN/CRON[6879]: (root) CMD ([ -d /etc/shaper ] && / etc/init.d/shaper timecheck)
    Aug 31 15:40:05 barrao pppoe[6864]: send (sendPacket): No buffer space available
    Aug 31 15:40:35 barrao last message repeated 39 times
    Aug 31 15:40:40 barrao pppoe[30253]: Packet too big! Check MTU on PPP interface
    Aug 31 15:40:40 barrao pppoe[6864]: send (sendPacket): No buffer space available
    Aug 31 15:40:40 barrao last message repeated 3 times
    Aug 31 15:40:41 barrao pppd[6863]: No response to 2 echo-requests
    Aug 31 15:40:41 barrao pppd[6863]: Serial link appears to be disconnected.
    Aug 31 15:40:45 barrao pppd[6863]: Connection terminated.
    Aug 31 15:40:45 barrao pppd[6863]: Connect time 1.6 minutes.
    Aug 31 15:40:45 barrao pppd[6863]: Sent 151591 bytes, received 126698 bytes.
    Aug 31 15:40:45 barrao pppoe[6864]: read (asyncReadFromPPP): Session 4: Input/ou tput error
    Aug 31 15:40:45 barrao pppd[6863]: Connect time 1.6 minutes.
    Aug 31 15:40:45 barrao pppd[6863]: Sent 151591 bytes, received 126698 bytes.
    Aug 31 15:40:45 barrao pppd[6863]: Exit.
    Aug 31 15:40:45 barrao pppoe-server[5942]: Session 4 closed for client 00:1a:4d: a1:2b:2f (172.16.0.5) on eth0
    Aug 31 15:40:45 barrao pppoe-server[5942]: Sent PADT



    Acredito q seja o MTU... como posso alterar o valor dele....
    ele esta atualmente como 1480

    ppp0 Encapsulamento do Link: Protocolo Ponto-a-Ponto
    inet end.: 172.16.0.1 P-a-P:172.16.0.10 Masc:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1480 Métrica:1
    RX packets:17 errors:0 dropped:0 overruns:0 frame:0
    TX packets:13 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:3
    RX bytes:7311 (7.1 KiB) TX bytes:6718 (6.5 KiB)

  2. #2

    Padrão

    amigo posta suas conf ae pra mim analisar



  3. #3

    Padrão

    # PPP options for the PPPoE server
    # LIC: GPL
    require-pap
    login
    lcp-echo-interval 10
    lcp-echo-failure 3
    ms-dns 200.254.210.132
    ms-dns 200.223.142.82
    netmask 255.255.255.0
    mtu 1488
    defaultroute
    noipdefault
    usepeerdns
    plugin radius.so
    plugin radattr.so



    a conexao com o radius esta beleza... o pppoe esta consultando o radius q esta consultando o mysql...
    agora o problema eh q a conexao nao segura
    ela conecta e cai.
    da o erro No response to 2 echo-requests

  4. #4

    Padrão

    tente deixar somente assim

    require-pap
    login
    lcp-echo-interval 10
    lcp-echo-failure 5
    ms-dns 200.254.210.132
    ms-dns 200.223.142.82
    plugin radius.so
    plugin radattr.so


    Citação Postado originalmente por fr4jol4 Ver Post
    # PPP options for the PPPoE server
    # LIC: GPL
    require-pap
    login
    lcp-echo-interval 10
    lcp-echo-failure 3
    ms-dns 200.254.210.132
    ms-dns 200.223.142.82
    netmask 255.255.255.0
    mtu 1488
    defaultroute
    noipdefault
    usepeerdns
    plugin radius.so
    plugin radattr.so



    a conexao com o radius esta beleza... o pppoe esta consultando o radius q esta consultando o mysql...
    agora o problema eh q a conexao nao segura
    ela conecta e cai.
    da o erro No response to 2 echo-requests



  5. #5

    Padrão

    Ok. coloquei assim o arquivo mas continua com o mesmo erro!!

    Sep 3 15:28:00 barrao pppd[24252]: Plugin radius.so loaded.
    Sep 3 15:28:00 barrao pppd[24252]: RADIUS plugin initialized.
    Sep 3 15:28:00 barrao pppd[24252]: Plugin radattr.so loaded.
    Sep 3 15:28:00 barrao pppd[24252]: RADATTR plugin initialized.
    Sep 3 15:28:00 barrao pppd[24252]: pppd 2.4.2b3 started by root, uid 0
    Sep 3 15:28:00 barrao pppd[24252]: Using interface ppp0
    Sep 3 15:28:00 barrao pppd[24252]: Connect: ppp0 <--> /dev/pts/1
    Sep 3 15:28:02 barrao pppd[24252]: PAP peer authentication succeeded for marcelo
    Sep 3 15:28:02 barrao pppd[24252]: local IP address 172.16.0.1
    Sep 3 15:28:02 barrao pppd[24252]: remote IP address 172.16.0.10
    Sep 3 15:29:11 barrao pppd[24252]: No response to 3 echo-requests
    Sep 3 15:29:11 barrao pppd[24252]: Serial link appears to be disconnected.
    Sep 3 15:29:18 barrao pppd[24252]: Connection terminated.
    Sep 3 15:29:18 barrao pppd[24252]: Connect time 1.2 minutes.
    Sep 3 15:29:18 barrao pppd[24252]: Sent 77289 bytes, received 14957 bytes.
    Sep 3 15:29:18 barrao pppoe[24253]: read (asyncReadFromPPP): Session 1: Input/output error
    Sep 3 15:29:18 barrao pppd[24252]: Connect time 1.2 minutes.
    Sep 3 15:29:18 barrao pppd[24252]: Sent 77289 bytes, received 14957 bytes.
    Sep 3 15:29:18 barrao pppd[24252]: Exit.
    Sep 3 15:29:18 barrao pppoe-server[24251]: Session 1 closed for client 00:1a:4d:a1:2b:2f (172.16.0.2) on eth0
    Sep 3 15:29:18 barrao pppoe-server[24251]: Sent PADT

  6. #6

    Padrão

    tente recompilar o rp-pppoe, outra coisa qual a linha de comando tu tá fazendo para subir os serviços e vc está utilizando auth no radius.



  7. #7

    Padrão

    Cara.. eu ja consegui resolver esse problema...
    Não me lembro oq eu fiz... rsrsr.. axo q devo ter compilado os pacotes mais atuais..

    Estou usando sim auth no radius.

    Inicio meu server com o comando:
    pppoe-server -C InoveNet -S InoveNet-PPPoe -L 172.16.100.1 -p /etc/ppp/faixa_ip -I eth0

    Agora me apareceu outro problema... rsrsrs

    Ja consegui fazer o seguinte:

    PPPoe-server + Freeradius + HTB + Cache Full

    So estou tendo problemas em amarrar o usuario ao mac.

    Vc pode me dar uma luz?

    Valeu!!

  8. #8

    Padrão

    Cconsegui...

    Fiz alguma coisa pra rodar o pppoe-server em kernel mode...
    dai ele envia o calling-id
    ainda nao sei ao certo oq foi...
    mas vou montar outro server do zero pra ver s consigo...

    valeu



  9. #9

    Padrão

    Citação Postado originalmente por fr4jol4 Ver Post
    Cconsegui...

    Fiz alguma coisa pra rodar o pppoe-server em kernel mode...
    dai ele envia o calling-id
    ainda nao sei ao certo oq foi...
    mas vou montar outro server do zero pra ver s consigo...

    valeu
    Legal, posta ae depois que vc fizer isso, e conselho melhor coisa é você subir em modo kernel o pppoe pois reduz bastante o consumo de cpu.

  10. #10

    Padrão Tenta setar no ppp.conf

    /etc/ppp/ppp.conf

    set mru 1452 #Coloque o MRU abaixo de 1500
    set mtu 1452 #Coloque o MRU abaixo de 1500

    Att.
    Budah



  11. #11

    Padrão

    Nao adianta cara...

    Tem q fazer o seguinte...

    vc compila o rp-pppoe com ./configure --enable-plugin

    e roda ele com pppoeserver -k

    em kernel mode..
    ai fica so o filé...

    Valeu