Página 2 de 11 PrimeiroPrimeiro 1234567 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #7

    Padrão Testes

    Fiz os testes aqui com o 3.0rc2 mais nao vi resultados, vou baixar a versão mais atualizada para testar, alguém já testou isso e deu certo?

  2. #8

    Padrão

    para wireless isso vai ser um tiro no pé !!! eu montei aqui um sistema que fazia isso.. e comecei a ter problema pelo alto trafego gerado...

    foi so desligar o 'super-cache' que tudo voltou ao normal... diminuiu 1.5mb de trafego em 2 dos meus pontos principais



  3. #9

    Padrão

    alexandre, dai dependo de como fazer, por exemplo to testando aqui mas ainda nao consegui direito, porem assim, issso é bom se caso o mk for o ap entao fazermos um controle de banda no ap do cliente, mas no meu caso to fazendo assim, mk no link fazendo controle de banda com esse recurso dai limito a 128 k o que nao estiver no proxy, e no ap que esta na torre faço mais uma queue e limito em 384 k, ou seja o trafego nao ira ser tao desastroso asssim e eu nao estarei colocando em risco minha rede.

    to testando aqui, instalei o sistema em um pendrive,. funciona maravilha, porem nao consegui terminar de testar e agora vou ter que reinstalar, segunda continuarei meus testes

  4. #10

    Padrão

    Citação Postado originalmente por alexandrecorrea Ver Post
    para wireless isso vai ser um tiro no pé !!! eu montei aqui um sistema que fazia isso.. e comecei a ter problema pelo alto trafego gerado...

    foi so desligar o 'super-cache' que tudo voltou ao normal... diminuiu 1.5mb de trafego em 2 dos meus pontos principais
    Eu também testei aqui e não obtive bons resultados. Acho melhor deixar o cliente navegando na banda contratado, mesmo quando o download está no cache. Em caso de download longo, pode deixar a rede lenta.



  5. #11

    Padrão

    bom eu ainda nao testei, porem ja fico meio desanimado com o parecer de voces, mas semanha que vem testarei pra ver, pq eu tinha esperança de que com isso funcionasse legal.

    vamos ver no que vai dar

  6. #12

    Padrão Cache FULL na versão 2.9.x

    Bom, estava esperando esse topico ser criado para eu poder entrar, vamos la.

    Cache Full.

    Todo mundo quer o danado do cache full, logo o cara ja imagina, poxa vida imagina meus clientes baixando arquivos que estejam direto no meu HD sem sair para net, e isso a todo vapor, em média 4MB que é o maximo hj que os cartões em 2.4ghz conseguem trafegar de dados real, o chamado "Throughput".
    Pois então, hj o mt se vc setar na opção do web-proxy que é o SQUID do mikrotik na opção Maximum Object Size para no exemplo 20000KB todos os arquivos que forem de ate 20MB baixados pela porta 80 serão armazenados em Disco, assim um proximo cliente que for baixar esse mesmo arquivo novamente ao inves de baixar ele da net d novo ele baixara direto do servidor mikrotik, sem precisar usar LINK de internet para isso, ate então perfeito!!! Isso é uma maravilha, da uma economia de 35% de link. Mas todos ja sabem que os clientes do mikrotik quando baixam esses arquivos que estão em cache "disco" ira baixar na largura da banda que esta setado no /queue simple dele. Ok
    Ai vem aquele lance, muita gente acha vantagem de se ter um cache full, o que seira isso, baixar os arquivos que estão em cache "disco" sem LIMITE DE VELOCIDADE, nossa, que louco não !!!

    Sim e não.

    Como ja foi falado anteriormente que se fazemos isso vai dar problemas, como gargalo nos APs, pq os mesmo n tem muita largura de banda para isso, então se apenas 1 cliente baixar um arquivo de 20MB que esta em cache "dsico" so ele ja estoura seu AP, pq vai dar uma taxa de transferencia de 400Kbps ate + um pouco... muito bom isso não ??? sim e não d novo, pq os d+ clientes estão tmb no mesmo AP requisitando acesso a net e como um cliente esta com essa taxa de transferencia a LATENCIA dos d+ estara la em cima, pings Horriveis, e muito problema, isso imaginamos em cima de um cliente, agora imagina 100 clientes ao mesmo tempo fazendo a mesma coisa caus e caus....

    Em fim o que eu quero deixar é que tem como sim fazer o cache FULL no mikrotik na versão 2.9.x vou postar como fazer isso, agora toma vc mesmo suas conclusãoes de se quer colocar ou não para funcionar

    1 - Marque os pacotes do proxy que entregue ao cliente
    / ip firewall mangle
    add chain=output protocol=tcp src-port=3126 action=mark-connection new-connection-mark=proxyC passthrough=yes comment="" disabled=no
    add chain=output connection-mark=proxyC action=mark-packet new-packet-mark=proxyF passthrough=no comment="" disabled=no

    2 - Crie um novo simple queue com essa marcação e deixa ele sem limite de velocidade
    /queue simple
    add name="CACHE FULL" target-addresses=0.0.0.0/0 dst-address=0.0.0.0/0 interface=all parent=none packet-marks=proxyF direction=both priority=8 \
    queue=default/default limit-at=0/0 max-limit=0/0 total-queue=default-small disabled=no

    Dessa forma tudo que estiver em cache "disco" será entregue ao cliente sem controle de banda.

    Não esquecer de colocar essas duas regras acima de qualquer OUTRA que tiver, tanto no /queue simple quanto no /ip firewall mangle

    Caso queira se aprovundar mais no que exatamente eu fiz pode consultar o fluxo do mikrotik, com ele vc faz o que vc quiser:
    http://www.mikrotik.com/testdocs/ros/2.9/ip/flow.php
    Última edição por tiagomatias; 22-09-2007 às 14:08.