Página 3 de 13 PrimeiroPrimeiro 12345678 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. bom eu ainda nao testei, porem ja fico meio desanimado com o parecer de voces, mas semanha que vem testarei pra ver, pq eu tinha esperança de que com isso funcionasse legal.

    vamos ver no que vai dar

  2. Bom, estava esperando esse topico ser criado para eu poder entrar, vamos la.

    Cache Full.

    Todo mundo quer o danado do cache full, logo o cara ja imagina, poxa vida imagina meus clientes baixando arquivos que estejam direto no meu HD sem sair para net, e isso a todo vapor, em média 4MB que é o maximo hj que os cartões em 2.4ghz conseguem trafegar de dados real, o chamado "Throughput".
    Pois então, hj o mt se vc setar na opção do web-proxy que é o SQUID do mikrotik na opção Maximum Object Size para no exemplo 20000KB todos os arquivos que forem de ate 20MB baixados pela porta 80 serão armazenados em Disco, assim um proximo cliente que for baixar esse mesmo arquivo novamente ao inves de baixar ele da net d novo ele baixara direto do servidor mikrotik, sem precisar usar LINK de internet para isso, ate então perfeito!!! Isso é uma maravilha, da uma economia de 35% de link. Mas todos ja sabem que os clientes do mikrotik quando baixam esses arquivos que estão em cache "disco" ira baixar na largura da banda que esta setado no /queue simple dele. Ok
    Ai vem aquele lance, muita gente acha vantagem de se ter um cache full, o que seira isso, baixar os arquivos que estão em cache "disco" sem LIMITE DE VELOCIDADE, nossa, que louco não !!!

    Sim e não.

    Como ja foi falado anteriormente que se fazemos isso vai dar problemas, como gargalo nos APs, pq os mesmo n tem muita largura de banda para isso, então se apenas 1 cliente baixar um arquivo de 20MB que esta em cache "dsico" so ele ja estoura seu AP, pq vai dar uma taxa de transferencia de 400Kbps ate + um pouco... muito bom isso não ??? sim e não d novo, pq os d+ clientes estão tmb no mesmo AP requisitando acesso a net e como um cliente esta com essa taxa de transferencia a LATENCIA dos d+ estara la em cima, pings Horriveis, e muito problema, isso imaginamos em cima de um cliente, agora imagina 100 clientes ao mesmo tempo fazendo a mesma coisa caus e caus....

    Em fim o que eu quero deixar é que tem como sim fazer o cache FULL no mikrotik na versão 2.9.x vou postar como fazer isso, agora toma vc mesmo suas conclusãoes de se quer colocar ou não para funcionar

    1 - Marque os pacotes do proxy que entregue ao cliente
    / ip firewall mangle
    add chain=output protocol=tcp src-port=3126 action=mark-connection new-connection-mark=proxyC passthrough=yes comment="" disabled=no
    add chain=output connection-mark=proxyC action=mark-packet new-packet-mark=proxyF passthrough=no comment="" disabled=no

    2 - Crie um novo simple queue com essa marcação e deixa ele sem limite de velocidade
    /queue simple
    add name="CACHE FULL" target-addresses=0.0.0.0/0 dst-address=0.0.0.0/0 interface=all parent=none packet-marks=proxyF direction=both priority=8 \
    queue=default/default limit-at=0/0 max-limit=0/0 total-queue=default-small disabled=no

    Dessa forma tudo que estiver em cache "disco" será entregue ao cliente sem controle de banda.

    Não esquecer de colocar essas duas regras acima de qualquer OUTRA que tiver, tanto no /queue simple quanto no /ip firewall mangle

    Caso queira se aprovundar mais no que exatamente eu fiz pode consultar o fluxo do mikrotik, com ele vc faz o que vc quiser:
    http://www.mikrotik.com/testdocs/ros/2.9/ip/flow.php
    Última edição por tiagomatias; 22-09-2007 às 14:08.



  3. tiago, na sua regra onde tem port 3126? é pq é a sua porta do proxy? pq no meu caso uso a porta 3128 entao devo mudar ali? é isso? ou o que?

    gostaria de lembrar ao meu ver acho util esse recurso como expliquei em um outro post, nao entregando full para o cliente mas sim, fazendo esse recurso no gateway da rede, e fazendo mais um controle de banda no AP, onde eu limitaria em 384 kbps, no meu caso, ou seja, o que estiver no proxy ira 3 vezes mais rapido do que o normal, o que nao seria um exagero assim, vou fazer testes, como falei, talvez eu ate coloque 256 kbps no lugar de 384, mas acho que ira ajudar sim, posso estar errado porem vou testar.

    parabes tiago boa contribuição, assim que der vou testar tbem

    ha no caso o ap que eu me refiro é um Mikrotik AP ta legal,,,

  4. Citação Postado originalmente por tiagomatias Ver Post
    Bom, estava esperando esse topico ser criado para eu poder entrar, vamos la.

    Cache Full.

    Todo mundo quer o danado do cache full, logo o cara ja imagina, poxa vida imagina meus clientes baixando arquivos que estejam direto no meu HD sem sair para net, e isso a todo vapor, em média 4MB que é o maximo hj que os cartões em 2.4ghz conseguem trafegar de dados real, o chamado "Throughput".
    Pois então, hj o mt se vc setar na opção do web-proxy que é o SQUID do mikrotik na opção Maximum Object Size para no exemplo 20000KB todos os arquivos que forem de ate 20MB baixados pela porta 80 serão armazenados em Disco, assim um proximo cliente que for baixar esse mesmo arquivo novamente ao inves de baixar ele da net d novo ele baixara direto do servidor mikrotik, sem precisar usar LINK de internet para isso, ate então perfeito!!! Isso é uma maravilha, da uma economia de 35% de link. Mas todos ja sabem que os clientes do mikrotik quando baixam esses arquivos que estão em cache "disco" ira baixar na largura da banda que esta setado no /queue simple dele. Ok
    Ai vem aquele lance, muita gente acha vantagem de se ter um cache full, o que seira isso, baixar os arquivos que estão em cache "disco" sem LIMITE DE VELOCIDADE, nossa, que louco não !!!

    Sim e não.

    Como ja foi falado anteriormente que se fazemos isso vai dar problemas, como gargalo nos APs, pq os mesmo n tem muita largura de banda para isso, então se apenas 1 cliente baixar um arquivo de 20MB que esta em cache "dsico" so ele ja estoura seu AP, pq vai dar uma taxa de transferencia de 400Kbps ate + um pouco... muito bom isso não ??? sim e não d novo, pq os d+ clientes estão tmb no mesmo AP requisitando acesso a net e como um cliente esta com essa taxa de transferencia a LATENCIA dos d+ estara la em cima, pings Horriveis, e muito problema, isso imaginamos em cima de um cliente, agora imagina 100 clientes ao mesmo tempo fazendo a mesma coisa caus e caus....

    Em fim o que eu quero deixar é que tem como sim fazer o cache FULL no mikrotik na versão 2.9.x vou postar como fazer isso, agora toma vc mesmo suas conclusãoes de se quer colocar ou não para funcionar

    1 - Marque os pacotes do proxy que entregue ao cliente
    / ip firewall mangle
    add chain=output protocol=tcp src-port=3126 action=mark-connection new-connection-mark=proxyC passthrough=yes comment="" disabled=no
    add chain=output connection-mark=proxyC action=mark-packet new-packet-mark=proxyF passthrough=no comment="" disabled=no

    2 - Crie um novo simple queue com essa marcação e deixa ele sem limite de velocidade
    /queue simple
    add name="CACHE FULL" target-addresses=0.0.0.0/0 dst-address=0.0.0.0/0 interface=all parent=none packet-marks=proxyF direction=both priority=8 \
    queue=default/default limit-at=0/0 max-limit=0/0 total-queue=default-small disabled=no

    Dessa forma tudo que estiver em cache "disco" será entregue ao cliente sem controle de banda.

    Não esquecer de colocar essas duas regras acima de qualquer OUTRA que tiver, tanto no /queue simple quanto no /ip firewall mangle

    Caso queira se aprovundar mais no que exatamente eu fiz pode consultar o fluxo do mikrotik, com ele vc faz o que vc quiser:
    http://www.mikrotik.com/testdocs/ros/2.9/ip/flow.php
    acho q dessa forma q vc descreveu nao vai adiantar muito, pq o mikrotik ainda nao sabe se vem do disco, ou se vem da internet, só vai saber q ta saindo do proxy

    o que o mikrotik na versao 3 faz, é marcar la no PROXY os pacotes com acertos (HITS) pq esses sim vem do disco, e depois tirar o controle de velocidade desses pacotes

    na sua demonstracao, todos os pacotes q vierem do proxy independente se vem do disco ou da internet seram sem velocidade,

    é uma boa saida para acelerar navegacao e deixar o resto com controle mais baixo
    mas vai acelerar tudo vier do proxy, e nao só o que vem do disco



  5. bom, olhando bem o codigo q o Tiago Matias postou, resolvi fazer uma implementacao diferente aqui e acho q ficou legal fiz da seguinte forma

    atendo cerca de 35 clientes por AP
    cada AP tem sua propria rede ex: AP1 rede 192.1680.0/24 AP2 192.168.1.0/24

    levando em conta q cada AP suporta um thorougput de 4mb, resolvi entao implementar as regras do queue da seguinte forma:

    1 name="Proxy-Cache 192.168.0.0/24" target-addresses=192.168.0.0/24
    dst-address=0.0.0.0/0 interface=all parent=none packet-marks=proxyF
    priority=6 queue=wireless-default/wireless-default
    limit-at=1024000/1024000 max-limit=2048000/2048000
    burst-limit=0/0 burst-threshold=0/0
    burst-time=0/0 total-queue=default

    2 name="Proxy-Cache 192.168.1.0/24" target-addresses=192.168.1.0/24
    dst-address=0.0.0.0/0 interface=all parent=none packet-marks=proxyF
    priority=6 queue=wireless-default/wireless-default
    limit-at=1024000/1024000 max-limit=2048000/2048000
    burst-limit=0/0 burst-threshold=0/0
    burst-time=0/0 total-queue=default


    e assim por diante, tudo q vier do PROXY passa para os clientes a 2mb, e tudo q vier por fora do PROXY, como radio, FTP, email e tal passa na velocidade normal

    lembrando q eh 2mb para todos os clientes da rede, nesse caso estarei usando metade do thorougput do AP para navegacao, fiz um teste agora, e ficou bem legal

    porem isso se aplica a minha forma de trabalhar com a rede, q tenho no max 35 40 clientes por rede, quem tiver redes lotadas com certeza vai embuxar no AP e ficar ruim pro pessoal

    quem usa rede cabeada acho q iria ficar uma maravilha

    testem ai e postem seus resultados






Tópicos Similares

  1. Proxy Full
    Por apnet no fórum Redes
    Respostas: 4
    Último Post: 12-03-2008, 07:55
  2. ConfiguraÇÃo Do Web Proxy Full No Mikrotik 3.2
    Por wescleybueno1 no fórum Redes
    Respostas: 9
    Último Post: 11-03-2008, 08:57
  3. Proxy Full Agora Sim........
    Por Briza no fórum Redes
    Respostas: 1
    Último Post: 21-01-2008, 01:29
  4. Acessando o proxy de fora da rede interna
    Por rogerius no fórum Servidores de Rede
    Respostas: 7
    Último Post: 13-09-2006, 20:18
  5. Respostas: 0
    Último Post: 22-05-2003, 08:20

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L