+ Responder ao Tópico



  1. #1

    Padrão Medidor de velocidae fora do controle de banda...

    Citação Postado originalmente por gustkiller Ver Post
    sobre fluxos pra galera entender apenas o que importa

    o fluxo input e output sao pacotes entrando e saindo do mikrotik.

    por isto fazendo um mangle com marcação de output da pra saber que é um pacote vindo do proprio mikrotik e nao da internet.


    pro pessoal não ficar tão voando de como a regra funciona
    Bom dia respondendo a algumas pessoas que pediram como fazer para que quando o cliente fazer o teste de velocidade em alguns determinados sites que medem a velocidade da internet, deixar ela fora do controle de banda, dessa forma, o cliente
    quando for medir a velocidade ela vai muito mais alto doque a contratado.

    Novamente se sabendo como fazer as marcações de pacotes corretas no /ip firewall mangle, se pode fazer qualquer coisa com o pacote.

    Então vamos la:
    Primeiro:
    Teremos que ter em mãos todos os endereços dos sites que fazem medição de velocidade, imagino que vc deve ter logo levado um susto né pq imagina qts sites tem no mundo que fazar medição de velocidade..... pois é nesse caso o que eu fiz, procurei no google.com.br por sites que fazem medição de velocidade e filtrei os ips das duas primeiras paginas de resultado que ela meu deu, ja da para começar com essa lista, qualquer coisa vc mesmo pode ir aumentando ela ok.

    Iremos criar uma lista com todos os ips dos sites que fazem medição de velocidade e o nome dela vai se chamar "medidor"
    / ip firewall address-list
    add list=medidor address=200.140.120.29 comment="" disabled=no
    add list=medidor address=200.159.128.189 comment="" disabled=no
    add list=medidor address=209.160.32.66 comment="" disabled=no
    add list=medidor address=64.247.18.18 comment="" disabled=no
    add list=medidor address=200.159.160.39 comment="" disabled=no
    add list=medidor address=213.200.107.145 comment="" disabled=no
    add list=medidor address=200.245.0.12 comment="" disabled=no
    add list=medidor address=201.76.32.191 comment="" disabled=no
    add list=medidor address=200.150.160.39 comment="" disabled=no
    add list=medidor address=201.20.64.39 comment="" disabled=no
    add list=medidor address=66.216.44.80 comment="" disabled=no
    add list=medidor address=200.181.108.29 comment="" disabled=no
    add list=medidor address=200.196.233.42 comment="" disabled=no
    add list=medidor address=200.233.43.14 comment="" disabled=no
    add list=medidor address=201.84.0.28 comment="" disabled=no
    add list=medidor address=200.162.192.57 comment="" disabled=no

    Aqui esta um pouco de alguns sites que fazem medição de velocidade caso queira acrescentar, pode acrescentar sem problemas algum.

    Segundo:
    Agora entra a marcação de pacotes desses endereços IPs, e é aqui o segredo de tudo para funcionar perfeitamente, iremos fazer as marcações e dar um nome ao pacote chamado "medidorF"
    / ip firewall mangle
    add chain=prerouting dst-address-list=medidor action=mark-connection new-connection-mark=medidorC passthrough=yes comment="MEDIDOR" disabled=no
    add chain=prerouting connection-mark=medidorC action=mark-packet new-packet-mark=medidorF passthrough=no comment="" disabled=no
    add chain=input dst-address-list=medidor action=mark-connection new-connection-mark=medidorC passthrough=yes comment="MEDIDOR" disabled=no
    add chain=input connection-mark=medidorC action=mark-packet new-packet-mark=medidorF passthrough=no comment="" disabled=no
    add chain=output dst-address-list=medidor action=mark-connection new-connection-mark=medidorC passthrough=yes comment="MEDIDOR" disabled=no
    add chain=output connection-mark=medidorC action=mark-packet new-packet-mark=medidorF passthrough=no comment="" disabled=no
    add chain=postrouting dst-address-list=medidor action=mark-connection new-connection-mark=medidorC passthrough=yes comment="MEDIDOR" disabled=no
    add chain=postrouting connection-mark=medidorC action=mark-packet new-packet-mark=medidorF passthrough=no comment="" disabled=no

    Basta essas marcações apenas para poder funcionar perfeitamente, não esqueça se vc tiver alguma outra marcação em seu firewall mangle, coloque essas acima de tudo para poder funcionar perfeitamente

    Terceiro:
    Agora temos que criar no /queue simple uma regra com a marcação de pacotes que criamos, dizendo a velocidade que vc quer que de na medição dos seus clientes, ou vc deixa ela ilimitado ou vc pode colocar um limite de velocidade, no exemplo vou deixar upload a 64k e download ilimitado.
    / queue simple
    add name="MEDIDOR" target-addresses=0.0.0.0/0 dst-address=0.0.0.0/0 interface=all parent=none packet-marks=medidorF direction=both priority=8 \
    queue=up-0/down-0 limit-at=0/0 max-limit=64000/0 total-queue=default-small disabled=no

    Não esquecer de colocar essa regra acima de todos os outros controles de banda que vc tiver.

    Façam os testes e se alguém conhecer outros sites que fazem medição de velocidade postem aqui para aumentarmos nossa lista.

    Ps. se alguem souber como criar um WIKI crie com esse artigo e se n for muito encomodo coloque tmb do :"proxy Full"

    Abraços
    Última edição por tiagomatias; 25-09-2007 às 12:47.

  2. #2



  3. #3

    Padrão

    acho isso uma bela de uma safadeza, e não farei isso nunca na minha rede.

    Mas a dica está aí, não contesto quem a divulgou. Contesto quem a usa.

  4. #4

    Padrão

    Citação Postado originalmente por Gosulator Ver Post
    acho isso uma bela de uma safadeza, e não farei isso nunca na minha rede.

    Mas a dica está aí, não contesto quem a divulgou. Contesto quem a usa.

    Olá, boa noite!


    Olhe com outros olhos, vamos supor que você venda 200k de velocidade ao seu cliente, ele faça o teste de velocidade 100 vezes por semana, se 99 vezes o teste mostrar exatamente a velocidade que você vende a ele e uma vez não, na primeira oportunidade que ele tiver ele vai te dizer: Fiz o teste de velocidade mas não deu os 200k só deu 150k, e despreza completamente as outras vezes em que ele fez o teste e estava tudo como contratado.


    Então o rapaz não está colocando no forum que alguém venda 200k e só entregue 64k, ele simplesmente está procurando uma solução para um problema constante que é os clientes reclamando que a velocidade só está dando xxx.

    A não ser que a sua rede seja pequena e não tenha muitos clientes navegando ai você com certeza não tem esse problema, mas espera crescer um pouco para lembrar do que estou falando...

    Abração e boa noite.



  5. #5

    Padrão

    Isso é verdade, aqui tenho 22 clientes, e vendo 160 k, geralmente dá isso nos testes, qdo algum dia dá abaixo, tipo 120 k aí depois vem falar q tava baixo, q isso e aquilo, as vzs enche o saco isso, se repararmos até nas grandes operadoras acontece isso, tenho conexões de 1024k e ñ passa de 940 k, ninguém reclama às operadoras, mas como nós pequenos somos mais fácil terem acesso, metem o pau...

  6. #6

    Padrão

    cara
    fiz o teste aqui e até ta marcando os pacotes mas o queue nao ta dando certo!!

    alguem posta certo a queue pq nao d apra adicionar a postada ai

    vlww



  7. #7

    Padrão

    Citação Postado originalmente por Gosulator Ver Post
    acho isso uma bela de uma safadeza, e não farei isso nunca na minha rede.
    Mas a dica está aí, não contesto quem a divulgou. Contesto quem a usa.
    Concordo, é extremamente anti-ético, mas achei muito interessante para adaptação em outras situações.

  8. #8

    Padrão

    Citação Postado originalmente por thenet Ver Post
    cara
    fiz o teste aqui e até ta marcando os pacotes mas o queue nao ta dando certo!!

    alguem posta certo a queue pq nao d apra adicionar a postada ai

    vlww
    Kara, vc tem q adaptar na sua rede, por ex esse é o script q ele postou:

    / queue simple
    add name="MEDIDOR" target-addresses=0.0.0.0/0 dst-address=0.0.0.0/0 interface=all parent=none packet-marks=medidorF direction=both priority=8 \
    queue=up-0/down-0 limit-at=0/0 max-limit=64000/0 total-queue=default-small disabled=no

    o meu só funcionou assim:

    / queue simple
    add name="MEDIDOR" target-addresses=0.0.0.0/0 dst-address=0.0.0.0/0 \
    interface=all parent=none packet-marks=medidorF direction=both priority=8 \
    queue=default-small/default-small limit-at=0/0 max-limit=200000/200000 \
    total-queue=default-small disabled=no



  9. #9

    Padrão

    Citação Postado originalmente por Roberto21 Ver Post
    Olá, boa noite!


    Olhe com outros olhos, vamos supor que você venda 200k de velocidade ao seu cliente, ele faça o teste de velocidade 100 vezes por semana, se 99 vezes o teste mostrar exatamente a velocidade que você vende a ele e uma vez não, na primeira oportunidade que ele tiver ele vai te dizer: Fiz o teste de velocidade mas não deu os 200k só deu 150k, e despreza completamente as outras vezes em que ele fez o teste e estava tudo como contratado.


    Então o rapaz não está colocando no forum que alguém venda 200k e só entregue 64k, ele simplesmente está procurando uma solução para um problema constante que é os clientes reclamando que a velocidade só está dando xxx.

    A não ser que a sua rede seja pequena e não tenha muitos clientes navegando ai você com certeza não tem esse problema, mas espera crescer um pouco para lembrar do que estou falando...

    Abração e boa noite.
    Uma coisa não justifica a outra Roberto. Aqui eu tenho MUITA reclamação desse tipo. Eu sento com o cliente, e explico pra ele que esses medidores não são precisos, e que as vezes realmente a rede está sobrecarregada e a velocidade baixa mesmo. Explico que esse é o único modo de cobrar dele o valor que cobro. E peço pra ele comparar, e se achar que vale a pena pagar um dsl pra ter a velocidade contratada 24h/d 7d/s, então contrate o dsl. Se ele acha que vale pagar o que me paga, pra ter sua velocidade máxima 90% do tempo, então ele fica.

    Como a maioria dos clientes são muito leigos, eu tento entrar o mínimo possível em detalhes. Prefiro focar no fato de esses medidores serem bem aleatórios e nem sempre mostrarem os valores iguais. Faço testes em vários sites diferentes, pra mostrar pra ele a variação que existe entre esses velocímetros, e explico pra ele que na hora do pico realmente pode acontecer de vc não alcançar a velocidade máxima contratada.

    Todos até agora entenderam e aceitaram, e minha conciência está mais limpa que nunca.