+ Responder ao Tópico



  1. #1

    Question Squid + AD + LDAP + Win2003 R2


    Olá, boa tarde a todos
    Tenho em minha rede 1 server com Windows 2003 R2 rodando com AD para autenticar os usuários da rede.
    Agora quero colocar o Squid como Proxy e os usuários sejam autenticados pelo AD do Win2003.
    Dei uma olhada nesse link:
    Linux: Squid autenticando em base Active Directory [Artigo]
    Fiz tudo exatamente como está ai, só que a autenticação não funciona, no browser fica pedindo user e senha dai eu digito e ele não autentica, volta para a tela de login e senha. Outro detalhe... o que tenho que alterar na conf do squid / AD para que o usuário só se autentique 1 vez, ou seja, no login da máquina, não sendo preciso o usuário autenticar quando abrir o navegador.

  2. #2

    Padrão

    acho q vc precisar colocar a ferramenta pra autenticar atravez do RADIUS

    ai tem q habilitar um serviço chamado IAS no 2003

    vamos colocar essa estrutura aqui na universidade

    da uma pesquisada ai, nao é tao dificil achar tutorial como usa radius nao
    flw



  3. #3

    Padrão

    Citação Postado originalmente por ticesar7 Ver Post

    Olá, boa tarde a todos
    Tenho em minha rede 1 server com Windows 2003 R2 rodando com AD para autenticar os usuários da rede.
    Agora quero colocar o Squid como Proxy e os usuários sejam autenticados pelo AD do Win2003.
    Dei uma olhada nesse link:
    Linux: Squid autenticando em base Active Directory [Artigo]
    Fiz tudo exatamente como está ai, só que a autenticação não funciona, no browser fica pedindo user e senha dai eu digito e ele não autentica, volta para a tela de login e senha. Outro detalhe... o que tenho que alterar na conf do squid / AD para que o usuário só se autentique 1 vez, ou seja, no login da máquina, não sendo preciso o usuário autenticar quando abrir o navegador.
    ticesar7,
    Também estou tendo o mesmo problema. Estou pesquisando para resolve-lo se eu achar algo postarei aqui, gostaria que fizesse o mesmo. Estava conversando com um amigo ontem, e ele disse que conseguiu fazer esta solucao funcionar com a tal distribuição chamada 'ipcop'. Ele disse que conseguiu fazer funcionar facilmente, mas meu caso nao pode ser resolvido assim, pois aqui na prefeitura de vix a gente usa fedora. Pesquisarei mais sobre o assunto e qualquer novidade eu posto aqui.

  4. #4

    Padrão

    fiz esse dias baseado nesse artigo: Linux: Squid Plus com AD, redirector, controle de banda e relatórios [Artigo]
    está funcional do jeito que vc´s precisam, mas foram necessárias algumas adpatações.



  5. #5

    Padrão

    Citação Postado originalmente por ticesar7 Ver Post

    Olá, boa tarde a todos
    Tenho em minha rede 1 server com Windows 2003 R2 rodando com AD para autenticar os usuários da rede.
    Agora quero colocar o Squid como Proxy e os usuários sejam autenticados pelo AD do Win2003.
    Dei uma olhada nesse link:
    Linux: Squid autenticando em base Active Directory [Artigo]
    Fiz tudo exatamente como está ai, só que a autenticação não funciona, no browser fica pedindo user e senha dai eu digito e ele não autentica, volta para a tela de login e senha. Outro detalhe... o que tenho que alterar na conf do squid / AD para que o usuário só se autentique 1 vez, ou seja, no login da máquina, não sendo preciso o usuário autenticar quando abrir o navegador.
    ticesar67

    Consegui resolver nosso problema a partir do tutorial que estavamos tentando seguir do vivaolinux. Como sempre faço mas porem desta vez esqueci de fazer, nao li os comentarios do tutorial que sempre estao logo abaixo dele, e um user encontrou um erro no tutorial e neste comentario postou o erro, que eu fiz a mudança no script e funcionou corretamente, teste ai e nos diga qual foi o resultado.

    --

    Comentário enviado por fredenais em 23/05/2007 - 15:59h:

    Ola para todos,

    Usei esse tutorial e funcionou bem depois que corrigi um problema de troca de posição de parâmetros.

    Observem que nas seguintes linhas está assim:

    acl ldapAcessoRestrito external ldap_group AcessoRestrito
    acl ldapAcessoPadrao external ldap_group AcessoPadrao
    acl ldapAcessoTotal external ldap_group AcessoTotal
    acl ldapAcessoDownload external ldap_group AcessoDownload

    Mudei para:

    acl AcessoRestrito external ldap_group ldapAcessoRestrito
    acl AcessoPadrao external ldap_group ldapAcessoPadrao
    acl AcessoTotal external ldap_group ldapAcessoTotal
    acl AcessoDownload external ldap_group ldapAcessoDownload

    e retirei os ldap das seguintes http_access:

    http_access deny ldapAcessoRestrito
    http_access allow ldapAcessoTotal
    http_access allow ldapAcessoDownload block_arq
    http_access allow ldapAcessoDownload palavra_download
    http_access allow ldapAcessoPadrao

    mudei para

    http_access deny AcessoRestrito
    http_access allow AcessoTotal
    http_access allow AcessoDownload block_arq
    http_access allow AcessoDownload palavra_download
    http_access allow AcessoPadrao

    agora está funcionando tudo bem
    Obrigado e parabéns pelo tutorial

    --

  6. #6

    Padrão

    timidboy
    Fiz aqui e mesmo assim continuo com o mesmo problema, estou testando agora outra maneira... pelo autenticador msnt_auth. Logo que terminar de testar, dando certo ou errado eu posta aqui.
    Valeu!!!



  7. #7

    Padrão

    Citação Postado originalmente por ticesar7 Ver Post

    Olá, boa tarde a todos
    Tenho em minha rede 1 server com Windows 2003 R2 rodando com AD para autenticar os usuários da rede.
    Agora quero colocar o Squid como Proxy e os usuários sejam autenticados pelo AD do Win2003.
    Dei uma olhada nesse link:
    Linux: Squid autenticando em base Active Directory [Artigo]
    Fiz tudo exatamente como está ai, só que a autenticação não funciona, no browser fica pedindo user e senha dai eu digito e ele não autentica, volta para a tela de login e senha. Outro detalhe... o que tenho que alterar na conf do squid / AD para que o usuário só se autentique 1 vez, ou seja, no login da máquina, não sendo preciso o usuário autenticar quando abrir o navegador.

    Boa Noite Amigo está funcionando o unico problema que voce esta tendo e nas acl tive esse problema cola suas acl para eu ver como está

  8. #8

    Smile

    Citação Postado originalmente por ticesar7 Ver Post
    timidboy
    Fiz aqui e mesmo assim continuo com o mesmo problema, estou testando agora outra maneira... pelo autenticador msnt_auth. Logo que terminar de testar, dando certo ou errado eu posta aqui.
    Valeu!!!
    ticesar, se precisar de ajuda estamos ai
    pq eu consegui fazer aquele tuto do site funcionar
    abracao



  9. #9

    Question

    Senhores, deculpe me insistencia mas mesmo seguindo todos os passos e refazendo 1 por 1 eu ainda não consegui fazer funcionar.
    digitei o comando direto: /usr/local/squid/libexec/squid_ldap_auth -R -b "dc=meudominio,dc=com,dc=br" -D "cn=proxy_user,ou=Internet,dc=meudominio,dc=com,dc=br" -w "123456" -f sAMAccountName=%s -h 192.168.1.1 e o resultado é nada... ou seja fica parado na tela, dai se eu aperto <ENTER> aparece ERR, só isso. paralelamente um fiz um tcpdump no ip do server de ldap e não vai nenhum pacote para ele.
    Fiz um teste com o autenticar msnt_auth e funcionou perfeitamente, mas com o squid_ldap_auth não funciona... Não sei mas o que fazer. Agradeço qq ajuda. Obrigado