+ Responder ao Tópico



  1. #1

    Question load balance/ hotspot

    pesso a ajudas de vcs para solucionar o meu problema, eu add umas regras aqui do under no mangle para marcar as rotas e add o gateway no rout mas só funciona quando desativo o hotspot, pois quando o hotspot está ligado sai tudo pelo link principal.

    Obs.: o segundo link vem pela mesmo interface q sai para os usuarios!

    abraços e um bom feriadao a todos!

  2. #2

    Padrão

    Sem as regras fica complicado te ajudar.
    Poste elas aqui, que vamos te ajudar .



  3. #3

    Padrão

    ai as regras

    2 X ;;; Marca conexoes na porta 21 c/ a marca link2
    chain=prerouting protocol=tcp dst-port=21 action=mark-routing
    new-routing-mark=link2 passthrough=no

    3 X ;;; Marca conexoes na porta 22 c/ a marca link2
    chain=prerouting protocol=tcp dst-port=22 action=mark-routing
    new-routing-mark=link2 passthrough=no

    4 X ;;; Marca conexoes na porta 23 c/ a marca link2
    chain=prerouting protocol=tcp dst-port=23 action=mark-routing
    new-routing-mark=link2 passthrough=no

    5 X ;;; Marca conexoes na porta 25 c/ a marca link2
    chain=prerouting protocol=tcp dst-port=25 action=mark-routing
    new-routing-mark=link2 passthrough=no

    6 X ;;; Marca conexoes na porta 53 c/ a marca link2
    chain=prerouting protocol=tcp dst-port=53 action=mark-routing
    new-routing-mark=link2 passthrough=no

    7 X ;;; Marca conexoes na porta 53 c/ a marca link2
    chain=prerouting protocol=udp dst-port=53 action=mark-routing
    new-routing-mark=link2 passthrough=no

    8 X ;;; Marca conexoes na porta 80 c/ a marca link2
    chain=prerouting protocol=tcp dst-port=80 action=mark-routing
    new-routing-mark=link2 passthrough=no

    9 X ;;; Marca conexoes na porta 110 c/ a marca link2
    chain=prerouting protocol=tcp dst-port=110 action=mark-routing
    new-routing-mark=link2 passthrough=no

    10 X ;;; Marca conexoes na porta 443 c/ a marca link2
    chain=prerouting protocol=tcp dst-port=443 action=mark-routing
    new-routing-mark=link2 passthrough=no

    11 X ;;; Marca pacotes c/ a marca link2
    chain=prerouting routing-mark=link2 action=mark-packet new-packet-mark=link2
    passthrough=no

    r em routes coloquei gateway 192.168.1.8(ip do link2) destination 0.0.0.0/0 e mark link2

  4. #4

    Padrão

    por favor ajudem aew, ta muito dificil axar issu, ja olhei o forum de cabo a rabo e nada de ter uma solução!



  5. #5

    Padrão

    Parceiro, num consegui colocar esse load ae pra funcionar certim não, e olha que tentei várias formas, com esse tipo ae de marcação de portas vc terá problemas.
    Eu uso sempre por rotas estáticas, é o unico que fiz funcionar 100%.
    Dê uma olhada com mais calma aqui no forum que vc vai encontrar exemplos.

  6. #6

    Unhappy

    Citação Postado originalmente por rps67 Ver Post
    Parceiro, num consegui colocar esse load ae pra funcionar certim não, e olha que tentei várias formas, com esse tipo ae de marcação de portas vc terá problemas.
    Eu uso sempre por rotas estáticas, é o unico que fiz funcionar 100%.
    Dê uma olhada com mais calma aqui no forum que vc vai encontrar exemplos.
    Boa noite amigo,
    Gostaria de te pedir esse script seu do load balance que vc usa pq eu pesquisei ums aki no forum e colei no meu MK e na hora ele funciona mas depois ele para de funcionar e qujeria que vc postase esse seu script pra mim para eu poder analizar. Tenho um MK com dois ADSL lembrando que os dois estão em Router. Grato.