+ Responder ao Tópico



  1. #1

    Unhappy Configurar os ips para funcionamento da internet

    Olá pessoal,
    sou novo na comunidade e este é o meu primeiro post!

    Acabo de instalar um servidor mikrotik, onde o mesmo conta com 2 placas de rede convencionais. Minha intensão é colocar uma das placas para buscar conexão internet em um modem adsl já roteado com os ips: ip 10.0.0.254 masc 255.255.0.0 dns 200.149.55.140 200.165.132.148 e levar internet a um Access Point Gi-Link já configurado em modo bridge onde os ips são: ip 10.0.0.1 masc 255.255.0.0 gateway 10.0.0.254 dns 200.149.55.140 200.165.132.148 para distribuição de internet via rádio indoor.

    Já quebrei bastante a cabeça antes entrar em contato com vcs, não consigo de maneira alguma transmitir a internet, nem mesmo plugando o cabo de rede de um computador na placa de rede do servidor mikrotik que configurei para levar ao Access Point. Já li vários posts e também algumas apostilas básicas, mas não tenho encontrado nada sobre como configurar os primeiros ips do servidor mikrotik.

    consigo acessar normalmente o servidor por qualquer uma das placas de rede instaladas, a ether1 e ether2, pinga normal e acessa por meio de WinBox.

    Acredito que exista segredos e marcetes de configuração que só vcs mesmos para
    me ajudar.

    Obrigado pela atenção.

    Um grande abraço a todos!
    Última edição por marioth; 24-10-2007 às 22:05.

  2. #2

    Padrão

    fala marioth.. blza?!.. bom deixa eu dar minha opinião:

    Primeiro vou dar minha opinião, caso vc ache interessante te passo os passos pra configurar:

    Se eu fosse vc, eu transformava esse modem ADSL em bridge, colocava o Mikrotik pra ser cliente PPPOE o que logo faria o mikrotik receber o IP válido da operadora em sua interface. Na outra interface vc mantem o ip falso 10.0.0.254 com a mascara 255.255.255.0, Ativa o NAT e habilita o DHCP se for o caso, coloca o AP como bridge com ip 10.0.0.1 mascara 255.255.255.0 e gtw 10.0.0.254 ou coloca ele pra pegar ip automático do mikrotik, seus usuarios que se conectarem no AP vão pegar IP automático do mikrotik e navegar numa boa.

    Essa é a minha idéia, se gostar, posta aí que monto a configuração pra vc...Valeu?!

    Abraços,

    Reinaldo.



  3. #3

    Wink

    Citação Postado originalmente por reinaldojr Ver Post

    Essa é a minha idéia, se gostar, posta aí que monto a configuração pra vc...Valeu?!

    Abraços,

    Reinaldo.

    Fala ae Reinaldo, blza cara!

    Aqui, se vc tá falando, tá feito! Posta aí pra nós o procedimento. Vamos fazer o melhor para que tudo saia praticamente perfeito!

    No entando, mesmo assim, gostaria depois que vc desse uma pincelada no que se diz respeito a colocar também ip fixo no mikrotik se o adsl continuasse com router. (isso será se de repente agente mudar para link satélite.) Aí não tem para onde fugir né? Tem que configurar os ips para a placa que receberá o link de internet.

    Mas... vamos ao que interessa... me passa o que será o procedimento à sua maneira.

    Valeu amigo!!!

  4. #4

    Padrão

    então vamos lá.. colocar a mão na massa...rsrs

    1a. Parte: Colocar o Mikrotik como Client PPPOE pra receber IP da Operadora.
    --------------------------------------------------------------
    Levando em consideração que vc vai usar a ether1 conectada ao modem ADSL.

    a) Transforma seu modem ADSL em Bridge.

    b) Acesse seu mikrotik via winbox e no menu lateral clique em IP -> DHCP Client

    c) Clique no botão "+" escolha a Interface "ether1" e clique em ok.

    Opcional: via console: /ip dhcp-client add interface=ether1 disabled=no

    d) No menu lateral clica em Interfaces, clica no "+" e escolhe PPPOE Client.

    e) Na Aba General, ajuste o MTU para o da sua operadora, normalmente em se tratando de ADSL é 1492 e na aba DialOut coloque o seu usuario e a sua password e marque a caixa "User Peer DNS" e clique em Apply.

    Opcional: Via console: / interface pppoe-client
    add interface=ether1 user="[email protected]" password="1234" \
    add-default-route=yes use-peer-dns=yes disabled=no

    f) Caso queira monitar pra ver se está conectado, verifique pelo Winbox na Aba Status ou pela console digite:

    /interface pppoe-client
    monitor pppoe-out1

    Obs: Nessa primeira Parte chamo a atenção para o MTU ele é muito importante e interfere principalmente em programas como messengers, chat e p2p... ele deve ser ajustado de acordo com a Operadora mas se no seu caso é ADSL o padrão 1492 deve ser suficiente.

    Primeira Parte Concluída.

    2a.Parte) Colocar IP na Interface dos clientes,Habilitar NAT, DHCP Server e DNS.

    a) No WInbox clique no menu lateral em IP -> Address, clica no botão "+" , em Address você coloca 10.0.0.254/24 e em interface vc escolher ether2 e clica em apply.

    Opicional: Via console: /ip address add address=10.0.0.254/24 interface=ether2

    b) No Winbox clique no Menu lateral em IP -> Firewall, e na aba NAT clique no botão "+" Na aba general, no campo "Chain:" escolha "srcnat" e no campo "Src Address:" digite: 10.0.0.0/24. Na aba Action no campo "Action:" escolha "Masquerade" e clique em Apply.

    Opicional: Via Console: /ip firewall nat add chain=srcnat src-address=10.0.0.0/24 action=masquerade

    c) No Winbox, no menu lateral clique em IP-> DHCP Server, clique no botão setup, escolha a interface ether2 e clique em Nex nas telas seguintes, observando as opções que já devem vir corretas, com excessão dos DNS's que vc deve informar os seus.

    Opicional: Via Console: /ip dhcp-server setup

    d) No Winbox, no meu Lateral, clique em IP->DNS , clique em Settings e em Primary DNS e Secondary DNS coloque os servidores de DNS da sua operadora e marque a caixa Allow Remote Requests.

    Bom, acho que a parte do AP vc faz aí... rsrs , lembrando de colocar ele pra pegar ip automático ou colocar com aquele IP que vc sugeriu: 10.0.0.1 , mascara 255.255.255.0 com o gateway 10.4.23.254.

    Pronto meu amigo... acho que não esqueci nda... segue os passos e verifica se faltou alguma coisa, qualquer novidade posta o resultado pra gente analisar.

    Abraços...

    Reinaldo.



  5. #5

    Smile

    Citação Postado originalmente por reinaldojr Ver Post

    Bom, acho que a parte do AP vc faz aí... rsrs , lembrando de colocar ele pra pegar ip automático ou colocar com aquele IP que vc sugeriu: 10.0.0.1 , mascara 255.255.255.0 com o gateway 10.4.23.254.
    Valeu amigão,

    já configurei tudo aqui, mas não há como testar agora, pois são 1:39am, e não estou onde há o link de internet. Mas acredito que dará tudo certo.

    Só não entendi a sua citação acima. Pq o gateway do AP vai ser 10.4.23.254 ao invés de ser o do mikrotik 10.0.0.254 ??

    No mais, ficou muito bem esclarecido, e com certeza não somente para mim, mas para vários outros usuários, este post vai ser 10 !!!!!!!

    Abraço Reinaldo.

    ps. posta aí o seu msn .

  6. #6

    Padrão

    vixeee... foi mesmo, eu troquei a faixa de ip...rsrsrs ... eh que pra mim aqui eu uso 10.4.23.x , ai na hora de escrever a sua eu troquei... força do hábito...kkkkk , mas é 10.0.0.254 mesmo... desculpa aí...

    abração...

    Reinaldo
    MSN: [email protected]



  7. #7

    Exclamation

    Reinaldo,

    Ocorre o seguinte, o modem está conectado mas não consigo navegar pelo mikrotik.

    Os ips foram distribuidos automaticamente por dhcp na placa de rede que liga ao AP, tudo ok, mas não navega.

    Fiz o seguinte, liguei o cabo que irá para o AP direto em um computador para testar e mesmo assim não está navegando, recebe os ips belezinha, mas não navega e é certeza que o modem está conectado.

    Aguardo...
    abraço

  8. #8

    Padrão

    verifique se o client-DHCP está ativo mesmo e se seu modem tah passando ip a placa do Mikrotik... isso é fundamental pra funcionar...

    vai pela console e digita:

    [[email protected]]ip dhcp-client
    [[email protected]]ip dhcp-client> print detail

    Flags: X - disabled, I - invalid
    0 interface=eth1-adsl add-default-route=yes use-peer-dns=yes
    use-peer-ntp=yes status=bound address="faixa dhcpd do seu modem"
    gateway="ip do seu modem" dhcp-server="ip do seu modem" primary-dns=80.232.169.11
    secondary-dns=195.122.1.59 expires-after=5h5m46s

    Deverá aparecever algo como o resultado acima...

    Qualquer coisa, posta aí...

    Reinaldo.



  9. #9

    Thumbs up Aleluia !!!

    Com a paciencia tamanha do nosso amigo Reinaldo, conseguimos finalizar o processo de configuração do MikroTik.

    Os problemas aos quais enfrentamos, estavam ligados às Rotas de ips, onde excluimos as mesmas e atualizamos reiniciando o modem adsl e o MikroTik, e sem fala que em interfaces deixe nas propriedades General > ARP > Enable.

    É isso aí galera, qualquer coisa, postem um novo tópico pq agora sou mais um na área para auxiliar vcs!!!!

    DEIXO O MEU
    O B R I G A D O ! ! !

    ao meu novo amigo Reinaldo.

    Marioth

  10. #10

    Exclamation ola

    Prezado reinado e Mario obsevando as pergunta e repostas resolvi tirar umas duvidas.
    Tenho um link adsl speed funcionado em minha casa , e estou apreparando 2 mikrotk para serem estalados em outra regiao, mas usaram tambem ads pppe.
    Ja segui os tutorial passo a passo aqui do forun em testes aqui em minha casa mas nao consigo fazer passar adsl,.
    A infraestrutura da rede seria assim, tenho um mode speedtouch fornecido pela telefonica, mas nao tem como transformar ele em bridigi como o reinaldo citou assima.
    !- o mktk principal que recebe adsl via modem e funcionara como servidor, com dois cartões um em 5.8 mandando o sinal com antena de disco para uma regiao rural, onde avera um segundo mktk, e outro cartao em 2.4 transmitindo local com um omini.
    2- o segundo mktk na area rural recebendo com um cartao em 5.8 e outros quatros repetindo em 2.4 com antenas setorial.
    Eu Ficaria muito grato se os senhores me ajudace com um passo a paso sobre esta infra-estrura.
    Desde Ja meus agradecimentos.
    Att. Silvestre



  11. #11

    Padrão

    boa tarde silvestre339, seguinte...vc ja fez alguma configuração no mk principal?, conceguiu pingar pra fora de dentro do mk?, tentou resetar o speedtoush e sem fazer mais nada ligar ele no mk pra ver se fica como bridgge? me passas essas informações que eu tento te dar uma ajuda....tbm sou iniciante...mas to com meu server funcionando e tenho um speedtoush em bridgge.....

  12. #12

    Padrão

    e aí silvestre.. blza?!... bem cara, quanto a tua pergunta, acho que entendi o que quer fazer, porém, não compreendi pq o teu modem não funciona em bridge?!.. pq até hoje todas as operadoras que eu vi trabalhar com PPPOE, podem trabalhar com os modens em bridge. Estou insistindo nisso, pq acho fundamental para um bom funcionamento do teu sistema, que o mikrotik servidor receba o ip válido da operadora, pq assim ele vai fazer o NAT para sua rede e dessa forma você poderá explorar mais os recursos do teu mikrotik, como o firewall, pppoe, hotspot, proxy transparente, entre outros.

    O Mikrotik é uma ferramenta muito poderosa, mas de nda adianta todos os seus recursos se ele tiver depois dele um modem roteado, fazendo outra NAT, e travando todas as suas regras. Não sei se compreendeu, espero que sim.

    Mas de qualquer forma vou postar mais tarde o passo-a-passo para seu exemplo, levando em consideração que o seu modem estará em bridge, blza?!

    abraço...

    Reinaldo.
    Última edição por reinaldojr; 11-11-2007 às 01:01.



  13. #13

    Padrão

    como o amigo anderson descreveu silvestre, acho que vc consegue sim configurar seu modem como bridge, então sendo assim, vamos para o primeiro passo:

    a. Dê um reset no teu modem e conecte ele diretamente ao te mikrotik.
    b. Configure o PPPOE Client na interface que está conectada ao modem. Ex:

    Levando em consideração que a interface conectada ao modem seja a ether0:

    - Acesse seu mikrotik via winbox e no menu lateral clique em IP -> DHCP Client
    - Clique no botão "+" escolha a Interface "ether0" e clique em ok.
    - No menu lateral clica em Interfaces, clica no "+" e escolhe PPPOE Client.
    - Na Aba General, ajuste o MTU para o da sua operadora, normalmente em se
    tratando de ADSL é 1492 e selecione a interface ether0. Na aba DialOut
    coloque o seu usuario e a sua password e marque a caixa "User Peer DNS" e
    clique em Apply.

    Se preferir usar a console: / interface pppoe-client
    add interface=ether0 user="[email protected]" password="1234" \
    add-default-route=yes use-peer-dns=yes disabled=no

    Caso queira monitar pra ver se está conectado, verifique pelo Winbox na Aba
    Status ou pela console digite:

    /interface pppoe-client
    monitor pppoe-out1

    Pronto!!.. se estiver "Connected" vc já vai poder pingar para fora da sua rede pelo Mikrotik e, sendo assim, podemos passar para o segundo passo.

    No 2o. Passo levarei em consideração que vc vai ter um Ponto-a-Ponto em 5.8Ghz na parábola e um Multi-Ponto em 2.4Ghz na Omni e que ambos não farão parte de uma bridge, ou seja, tudo será roteado, pois tratam-se de redes diferentes. ok?!

    a) Colocar IP na interface 5.8Ghz:
    - No menu lateral, acesse a Aba IP e depois Address. Clique no botão "+" ,
    coloque o IP: 192.168.0.254/24 e escolha a interface 5.8Ghz. Ex: wlan2.
    Clique em OK.
    - No menu lateral clique em Wireless e dê 2 cliques na sua interface 5.8Ghz.
    Como o seu Link vai do servidor para o 2o. Mikrotik e nós estamos
    configurando o Servidor, então na Aba Wireless coloque a opção MODE: como
    BRIDGE (o modo Bridge funciona semelhante ao AP Bridge, porém só permite
    a conexão de 1 Station , ou seja, o outro lado, fechando o Ponto-a-Ponto). No
    campo SSID, coloque o da sua prefetencia: Ex: Enlace1. Na opção Band
    escolha 5GHZ e em Frequency: escolha um canal, o melhor canal vai depender
    do espectro da tua área, mas coloca o 5180, se n ficar bom, vc testa outros.
    b) Colocar IP na interface 2.4Ghz:
    - No menu lateral, acesse a Aba IP e depois Address. Clique no botão "+" ,
    coloque o IP: 10.10.10.254/24 e escolha a interface 2.4Ghz. Ex: wlan1.
    Clique em OK.
    - No menu lateral clique em Wireless e dê 2 cliques na sua interface 2.4Ghz.
    Na Aba Wireless coloque a opção MODE: como AP BRIDGE . No campo SSID,
    coloque o da sua prefetencia: Ex: SilvestreNET. Na opção Band
    escolha 2.4GHz-B (Apesar de só ir até 11mbps, aqui na minha região eu
    prefiro trabalhar apenas em "B", vc pode usar "B/G" se quiser e ir até
    54mbps.) e em Frequency: escolha um canal, o melhor canal tbm vai
    depender do espectro da tua área, mas coloca o 2412 (Canal 1), se n ficar
    bom, vc testa outros.

    Bom, por enquanto o lado servidor tah pronto pra fechar o enlace e atender
    os clientes. Vou dormir agora, amanha posto a conf do outro Mikrotik,
    acho que o que tem aí já da pra vc se destrair um pouco..rsrsrrs

    Abraços!!!

    Reinaldo.

  14. #14

    Smile Oi

    Estou começando agora com mikrotik e gostaria de ajuda para configurar o mk para fazer distribuir a internet para meus aps que estão na torre. Como eu faço isso?



  15. #15

    Padrão

    amigão....tem um passo a passo que te encina direitinho como fazer...mas se tiver dificuldades, passe mais informações que podemos te ajudar....tipo como vc recebe a internet e outras coisas, faixa de ip dos cliente etc....

  16. #16

    Padrão

    olá gente, fiquei muito esclarecido com respeito a todas as explicações, mas na minha rede caseira diga-se da passagem com apenas 16 pcs conectados usando velox 1mb, e com o modem roteado, como nunca consegui levantar o modem em modo bridge porque o mesmo sempre trava, eu uso outro modem roteado na ponta externa do mikrotik, porem pra não haver esse problema de outro nat, fiz um dmz no ip do mikrotik, o que satisfez toda a minha necessidade. mas pra registro vou tentar mais 1 vez fazer com bridge. obrigado.