+ Responder ao Tópico



  1. #1

    Padrão Servidor proxy + Mikrotik

    Bom dia amigos do fórum,

    Eu tenho um pequeno provedor e depois de estudar possíveis melhoramentos para a qualidade de nosso serviço, ressolvi instalar um servidor proxy em minha rede. Para configurar o MK eu segui o tutorial aki do fórum e implementei umas regras para redirecionar todo o trafego para o servidor squid que roda o proxy. Porém no momento que eu habilito o proxy tudo para de funcionar já fiz uns testes mas nada deu certo. Procurei aki no fórum e infelizmente nao achei o que queria. Se alguém puder me ajudar ficarei eternamente grato.

    Abaixo seguem as regras.::

    add chain=dstnat in-interface=Clientes protocol=tcp dst-port=80 \
    packet-mark=!semproxy action=dst-nat to-addresses=192.168.1.200 \
    to-ports=3128 comment="" disabled=no

    / ip web-proxy
    set enabled=yes src-address=0.0.0.0 port=3128 hostname="proxy" \
    transparent-proxy=yes parent-proxy=192.168.1.200:3128 \
    cache-administrator="webmaster" max-object-size=4096KiB cache-drive=system \
    max-cache-size=unlimited max-ram-cache-size=unlimited

    O ip do squid é 192.168.1.200, ele esta ligado ao servidor MK na ether1 ( backup).]

    Conto com a colaboração dos amigos.

    Obrigado.

  2. #2

    Padrão

    Se alguém souber de algum outro tópico com o mesmo problema que eu puder indicar. Eu to passando o amior aperto aki. Quando eu habilito o proxy nao navega nada....

    Grato



  3. #3
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Opa... tem um erro ai... se vc habilita o web-proxy do MT, na regra de NAT tem que faze-la para ele mesmo ou seja, usar o redirect to ports PORTA.

    Se não pretende usar o web-proxy do MT, apenas deixe a regra de dst-nat como está e pronto.

  4. #4

    Padrão

    Opa Sérgio, eu fiz o que vc me indicou mas mesmo assim nao navega.
    Dá uma olhada por favor:

    / ip firewall nat
    add chain=dstnat in-interface=Clientes protocol=tcp dst-port=80 \
    packet-mark=!semproxy action=redirect to-ports=3128 comment="" \
    disabled=no


    Obrigado pela anteção.



  5. #5
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Citação Postado originalmente por Pantanero2006 Ver Post
    Opa Sérgio, eu fiz o que vc me indicou mas mesmo assim nao navega.
    Dá uma olhada por favor:

    / ip firewall nat
    add chain=dstnat in-interface=Clientes protocol=tcp dst-port=80 \
    packet-mark=!semproxy action=redirect to-ports=3128 comment="" \
    disabled=no


    Obrigado pela anteção.
    Esse lance de packte mark... não precisa disso... cria uma address list e adiciona os IPs que não quer no proxy e na regra de nat em advanced usa a address list... creio que o erro esteja ai... pois o resto está ok (desde que o outro proxy esteja ok).

  6. #6

    Padrão

    Sérgio eu retirei a regra que marcava os pacotes, mas mesmo assim não roda quando eu habilito o proxy. To começando a achar que tem algo errado no servidor que ta com o squid instalado.



  7. #7
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Citação Postado originalmente por Pantanero2006 Ver Post
    Sérgio eu retirei a regra que marcava os pacotes, mas mesmo assim não roda quando eu habilito o proxy. To começando a achar que tem algo errado no servidor que ta com o squid instalado.
    Remova o Parent e a porta do mesmo e veja se funciona. Se funcionar é o squid o problema.

  8. #8

    Padrão

    Eu retirei e funcionou pelo proxy do MK, fica super lento mas funciona. Bem, agora ta provado que o problema é o squid. Eu já fucei em tudo quanto é fórum, tutorial e aparentemente tá igual ao que eles recomendam. O que será que pode estar errado? Tem algum " pulo do gato" que está faltando? To ficando até careca por causa disso!



  9. #9

    Padrão

    Estou com o mesmo problema do colega, e também ja refiz e fiz a configuração do proxy mas não funciona, qual seria o detalhe que ta faltando para funcionar

  10. #10

    Padrão

    Resolvi meu problema instalando debian e configurando no parent proxy,
    agora meu proxy squid ta rodando junto com o mk.



  11. #11

    Padrão

    oi amigo jasonlinux posta ai como vc fez essas configuracoes no squid e no mikrotik estou com o mesmo problema. Obrigado