Página 2 de 2 PrimeiroPrimeiro 12
+ Responder ao Tópico



  1. Descobri pq nao roda...

    Não tenho instalado as ferramentas avançadas..

    Como faço para instalar somente elas?

  2. Olá, galera eu sofri até descobrir este aki !!!

    1º vai no site faça o cadastro link Enhanced Dynamic DNS Solutions

    system/script
    adiciona pelo winbox

    /tool dns-update name=DOMINIO ESCOLHIDO.changeip.org address=127.0.0.255 key-name=USUARIO DO SITE key="SENHA DO SITE"

    PRONTO SO CRIAR O AGENDAMENTO RODAR O SCRIPT

    system / schedule



  3. Funcionou !!!!!!!!!!!!!!!!!!!!!

    O script abaixo roda o domínio do site Enhanced Dynamic DNS Solutions .

    :global ddnsuser "YOURUSERID"
    :global ddnspass "YOURPASSWORD"
    :global ddnshost "YOUR.HOST.NAME.HERE"

    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )

    :foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={
    :if ([:typeof [/ip route get $int routing-mark ]] = nothing ) do={
    :global ddnsinterface [/ip route get $int interface]
    }
    }

    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]

    :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip 0.0.0.0/0 }

    :if ([ :typeof $ddnsip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")

    } else={

    :if ($ddnsip != $ddnslastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip

    } else={

    }

    }



    É somente criar o script e depois o agendamento da execução no Scheduler:

    /system script run "NOME DADO AO SCRIPT"

    Falou galera, agora é só curtir o acesso remoto a partir de uma rede externa !!!






Tópicos Similares

  1. Respostas: 4
    Último Post: 09-06-2015, 07:44
  2. DynDns não funciona
    Por joseluiz no fórum Redes
    Respostas: 2
    Último Post: 06-03-2014, 00:00
  3. Script de Logon nao funciona em estações 98
    Por fredera no fórum Servidores de Rede
    Respostas: 7
    Último Post: 22-03-2005, 08:50
  4. Perl e Apache - Script nao funciona
    Por frpaes no fórum Servidores de Rede
    Respostas: 0
    Último Post: 21-01-2005, 11:22
  5. NAT nao funciona (erro iptables ao rodar o script do nat)
    Por lgmferras no fórum Servidores de Rede
    Respostas: 10
    Último Post: 23-11-2004, 13:53

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L